summaryrefslogtreecommitdiffstats
path: root/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-01-02 16:19:49 -0500
committerScott Murray <scott.murray@konsulko.com>2020-01-03 15:53:03 +0000
commit93483ec3893c1060732a996b24af5073045c042d (patch)
tree09d41b535e80a0cf2f618cba5799c448b321299d /meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service_git.bb
parent0f1d405101e1419474de80658535dc34dc8d8b16 (diff)
alexa-voiceagent-service: Add patch to fix event argument JSON
In several places in the alexa-voiceagent-service code, strings containing JSON document fragments are put whole into a json-c string object which is added to the event argument json_object, rather than being properly added as built up json-c object hierarchies. The result is an embedded JSON document in a string with extra escaping, which is not usable on the receiving side without knowing that part of the event object effectively needs to be run through a JSON parser to be usable. This is contrary to the voiceagent event documentation and inconvenient for client implementors, so fix it by tokenizing the internal JSON payload string into a json_object tree and passing that as the event argument where necessary. Note that it is ATM not clear if all affected event argument payloads are correct, e.g. LocalMediaSource may need some more work. Bug-AGL: SPEC-3084 Change-Id: I77c97d7eb241d6ccbd98fb379b88336494ce12e9 Signed-off-by: Scott Murray <scott.murray@konsulko.com> (cherry picked from commit 3fdec9d7e81cff04fd2aa38e25872da7c431b769)
Diffstat (limited to 'meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service_git.bb')
-rw-r--r--meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service_git.bb b/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service_git.bb
index 2ddfaa4b..3fedb26b 100644
--- a/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service_git.bb
+++ b/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service_git.bb
@@ -27,6 +27,7 @@ SRC_URI = "git://github.com/alexa/alexa-auto-sdk.git;protocol=https;branch=2.0 \
file://0003-update-audio-device-configuration.patch \
file://0004-update-config-and-database-paths.patch \
file://0005-fix-segmentation-fault-for-release-build-mode.patch \
+ file://0006-fix-event-argument-json.patch \
"
SRCREV = "86916d2d8c1702a8be3c88a9012ca56583bcc0c8"