summaryrefslogtreecommitdiffstats
path: root/meta-speech-framework/meta-aac/recipes-apis
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-08-20 13:57:33 -0400
committerScott Murray <scott.murray@konsulko.com>2021-11-17 14:19:36 -0500
commita8dbd14daaac8b5c52326262dbc43975836cc0df (patch)
treee52e3eaaa084ddf2d3fb44158cd0f2d5c9140178 /meta-speech-framework/meta-aac/recipes-apis
parentf9dcc4101b86d14f583319786286a72b63cbbc98 (diff)
Convert to new override syntax
This is effectively a manual cherry-pick of commit: 37d3b1b316470fdcfebc59d5522bfbfefc025ff6 from the master branch with additional review and fixups. The intent of these changes is to minimize the effort to backport fixes from the master branch, which has been updated in preparation for the switch to the next Yocto LTS release in early 2022. Bug-AGL: SPEC-4144 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ic649d942ac043edc52976a3d4190590bb1c125e7
Diffstat (limited to 'meta-speech-framework/meta-aac/recipes-apis')
-rw-r--r--meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voice-high-config_1.0.bb2
-rw-r--r--meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb2
-rw-r--r--meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service_git.bb6
3 files changed, 5 insertions, 5 deletions
diff --git a/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voice-high-config_1.0.bb b/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voice-high-config_1.0.bb
index 736a7ce5..6b0203a9 100644
--- a/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voice-high-config_1.0.bb
+++ b/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voice-high-config_1.0.bb
@@ -16,5 +16,5 @@ do_install () {
install -D -m 644 ${WORKDIR}/voice-high.json ${D}${sysconfdir}/xdg/AGL/voice-high.json
}
-RPROVIDES_${PN} += "virtual/voice-high-config"
+RPROVIDES:${PN} += "virtual/voice-high-config"
diff --git a/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb b/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb
index a16ad182..13d259b8 100644
--- a/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb
+++ b/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb
@@ -48,4 +48,4 @@ do_install () {
install -D -m 644 ${WORKDIR}/AlexaAutoCoreEngineConfig.json ${D}${sysconfdir}/xdg/AGL/AlexaAutoCoreEngineConfig.json
}
-RPROVIDES_${PN} += "virtual/alexa-voiceagent-config"
+RPROVIDES:${PN} += "virtual/alexa-voiceagent-config"
diff --git a/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service_git.bb b/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service_git.bb
index 580b141c..c08377cd 100644
--- a/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service_git.bb
+++ b/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service_git.bb
@@ -38,17 +38,17 @@ EXTRA_OECMAKE += "-DAAC_HOME=${RECIPE_SYSROOT}/${AAC_PREFIX}"
ALEXA_WAKEWORD ??= "false"
-do_install_append() {
+do_install:append() {
install -D -m 0644 ${WORKDIR}/alexa.json ${D}${sysconfdir}/xdg/AGL/voiceagents/alexa.json
}
PACKAGES =+ "${PN}-conf"
-FILES_${PN}-conf = "${sysconfdir}/xdg/AGL/voiceagents/*"
+FILES:${PN}-conf = "${sysconfdir}/xdg/AGL/voiceagents/*"
# NOTE: curl and opus are from the base SDK libraries, sqlite3 from the
# core module
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
libcurl \
libopus \
libsqlite3 \