summaryrefslogtreecommitdiffstats
path: root/meta-speech-framework/meta-aac/recipes-platform/packagegroups/packagegroup-agl-voiceagent-alexa.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-04-28 21:12:10 +0000
committerScott Murray <scott.murray@konsulko.com>2020-05-08 14:43:13 -0400
commitba3c28a56b99e5628041d772b4faa36553846c21 (patch)
treef107c33d917dadaf399ec5c590fe17a3e15f4ad7 /meta-speech-framework/meta-aac/recipes-platform/packagegroups/packagegroup-agl-voiceagent-alexa.bb
parent5c096a9bc3e336bff3fb9d678082ce8805154b22 (diff)
Widget packaging rework
Changes include: - Created new packagegroup-agl-speech-services packagegroup and associated test and devel packagegroups to replace previous extending of packagegroup-agl-ivi-services via bbappend. This makes it simpler to create the test/devel packagegroups in packagegroup-agl-ivi-services, and is cleaner with respect to the packagefeed since it avoids modifying a packagegroup in another layer. - Extend the agl-devel-wgt and agl-test-wgt FEATURE_PACKAGES variables as necessary to add the required corresponding widget packagegroups. Bug-AGL: SPEC-3300 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I17b61f3e4549a7baa8ac1a6f9c857e2f78bb6448
Diffstat (limited to 'meta-speech-framework/meta-aac/recipes-platform/packagegroups/packagegroup-agl-voiceagent-alexa.bb')
-rw-r--r--meta-speech-framework/meta-aac/recipes-platform/packagegroups/packagegroup-agl-voiceagent-alexa.bb20
1 files changed, 14 insertions, 6 deletions
diff --git a/meta-speech-framework/meta-aac/recipes-platform/packagegroups/packagegroup-agl-voiceagent-alexa.bb b/meta-speech-framework/meta-aac/recipes-platform/packagegroups/packagegroup-agl-voiceagent-alexa.bb
index 5f38e7ef..6118dbf2 100644
--- a/meta-speech-framework/meta-aac/recipes-platform/packagegroups/packagegroup-agl-voiceagent-alexa.bb
+++ b/meta-speech-framework/meta-aac/recipes-platform/packagegroups/packagegroup-agl-voiceagent-alexa.bb
@@ -5,11 +5,19 @@ LICENSE = "MIT"
inherit packagegroup
+ALLOW_EMPTY_${PN} = "1"
+
+PROVIDES = "${PACKAGES}"
PACKAGES = "\
- packagegroup-agl-voiceagent-alexa \
-"
+ packagegroup-agl-voiceagent-alexa \
+ packagegroup-agl-voiceagent-alexa-test \
+ packagegroup-agl-voiceagent-alexa-devel \
+ "
+
+RDEPENDS_${PN} = " \
+ alexa-voiceagent-service \
+ "
-RDEPENDS_${PN} += " \
- alexa-voiceagent-service \
- ${@bb.utils.contains("DISTRO_FEATURES", "agl-demo-preload", "virtual/alexa-voiceagent-config", "",d)} \
-"
+# Empty for now, no test/dbg/coverage widgets
+RDEPENDS_${PN}-test = ""
+RDEPENDS_${PN}-devel = ""