aboutsummaryrefslogtreecommitdiffstats
path: root/meta-speech-framework/recipes-apis/agl-service-voice-high/default-voice-high-config_1.0.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-10-15 20:37:40 -0400
committerScott Murray <scott.murray@konsulko.com>2019-12-20 15:44:08 -0500
commit51b5717e14a9286dc335f601f2830827625f1d67 (patch)
tree6dc9049ef892ecdb9adc4bf0dc16dfdeb5f05e9e /meta-speech-framework/recipes-apis/agl-service-voice-high/default-voice-high-config_1.0.bb
parent3d6edba9fc888d4c6a02453dc44c047a665ec59c (diff)
meta-speech-framework: rework voiceagent configuration
After agl-service-voice-high rework to make the voiceagent(s) used externally configurable, replace the previous virtual/voiceagent PREFERRED_RPROVIDER scheme with a virtual/voice-high-config that just selects the appropriate configuration package based on the specified feature. If agl-speech-framework is specified on its own, a default configuration file specifying no default voiceagent will be installed. If agl-voiceagent-alexa is specified, the default configuration will specify the Alexa voiceagent as the default. Recipes have been added for the new configuration file packages, and the alexa-voiceagent-service recipe has been tweaked to create a package with the Alexa per-voiceagent configuration file and add it as a dependency. Bug-AGL: SPEC-2898 Change-Id: I3ea2534b0f55aefa0226ef09b6ffde468feef2fe Signed-off-by: Scott Murray <scott.murray@konsulko.com> (cherry picked from commit a765be206e7379885c8df72f4ff89b6e0bf14e1e)
Diffstat (limited to 'meta-speech-framework/recipes-apis/agl-service-voice-high/default-voice-high-config_1.0.bb')
-rw-r--r--meta-speech-framework/recipes-apis/agl-service-voice-high/default-voice-high-config_1.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-speech-framework/recipes-apis/agl-service-voice-high/default-voice-high-config_1.0.bb b/meta-speech-framework/recipes-apis/agl-service-voice-high/default-voice-high-config_1.0.bb
new file mode 100644
index 00000000..b015dd5d
--- /dev/null
+++ b/meta-speech-framework/recipes-apis/agl-service-voice-high/default-voice-high-config_1.0.bb
@@ -0,0 +1,20 @@
+SUMMARY = "High level voice service binding default voiceagent configuration"
+DESCRIPTION = "Default voiceagent JSON configuration file for agl-service-voice-high binding"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/agl-service-voice-high"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = "file://voice-high.json"
+
+inherit allarch
+
+do_compile[noexec] = "1"
+
+do_install () {
+ install -D -m 644 ${WORKDIR}/voice-high.json ${D}${sysconfdir}/xdg/AGL/voice-high.json
+}
+
+RPROVIDES_${PN} += "virtual/voice-high-config"
+