summaryrefslogtreecommitdiffstats
path: root/meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/uhmi-config-sender.bb
diff options
context:
space:
mode:
authorKenta <murakami.kenta002@jp.panasonic.com>2025-01-15 17:22:25 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2025-01-17 08:58:19 +0000
commit5bf650925c8d8d6cf77139a2a2deee74e2b5cfe7 (patch)
tree53dd73e7085b6283f2d55f65e00d42036ea7d3ec /meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/uhmi-config-sender.bb
parentd81cbb24347f42be696984087846d29c67519be8 (diff)
Unified HMI: Preconfigured Images
A new preconfigured demo image for Unified HMI has been added. By building and launching the images for both the sender and receiver, and executing a few commands, you can display the application across two displays. It supports three boards: qemu-x86-64, raspberrypi4, and agl-refhw. Bug-AGL: SPEC-5321 Change-Id: I682f9eef6d1861e9ec2a7153dd8f3c42f1078a05 Signed-off-by: Kenta <murakami.kenta002@jp.panasonic.com>
Diffstat (limited to 'meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/uhmi-config-sender.bb')
-rw-r--r--meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/uhmi-config-sender.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/uhmi-config-sender.bb b/meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/uhmi-config-sender.bb
new file mode 100644
index 00000000..ee854d85
--- /dev/null
+++ b/meta-uhmi/meta-agl-uhmi-demo/recipes-config/uhmi-config/uhmi-config-sender.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Setting files for UHMI sender"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+SRC_URI = " \
+ file://app.json \
+ file://initial_vscreen.json \
+ file://wired-sender.config \
+ file://uhmi-ivi-wm.conf \
+"
+
+do_install() {
+ if [ ! -e ${D}/var/lib/connman/wired.config ]; then
+ install -d ${D}/var/lib/connman/
+ install -m 6444 ${WORKDIR}/wired-sender.config ${D}/var/lib/connman/wired.config
+ fi
+
+ install -d ${D}/var/local/uhmi-app/glmark2
+ install -m 644 ${WORKDIR}/app.json ${D}/var/local/uhmi-app/glmark2/
+ install -m 644 ${WORKDIR}/initial_vscreen.json ${D}/var/local/uhmi-app/glmark2/
+
+ install -d ${D}/etc/systemd/system/uhmi-ivi-wm.service.d/
+ install -m 0644 ${WORKDIR}/uhmi-ivi-wm.conf ${D}/etc/systemd/system/uhmi-ivi-wm.service.d/
+}
+
+FILES:${PN} += " \
+ /var/lib/connman/wired.config \
+ /var/local/uhmi-app/glmark2 \
+"