summaryrefslogtreecommitdiffstats
path: root/meta-uhmi/meta-agl-uhmi-demo/recipes-graphics/wayland
diff options
context:
space:
mode:
authorKenta <murakami.kenta002@jp.panasonic.com>2025-01-15 17:22:25 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2025-01-17 08:58:19 +0000
commit5bf650925c8d8d6cf77139a2a2deee74e2b5cfe7 (patch)
tree53dd73e7085b6283f2d55f65e00d42036ea7d3ec /meta-uhmi/meta-agl-uhmi-demo/recipes-graphics/wayland
parentd81cbb24347f42be696984087846d29c67519be8 (diff)
Unified HMI: Preconfigured Images
A new preconfigured demo image for Unified HMI has been added. By building and launching the images for both the sender and receiver, and executing a few commands, you can display the application across two displays. It supports three boards: qemu-x86-64, raspberrypi4, and agl-refhw. Bug-AGL: SPEC-5321 Change-Id: I682f9eef6d1861e9ec2a7153dd8f3c42f1078a05 Signed-off-by: Kenta <murakami.kenta002@jp.panasonic.com>
Diffstat (limited to 'meta-uhmi/meta-agl-uhmi-demo/recipes-graphics/wayland')
-rw-r--r--meta-uhmi/meta-agl-uhmi-demo/recipes-graphics/wayland/files/weston_ivi-shell.ini50
-rw-r--r--meta-uhmi/meta-agl-uhmi-demo/recipes-graphics/wayland/weston-init.bbappend13
2 files changed, 63 insertions, 0 deletions
diff --git a/meta-uhmi/meta-agl-uhmi-demo/recipes-graphics/wayland/files/weston_ivi-shell.ini b/meta-uhmi/meta-agl-uhmi-demo/recipes-graphics/wayland/files/weston_ivi-shell.ini
new file mode 100644
index 00000000..5001d11e
--- /dev/null
+++ b/meta-uhmi/meta-agl-uhmi-demo/recipes-graphics/wayland/files/weston_ivi-shell.ini
@@ -0,0 +1,50 @@
+[core]
+shell=ivi-shell.so
+modules=ivi-controller.so
+require-input=false
+
+[output]
+name=HDMI-A-1
+mode=1920x1080@60
+
+[output]
+name=HDMI-A-2
+mode=1920x1080@60
+
+[output]
+name=HDMI-A-3
+mode=1920x1080@60
+
+[output]
+name=DSI-1
+mode=1920x1080@60
+
+[output]
+name=DSI-2
+mode=1920x1080@60
+
+[output]
+name=DP-1
+mode=1920x1080@60
+
+[output]
+name=Virtual-1
+mode=1920x1080
+
+[output]
+name=Virtual-2
+mode=1920x1080
+
+[output]
+name=VGA-1
+mode=1920x1080
+
+[output]
+name=VGA-2
+mode=1920x1080
+
+[ivi-shell]
+ivi-input-module=ivi-input-controller.so
+#ivi-client-name=/usr/bin/simple-weston-client
+bkgnd-surface-id=1000000
+bkgnd-color=0xFF000000
diff --git a/meta-uhmi/meta-agl-uhmi-demo/recipes-graphics/wayland/weston-init.bbappend b/meta-uhmi/meta-agl-uhmi-demo/recipes-graphics/wayland/weston-init.bbappend
new file mode 100644
index 00000000..1cc6091c
--- /dev/null
+++ b/meta-uhmi/meta-agl-uhmi-demo/recipes-graphics/wayland/weston-init.bbappend
@@ -0,0 +1,13 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
+
+WESTON_INIT_IVI_SHELL ?= "weston_ivi-shell.ini"
+
+SRC_URI:append = " \
+ file://${WESTON_INIT_IVI_SHELL} \
+"
+
+do_install:append () {
+ install -d ${D}/${sysconfdir}/xdg/weston
+ install -m 644 ${WORKDIR}/${WESTON_INIT_IVI_SHELL} ${D}/${sysconfdir}/xdg/weston/
+ ln -nfs ${sysconfdir}/xdg/weston/${WESTON_INIT_IVI_SHELL} ${D}/${sysconfdir}/xdg/weston/weston.ini
+}