summaryrefslogtreecommitdiffstats
path: root/meta-uhmi/meta-agl-uhmi-demo/recipes-platform
diff options
context:
space:
mode:
authorKenta <murakami.kenta002@jp.panasonic.com>2025-01-15 17:22:25 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2025-01-17 08:58:19 +0000
commit5bf650925c8d8d6cf77139a2a2deee74e2b5cfe7 (patch)
tree53dd73e7085b6283f2d55f65e00d42036ea7d3ec /meta-uhmi/meta-agl-uhmi-demo/recipes-platform
parentd81cbb24347f42be696984087846d29c67519be8 (diff)
Unified HMI: Preconfigured Images
A new preconfigured demo image for Unified HMI has been added. By building and launching the images for both the sender and receiver, and executing a few commands, you can display the application across two displays. It supports three boards: qemu-x86-64, raspberrypi4, and agl-refhw. Bug-AGL: SPEC-5321 Change-Id: I682f9eef6d1861e9ec2a7153dd8f3c42f1078a05 Signed-off-by: Kenta <murakami.kenta002@jp.panasonic.com>
Diffstat (limited to 'meta-uhmi/meta-agl-uhmi-demo/recipes-platform')
-rw-r--r--meta-uhmi/meta-agl-uhmi-demo/recipes-platform/images/agl-uhmi-demo-preconfigured-receiver.bb18
-rw-r--r--meta-uhmi/meta-agl-uhmi-demo/recipes-platform/images/agl-uhmi-demo-preconfigured-sender.bb19
2 files changed, 37 insertions, 0 deletions
diff --git a/meta-uhmi/meta-agl-uhmi-demo/recipes-platform/images/agl-uhmi-demo-preconfigured-receiver.bb b/meta-uhmi/meta-agl-uhmi-demo/recipes-platform/images/agl-uhmi-demo-preconfigured-receiver.bb
new file mode 100644
index 00000000..1e7de2c0
--- /dev/null
+++ b/meta-uhmi/meta-agl-uhmi-demo/recipes-platform/images/agl-uhmi-demo-preconfigured-receiver.bb
@@ -0,0 +1,18 @@
+SUMMARY = "AGL Unified HMI demo preconfigured weston receiver image"
+LICENSE = "MIT"
+
+DEPENDS = "uhmi-ivi-wm"
+
+require recipes-platform/images/agl-image-weston.bb
+
+IMAGE_FEATURES += "ssh-server-openssh"
+
+# Add packages for Unified HMI demo platform here
+IMAGE_INSTALL += " \
+ packagegroup-rvgpu \
+ packagegroup-ddfw \
+ uhmi-config-receiver \
+"
+
+UHMI_HOSTNAME ?= "agl-host1"
+require recipes-config/uhmi-config/set-hostname.inc
diff --git a/meta-uhmi/meta-agl-uhmi-demo/recipes-platform/images/agl-uhmi-demo-preconfigured-sender.bb b/meta-uhmi/meta-agl-uhmi-demo/recipes-platform/images/agl-uhmi-demo-preconfigured-sender.bb
new file mode 100644
index 00000000..5c9d6a2b
--- /dev/null
+++ b/meta-uhmi/meta-agl-uhmi-demo/recipes-platform/images/agl-uhmi-demo-preconfigured-sender.bb
@@ -0,0 +1,19 @@
+SUMMARY = "AGL Unified HMI demo preconfigured weston sender image"
+LICENSE = "MIT"
+
+DEPENDS = "uhmi-ivi-wm"
+
+require recipes-platform/images/agl-image-weston.bb
+
+IMAGE_FEATURES += "ssh-server-openssh"
+
+# Add packages for Unified HMI demo platform here
+IMAGE_INSTALL += " \
+ packagegroup-rvgpu \
+ packagegroup-ddfw \
+ uhmi-config-sender \
+ glmark2 \
+"
+
+UHMI_HOSTNAME ?= "agl-host0"
+require recipes-config/uhmi-config/set-hostname.inc