summaryrefslogtreecommitdiffstats
path: root/meta-uhmi/meta-rvgpu/recipes-graphics/mesa-virtio/mesa-virtio_20.3.5.bb
diff options
context:
space:
mode:
authorFumiya Kohzu <kohzu.fumiya@jp.panasonic.com>2023-11-30 13:28:56 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-12-12 11:08:46 +0000
commitdef59d5aa61099be03a81e5189014ffe23f222e5 (patch)
tree103e282318960731f0a6500e8ed42c8c6ad64e94 /meta-uhmi/meta-rvgpu/recipes-graphics/mesa-virtio/mesa-virtio_20.3.5.bb
parentb3b7c5dc302e856a432835708704f498b1728083 (diff)
UnifiedHMI: Update SRCREV for RVGPU and virtio-loopback-driver, and upgrade mesa-virtio.
- OSS RVGPU update: Support for xdg_shell. - OSS virtio-gpu-driver update: Simplify directory structure, not use cmake. - Recipe updates: 1, Update SRCREV for RVGPU. Since RVGPU now supports xdg_shell in OSS, the patch enabling xdg_shell has been removed. 2, Remove the agl-shell-desktop interface because it is planned to be phased out. 3, Upgrade the base mesa for mesa-virtio from 18.2.0 to 20.3.5. Remove patches that were used with mesa-18.2.0. We are exploring ways to run it with the newer mesa. 4, Update SRCREV for virtio-loopback-driver. 5, Update meta-data for patches of RVGPU and virtio-gpu-driver. The content of the patches remains unchanged. We are planning to support a gRPC protocol interface for RVGPU. Bug-AGL: SPEC-4898 Change-Id: Ie314f40687c92ef93258b8fdc817584586d20e25 Signed-off-by: Fumiya Kohzu <kohzu.fumiya@jp.panasonic.com>
Diffstat (limited to 'meta-uhmi/meta-rvgpu/recipes-graphics/mesa-virtio/mesa-virtio_20.3.5.bb')
-rw-r--r--meta-uhmi/meta-rvgpu/recipes-graphics/mesa-virtio/mesa-virtio_20.3.5.bb59
1 files changed, 59 insertions, 0 deletions
diff --git a/meta-uhmi/meta-rvgpu/recipes-graphics/mesa-virtio/mesa-virtio_20.3.5.bb b/meta-uhmi/meta-rvgpu/recipes-graphics/mesa-virtio/mesa-virtio_20.3.5.bb
new file mode 100644
index 00000000..9a0dab2f
--- /dev/null
+++ b/meta-uhmi/meta-rvgpu/recipes-graphics/mesa-virtio/mesa-virtio_20.3.5.bb
@@ -0,0 +1,59 @@
+SUMMARY = "Mesa library"
+SECTION = "graphics"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://docs/license.rst;md5=9aa1bc48c9826ad9fdb16661f6930496"
+
+
+DEPENDS = "expat makedepend-native flex-native bison-native libxml2-native zlib chrpath-replacement-native python3-mako-native gettext-native"
+DEPENDS:append = " libdrm wayland wayland-native wayland-protocols python3-native"
+
+SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz"
+
+SRC_URI[md5] = "224d7576618ef4dd8ac69f30b5b90b38"
+SRC_URI[sha256sum] = "909a72df63dfa3c0844ccf44a26ac028d148297ed333ab51560893923d7691ce"
+
+S = "${WORKDIR}/mesa-${PV}"
+
+RDEPENDS:${PN}:append = " libgcc wayland libdrm glibc libstdc++ zlib expat"
+
+inherit meson pkgconfig python3native gettext
+
+EXTRA_OEMESON = " \
+ -Dshared-glapi=true \
+ -Dgallium-opencl=disabled \
+ -Dglx-read-only-text=true \
+ -Dplatforms='wayland' \
+"
+
+EXTRA_OEMESON += " \
+ --prefix=/usr/lib/mesa-virtio \
+ --libdir=/usr/lib/mesa-virtio \
+ --sysconfdir=/etc/mesa-virtio \
+"
+
+EXTRA_OEMESON += " \
+ -Ddri-drivers='' \
+ -Dgallium-drivers='virgl,swrast' \
+ -Dglx=disabled \
+ -Dgles1=disabled \
+ -Dgles2=enabled \
+ -Degl=true \
+ -Dgbm=true \
+ -Dllvm=disabled \
+ -Dvulkan-drivers='[]' \
+"
+
+FILES:${PN} = " \
+ /usr/lib/mesa-virtio/* \
+ /etc/mesa-virtio/drirc \
+ /usr/share/mesa-virtio/* \
+"
+
+FILES:${PN}-dev += " \
+ /usr/lib/mesa-virtio/libglapi.so \
+ /usr/lib/mesa-virtio/libEGL.so \
+ /usr/lib/mesa-virtio/libgbm.so \
+ /usr/lib/mesa-virtio/libGLESv2.so \
+ /usr/lib/mesa-virtio/libGLESv1_CM.so \
+"