summaryrefslogtreecommitdiffstats
path: root/meta-uhmi/meta-rvgpu/recipes-kernel/virtio-loopback-driver/virtio-loopback-driver_git.bb
diff options
context:
space:
mode:
authorFumiya Kohzu <kohzu.fumiya@jp.panasonic.com>2023-11-30 13:28:56 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-12-12 11:08:46 +0000
commitdef59d5aa61099be03a81e5189014ffe23f222e5 (patch)
tree103e282318960731f0a6500e8ed42c8c6ad64e94 /meta-uhmi/meta-rvgpu/recipes-kernel/virtio-loopback-driver/virtio-loopback-driver_git.bb
parentb3b7c5dc302e856a432835708704f498b1728083 (diff)
UnifiedHMI: Update SRCREV for RVGPU and virtio-loopback-driver, and upgrade mesa-virtio.
- OSS RVGPU update: Support for xdg_shell. - OSS virtio-gpu-driver update: Simplify directory structure, not use cmake. - Recipe updates: 1, Update SRCREV for RVGPU. Since RVGPU now supports xdg_shell in OSS, the patch enabling xdg_shell has been removed. 2, Remove the agl-shell-desktop interface because it is planned to be phased out. 3, Upgrade the base mesa for mesa-virtio from 18.2.0 to 20.3.5. Remove patches that were used with mesa-18.2.0. We are exploring ways to run it with the newer mesa. 4, Update SRCREV for virtio-loopback-driver. 5, Update meta-data for patches of RVGPU and virtio-gpu-driver. The content of the patches remains unchanged. We are planning to support a gRPC protocol interface for RVGPU. Bug-AGL: SPEC-4898 Change-Id: Ie314f40687c92ef93258b8fdc817584586d20e25 Signed-off-by: Fumiya Kohzu <kohzu.fumiya@jp.panasonic.com>
Diffstat (limited to 'meta-uhmi/meta-rvgpu/recipes-kernel/virtio-loopback-driver/virtio-loopback-driver_git.bb')
-rw-r--r--meta-uhmi/meta-rvgpu/recipes-kernel/virtio-loopback-driver/virtio-loopback-driver_git.bb21
1 files changed, 6 insertions, 15 deletions
diff --git a/meta-uhmi/meta-rvgpu/recipes-kernel/virtio-loopback-driver/virtio-loopback-driver_git.bb b/meta-uhmi/meta-rvgpu/recipes-kernel/virtio-loopback-driver/virtio-loopback-driver_git.bb
index 687c33dd..7a203767 100644
--- a/meta-uhmi/meta-rvgpu/recipes-kernel/virtio-loopback-driver/virtio-loopback-driver_git.bb
+++ b/meta-uhmi/meta-rvgpu/recipes-kernel/virtio-loopback-driver/virtio-loopback-driver_git.bb
@@ -7,24 +7,20 @@ require virtio-loopback-driver.inc
SRC_URI:append = " \
file://0001-Remove-card_index-option.patch \
- file://Makefile.driver \
- file://Kbuild \
"
S = "${WORKDIR}/git"
-EXTRA_OEMAKE = "KDIR=${STAGING_KERNEL_BUILDDIR}"
-MODULES_MODULE_SYMVERS_LOCATION = "src"
inherit module
-do_compile:prepend() {
- cp ${WORKDIR}/Makefile.driver ${S}/Makefile
- cp ${WORKDIR}/Kbuild ${S}/src/
-}
+EXTRA_OEMAKE = "M=${S} -C ${STAGING_KERNEL_DIR}"
do_install:append() {
- install -d ${D}${PKG_CONFIG_SYSTEM_INCLUDE_PATH}/remote-virtio-gpu
- install -m 755 ${S}/src/virtio_lo.h ${D}${PKG_CONFIG_SYSTEM_INCLUDE_PATH}/remote-virtio-gpu/virtio_lo.h
+ install -d ${D}${PKG_CONFIG_SYSTEM_INCLUDE_PATH}/linux
+ install -m 755 ${S}/virtio_lo.h ${D}${PKG_CONFIG_SYSTEM_INCLUDE_PATH}/linux/
+ # Add this section to install virtio_lo.conf
+ install -d ${D}${sysconfdir}/modules-load.d
+ echo "virtio_lo" > ${D}${sysconfdir}/modules-load.d/virtio_lo.conf
}
FILES:${PN} = " \
@@ -32,10 +28,5 @@ FILES:${PN} = " \
${sysconfdir}/modules-load.d \
"
-RPROVIDES:${PN} += " \
- kernel-module-virtiolo \
- kernel-module-virtio-lo${KERNEL_MODULE_PACKAGE_SUFFIX} \
-"
-
# Autoload virtio lo driver
KERNEL_MODULE_AUTOLOAD:append = " virtio_lo"