summaryrefslogtreecommitdiffstats
path: root/meta-uhmi/recipes-core/ucl-tools
diff options
context:
space:
mode:
authorKenta <murakami.kenta002@jp.panasonic.com>2024-10-10 18:10:32 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-10-24 08:24:43 +0000
commitdd48c93dc7ca4e37156413652ba716d008c2edcd (patch)
tree0e7d6833f00b2290b8696b2a1e76fc287ef1912f /meta-uhmi/recipes-core/ucl-tools
parent58da6681f4cd53670cb10d63f37ffaae3e6346c4 (diff)
Unified HMI: Consolidate recipes under meta-uhmi
Move all recipes from meta-rvgpu and meta-distributed-display-fw into meta-uhmi. And, document the build instructions for RVGPU and DDFW in the README. Bug-AGL: SPEC-5254 Change-Id: I0f3362b0f79105de39584d0a5659ac9e3c9d3a2b Signed-off-by: Kenta <murakami.kenta002@jp.panasonic.com>
Diffstat (limited to 'meta-uhmi/recipes-core/ucl-tools')
-rw-r--r--meta-uhmi/recipes-core/ucl-tools/files/ucl-launcher.service13
-rw-r--r--meta-uhmi/recipes-core/ucl-tools/ucl-tools_git.bb46
2 files changed, 59 insertions, 0 deletions
diff --git a/meta-uhmi/recipes-core/ucl-tools/files/ucl-launcher.service b/meta-uhmi/recipes-core/ucl-tools/files/ucl-launcher.service
new file mode 100644
index 00000000..37f289e6
--- /dev/null
+++ b/meta-uhmi/recipes-core/ucl-tools/files/ucl-launcher.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=ucl-launcher
+
+[Service]
+Type=idle
+ExecStart=/usr/bin/ucl-launcher
+KillSignal=SIGTERM
+TimeoutStopSec=10
+Restart=always
+RestartSec=2
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-uhmi/recipes-core/ucl-tools/ucl-tools_git.bb b/meta-uhmi/recipes-core/ucl-tools/ucl-tools_git.bb
new file mode 100644
index 00000000..cc26678b
--- /dev/null
+++ b/meta-uhmi/recipes-core/ucl-tools/ucl-tools_git.bb
@@ -0,0 +1,46 @@
+SUMMARY = "Unified HMI Clustering Tools"
+SECTION = "graphics"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://src/ucl-tools/LICENSE.md;md5=e789951aab02a3028d2e58b90fc933ba"
+
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
+
+PN="ucl-tools"
+PROVIDES += "ucl-tools"
+
+SRCREV = "80e83132834b5ab62875bc294332bd00cd559d5d"
+BRANCH ?= "main"
+SRC_URI = " \
+ git://github.com/unified-hmi/ucl-tools.git;protocol=https;branch=${BRANCH} \
+"
+PV = "0.0+git${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+export GO111MODULE="auto"
+
+GO_IMPORT = "ucl-tools"
+GO_INSTALL = " ${GO_IMPORT}/cmd/ucl-launcher ${GO_IMPORT}/cmd/ucl-distrib-com ${GO_IMPORT}/cmd/ucl-consistency-keeper ${GO_IMPORT}/cmd/ucl-ncount-master ${GO_IMPORT}/cmd/ucl-ncount-worker ${GO_IMPORT}/cmd/ucl-nkeep-master ${GO_IMPORT}/cmd/ucl-nkeep-worker ${GO_IMPORT}/cmd/ucl-timing-wrapper ${GO_IMPORT}/cmd/ucl-virtio-gpu-wl-send ${GO_IMPORT}/cmd/ucl-virtio-gpu-wl-recv"
+
+inherit go
+
+RDEPENDS:${PN} = "bash"
+RDEPENDS:${PN}-dev = "bash"
+
+inherit systemd
+SRC_URI += " file://ucl-launcher.service"
+
+REQUIRED_DISTRO_FEATURES = "systemd"
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE:${PN} = "ucl-launcher.service"
+SYSTEMD_AUTO_ENABLE:${PN} = "enable"
+FILES:${PN} += " \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_system_unitdir}/${SYSTEMD_SERVICE}', '', d)} \
+ "
+do_install:append() {
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -d ${D}${systemd_system_unitdir}
+ install -m 644 ${WORKDIR}/*.service ${D}/${systemd_system_unitdir}
+ fi
+}