summaryrefslogtreecommitdiffstats
path: root/meta-uhmi/recipes-graphics/wayland/wayland-ivi-extension_git.bb
diff options
context:
space:
mode:
authorKenta <murakami.kenta002@jp.panasonic.com>2024-10-10 18:10:32 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-10-24 08:24:43 +0000
commitdd48c93dc7ca4e37156413652ba716d008c2edcd (patch)
tree0e7d6833f00b2290b8696b2a1e76fc287ef1912f /meta-uhmi/recipes-graphics/wayland/wayland-ivi-extension_git.bb
parent58da6681f4cd53670cb10d63f37ffaae3e6346c4 (diff)
Unified HMI: Consolidate recipes under meta-uhmi
Move all recipes from meta-rvgpu and meta-distributed-display-fw into meta-uhmi. And, document the build instructions for RVGPU and DDFW in the README. Bug-AGL: SPEC-5254 Change-Id: I0f3362b0f79105de39584d0a5659ac9e3c9d3a2b Signed-off-by: Kenta <murakami.kenta002@jp.panasonic.com>
Diffstat (limited to 'meta-uhmi/recipes-graphics/wayland/wayland-ivi-extension_git.bb')
-rw-r--r--meta-uhmi/recipes-graphics/wayland/wayland-ivi-extension_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-uhmi/recipes-graphics/wayland/wayland-ivi-extension_git.bb b/meta-uhmi/recipes-graphics/wayland/wayland-ivi-extension_git.bb
new file mode 100644
index 00000000..f7b25917
--- /dev/null
+++ b/meta-uhmi/recipes-graphics/wayland/wayland-ivi-extension_git.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Wayland IVI Extension"
+DESCRIPTION = "GENIVI Layer Management API based on Wayland IVI Extension"
+HOMEPAGE = "https://github.com/COVESA/wayland-ivi-extension"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1f1a56bb2dadf5f2be8eb342acf4ed79"
+
+DEPENDS = "weston virtual/libgles2 pixman wayland-native"
+
+PV = "2.3.2+git${SRCPV}"
+
+SRC_URI = " \
+ git://github.com/COVESA/${BPN}.git;protocol=https;branch=master \
+ file://0001-Update-libweston-to-version-13.patch \
+"
+SRCREV = "60d616ad3abd925956207b9b6ff981afa004e792"
+
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig
+
+EXTRA_OECMAKE := "-DWITH_ILM_INPUT=1"
+EXTRA_OECMAKE += "-DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')}"
+
+FILES:${PN} += "${datadir}/wayland-protocols/stable/ivi-application/ivi-application.xml"
+FILES:${PN} += "${libdir}/weston/*"
+FILES:${PN}-dbg += "${libdir}/weston/.debug/*"