summaryrefslogtreecommitdiffstats
path: root/meta-uhmi/recipes-graphics
diff options
context:
space:
mode:
authorKenta <murakami.kenta002@jp.panasonic.com>2024-10-10 18:10:32 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-10-24 08:24:43 +0000
commitdd48c93dc7ca4e37156413652ba716d008c2edcd (patch)
tree0e7d6833f00b2290b8696b2a1e76fc287ef1912f /meta-uhmi/recipes-graphics
parent58da6681f4cd53670cb10d63f37ffaae3e6346c4 (diff)
Unified HMI: Consolidate recipes under meta-uhmi
Move all recipes from meta-rvgpu and meta-distributed-display-fw into meta-uhmi. And, document the build instructions for RVGPU and DDFW in the README. Bug-AGL: SPEC-5254 Change-Id: I0f3362b0f79105de39584d0a5659ac9e3c9d3a2b Signed-off-by: Kenta <murakami.kenta002@jp.panasonic.com>
Diffstat (limited to 'meta-uhmi/recipes-graphics')
-rw-r--r--meta-uhmi/recipes-graphics/mesa-virtio/mesa-virtio_20.3.5.bb59
-rw-r--r--meta-uhmi/recipes-graphics/remote-virtio-gpu/remote-virtio-gpu.inc6
-rw-r--r--meta-uhmi/recipes-graphics/remote-virtio-gpu/remote-virtio-gpu_git.bb22
-rw-r--r--meta-uhmi/recipes-graphics/rvgpu-wlproxy/rvgpu-wlproxy_git.bb19
-rw-r--r--meta-uhmi/recipes-graphics/wayland/wayland-ivi-extension/0001-Update-libweston-to-version-13.patch62
-rw-r--r--meta-uhmi/recipes-graphics/wayland/wayland-ivi-extension_git.bb26
6 files changed, 194 insertions, 0 deletions
diff --git a/meta-uhmi/recipes-graphics/mesa-virtio/mesa-virtio_20.3.5.bb b/meta-uhmi/recipes-graphics/mesa-virtio/mesa-virtio_20.3.5.bb
new file mode 100644
index 00000000..9a0dab2f
--- /dev/null
+++ b/meta-uhmi/recipes-graphics/mesa-virtio/mesa-virtio_20.3.5.bb
@@ -0,0 +1,59 @@
+SUMMARY = "Mesa library"
+SECTION = "graphics"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://docs/license.rst;md5=9aa1bc48c9826ad9fdb16661f6930496"
+
+
+DEPENDS = "expat makedepend-native flex-native bison-native libxml2-native zlib chrpath-replacement-native python3-mako-native gettext-native"
+DEPENDS:append = " libdrm wayland wayland-native wayland-protocols python3-native"
+
+SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz"
+
+SRC_URI[md5] = "224d7576618ef4dd8ac69f30b5b90b38"
+SRC_URI[sha256sum] = "909a72df63dfa3c0844ccf44a26ac028d148297ed333ab51560893923d7691ce"
+
+S = "${WORKDIR}/mesa-${PV}"
+
+RDEPENDS:${PN}:append = " libgcc wayland libdrm glibc libstdc++ zlib expat"
+
+inherit meson pkgconfig python3native gettext
+
+EXTRA_OEMESON = " \
+ -Dshared-glapi=true \
+ -Dgallium-opencl=disabled \
+ -Dglx-read-only-text=true \
+ -Dplatforms='wayland' \
+"
+
+EXTRA_OEMESON += " \
+ --prefix=/usr/lib/mesa-virtio \
+ --libdir=/usr/lib/mesa-virtio \
+ --sysconfdir=/etc/mesa-virtio \
+"
+
+EXTRA_OEMESON += " \
+ -Ddri-drivers='' \
+ -Dgallium-drivers='virgl,swrast' \
+ -Dglx=disabled \
+ -Dgles1=disabled \
+ -Dgles2=enabled \
+ -Degl=true \
+ -Dgbm=true \
+ -Dllvm=disabled \
+ -Dvulkan-drivers='[]' \
+"
+
+FILES:${PN} = " \
+ /usr/lib/mesa-virtio/* \
+ /etc/mesa-virtio/drirc \
+ /usr/share/mesa-virtio/* \
+"
+
+FILES:${PN}-dev += " \
+ /usr/lib/mesa-virtio/libglapi.so \
+ /usr/lib/mesa-virtio/libEGL.so \
+ /usr/lib/mesa-virtio/libgbm.so \
+ /usr/lib/mesa-virtio/libGLESv2.so \
+ /usr/lib/mesa-virtio/libGLESv1_CM.so \
+"
diff --git a/meta-uhmi/recipes-graphics/remote-virtio-gpu/remote-virtio-gpu.inc b/meta-uhmi/recipes-graphics/remote-virtio-gpu/remote-virtio-gpu.inc
new file mode 100644
index 00000000..ddd6dbab
--- /dev/null
+++ b/meta-uhmi/recipes-graphics/remote-virtio-gpu/remote-virtio-gpu.inc
@@ -0,0 +1,6 @@
+PV = "0.0+git${SRCPV}"
+SRCREV = "bce1f77f189dacf3e57d2f4edc37be4ff63b9e4b"
+BRANCH ?= "main"
+SRC_URI = " \
+ git://github.com/unified-hmi/remote-virtio-gpu.git;protocol=https;branch=${BRANCH} \
+"
diff --git a/meta-uhmi/recipes-graphics/remote-virtio-gpu/remote-virtio-gpu_git.bb b/meta-uhmi/recipes-graphics/remote-virtio-gpu/remote-virtio-gpu_git.bb
new file mode 100644
index 00000000..86e456c3
--- /dev/null
+++ b/meta-uhmi/recipes-graphics/remote-virtio-gpu/remote-virtio-gpu_git.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Remote virtual display userland"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=573c152503e0d9b97c8e0cc09fbb1ad2"
+
+require remote-virtio-gpu.inc
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "virglrenderer virtual/libgbm wayland wayland-native libepoxy libinput virtio-loopback-driver"
+RDEPENDS:${PN} = " wayland libgles2"
+
+inherit cmake pkgconfig
+
+PACKAGECONFIG_CONFARGS += " \
+ -DCMAKE_BUILD_TYPE=Release \
+"
+
+FILES:SOLIBSDEV = ""
+FILES:${PN} += " \
+ ${libdir}/librvgpu.so* \
+"
diff --git a/meta-uhmi/recipes-graphics/rvgpu-wlproxy/rvgpu-wlproxy_git.bb b/meta-uhmi/recipes-graphics/rvgpu-wlproxy/rvgpu-wlproxy_git.bb
new file mode 100644
index 00000000..5f6a70f2
--- /dev/null
+++ b/meta-uhmi/recipes-graphics/rvgpu-wlproxy/rvgpu-wlproxy_git.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Panasonic UHMI RVGPU Wayland Proxy"
+DEPENDS = " virtual/libgbm libinput libxkbcommon"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=a8a0cf4075753e7d7e8c948171357af0"
+
+SRCREV ="067d46a8977852afb8b503bd7d833b9037673db4"
+BRANCH ?= "main"
+
+SRC_URI = " \
+ git://github.com/unified-hmi/rvgpu-wlproxy.git;protocol=https;branch=${BRANCH} \
+"
+PV = "0.0+git${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+inherit pkgconfig cmake
+
+FILES:${PN} += "/usr/bin/*"
diff --git a/meta-uhmi/recipes-graphics/wayland/wayland-ivi-extension/0001-Update-libweston-to-version-13.patch b/meta-uhmi/recipes-graphics/wayland/wayland-ivi-extension/0001-Update-libweston-to-version-13.patch
new file mode 100644
index 00000000..008d0f4b
--- /dev/null
+++ b/meta-uhmi/recipes-graphics/wayland/wayland-ivi-extension/0001-Update-libweston-to-version-13.patch
@@ -0,0 +1,62 @@
+From e7984b2a8a7508cdbc3f269f4e0789edcfe8b30a Mon Sep 17 00:00:00 2001
+From: James Thomas <james.thomas@codethink.co.uk>
+Date: Thu, 22 Feb 2024 12:26:58 +0000
+Subject: [PATCH] Update libweston to version 13
+
+Upstream-Status: Submitted [https://github.com/COVESA/wayland-ivi-extension/pull/185]
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
+
+---
+ CMakeLists.txt | 2 +-
+ weston-ivi-shell/src/ivi-controller.c | 10 +++++-----
+ 2 files changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index d6428c2..5917875 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -28,7 +28,7 @@ include(GNUInstallDirs)
+ SET(IVI_EXTENSION_VERSION 2.3.2)
+ SET(ILM_API_VERSION 2.3.2)
+
+-SET(LIBWESTON_VER 12)
++SET(LIBWESTON_VER 13)
+
+ SET( CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Wno-unused-parameter" )
+ SET( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wextra -Wno-unused-parameter" )
+diff --git a/weston-ivi-shell/src/ivi-controller.c b/weston-ivi-shell/src/ivi-controller.c
+index 4701aec..94ca83e 100644
+--- a/weston-ivi-shell/src/ivi-controller.c
++++ b/weston-ivi-shell/src/ivi-controller.c
+@@ -881,15 +881,15 @@ set_bkgnd_surface_prop(struct ivishell *shell)
+ wl_list_for_each(output, &compositor->output_list, link) {
+ if (!count)
+ {
+- x = output->x;
+- y = output->y;
++ x = output->pos.c.x;
++ y = output->pos.c.y;
+ count++;
+ }
+- dest_width = output->x + output->width;
++ dest_width = output->pos.c.x + output->width;
+ if (output->height > dest_height)
+ dest_height = output->height;
+ weston_log("set_bkgnd_surface_prop: o_name:%s x:%d y:%d o_width:%d o_height:%d\n",
+- output->name, output->x, output->y, output->width, output->height);
++ output->name, output->pos.c.x, output->pos.c.y, output->width, output->height);
+ }
+
+ w_surface = view->surface;
+@@ -2197,7 +2197,7 @@ launch_client_process(void *data)
+ setenv(IVI_CLIENT_ENABLE_CURSOR_ENV_NAME, option, 0x1);
+ }
+
+- shell->client = weston_client_start(shell->compositor,
++ shell->client = wet_client_start(shell->compositor,
+ shell->ivi_client_name);
+
+ shell->client_destroy_listener.notify = ivi_shell_client_destroy;
+--
+2.44.0
+
diff --git a/meta-uhmi/recipes-graphics/wayland/wayland-ivi-extension_git.bb b/meta-uhmi/recipes-graphics/wayland/wayland-ivi-extension_git.bb
new file mode 100644
index 00000000..f7b25917
--- /dev/null
+++ b/meta-uhmi/recipes-graphics/wayland/wayland-ivi-extension_git.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Wayland IVI Extension"
+DESCRIPTION = "GENIVI Layer Management API based on Wayland IVI Extension"
+HOMEPAGE = "https://github.com/COVESA/wayland-ivi-extension"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1f1a56bb2dadf5f2be8eb342acf4ed79"
+
+DEPENDS = "weston virtual/libgles2 pixman wayland-native"
+
+PV = "2.3.2+git${SRCPV}"
+
+SRC_URI = " \
+ git://github.com/COVESA/${BPN}.git;protocol=https;branch=master \
+ file://0001-Update-libweston-to-version-13.patch \
+"
+SRCREV = "60d616ad3abd925956207b9b6ff981afa004e792"
+
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig
+
+EXTRA_OECMAKE := "-DWITH_ILM_INPUT=1"
+EXTRA_OECMAKE += "-DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')}"
+
+FILES:${PN} += "${datadir}/wayland-protocols/stable/ivi-application/ivi-application.xml"
+FILES:${PN} += "${libdir}/weston/*"
+FILES:${PN}-dbg += "${libdir}/weston/.debug/*"