summaryrefslogtreecommitdiffstats
path: root/templates
diff options
context:
space:
mode:
authorAnuj Solanki <anuj603362@gmail.com>2024-07-03 17:28:05 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-08-30 11:53:02 +0000
commit8607d696eca482e025a9ca30ee992707211d1f11 (patch)
treeca4342a7db0465199119d1c24bf3e824a0f0a1c3 /templates
parent65f1ec44778eaa59c2c74bf5fbb22a670b6231a0 (diff)
Integrate Whisper AI into AGL Voice Agent and Update Dependencies
V1: - Removed the following recipes from meta-offline-voiceagent: - python3-scipy - python3-scikit-learn - python3-openblas - python3-lapack - python3-numpy - Updated to use meta-python-ai layer for: - python3-scipy - python3-scikit-learn - python3-openblas - python3-lapack - python3-numpy - python3-pytorch - Added all the required recipes for Whisper AI: - Included recipes for Whisper AI base and tiny model - Updated recipes for: - python3-uvloop - python3-python-crfsuite V2: - Remove vulkan from DISTRO_FEATURES as it has become coditional at upstream - Fix flutter_voiceassistant service - Update recipe of llvmlite to include the wheel for aarch64 also. V3: - Fix llvmlite recipe and some patches - Removes rasa and its dependencies - Fix agl-service-voiceagent.service Bug-AGL: SPEC-5200 Change-Id: I429e7d4b98fbbe1a4f8c1341ac8918d7d177b382 Signed-off-by: Anuj Solanki <anuj603362@gmail.com>
Diffstat (limited to 'templates')
-rw-r--r--templates/feature/agl-offline-voice-agent/50_bblayers.conf.inc6
-rw-r--r--templates/feature/agl-offline-voice-agent/50_local.conf.inc14
2 files changed, 15 insertions, 5 deletions
diff --git a/templates/feature/agl-offline-voice-agent/50_bblayers.conf.inc b/templates/feature/agl-offline-voice-agent/50_bblayers.conf.inc
index ef9d57df..5c235ac0 100644
--- a/templates/feature/agl-offline-voice-agent/50_bblayers.conf.inc
+++ b/templates/feature/agl-offline-voice-agent/50_bblayers.conf.inc
@@ -4,5 +4,9 @@ AGL_META_PYTHON = "${METADIR}/external/meta-openembedded/meta-python"
BBLAYERS =+ " \
${METADIR}/meta-agl-devel/meta-offline-voice-agent \
- ${METADIR}/external/meta-tensorflow \
+ ${METADIR}/external/meta-python-ai \
"
+
+# package in meta-oe is newer
+BBMASK += "meta-tensorflow/recipes-devtools/python/python3-gast_0.4.0.bb"
+
diff --git a/templates/feature/agl-offline-voice-agent/50_local.conf.inc b/templates/feature/agl-offline-voice-agent/50_local.conf.inc
index f8ca1d82..632f14be 100644
--- a/templates/feature/agl-offline-voice-agent/50_local.conf.inc
+++ b/templates/feature/agl-offline-voice-agent/50_local.conf.inc
@@ -8,11 +8,11 @@ HOSTTOOLS += "gfortran"
# FIXME check if needed and/or submit upstream
BBCLASSEXTEND:pn-python3-charset-normalizer = "native nativesdk"
-IMAGE_INSTALL:append = " \
+PACKAGECONFIG:pn-openblas := "cblas lapack lapack-deprecated"
+
+FEATURE_PACKAGES_agl-offline-voice-agent:append = " \
python3-snips-inference-agl \
snips-model-agl \
- python3-rasa \
- rasa-model-agl \
vosk \
vosk-kaldi \
vosk-server \
@@ -21,11 +21,17 @@ IMAGE_INSTALL:append = " \
python3-sounddevice \
flutter-voiceassistant \
agl-service-voiceagent \
+ whisper \
+ openai-whisper-base \
"
-PREFERRED_RPROVIDER_vosk-model ?= "vosk-model-small-en-us"
+EXTRA_IMAGE_FEATURES += "agl-offline-voice-agent"
+PREFERRED_RPROVIDER_vosk-model ?= "vosk-model-small-en-us"
+PREFERRED_RPROVIDER_whisper-model ?= "openai-whisper-base"
# bump bazel limits
BAZEL_JOBS = "HOST_CPUS*.4"
BAZEL_MEM = "HOST_RAM*.4"
+
+LICENSE_FLAGS_ACCEPTED += "commercial_ffmpeg"