summaryrefslogtreecommitdiffstats
path: root/templates
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-09-12 13:30:23 -0400
committerScott Murray <scott.murray@konsulko.com>2019-09-14 13:04:02 +0000
commitefc3de9ad64b322b1b4025d0a75150d2a3bf00ed (patch)
tree601783b101ed00dde02c3a261f799d9a868ebb16 /templates
parentb75b8cf21743708f6eb22d53348aaf2607440cdd (diff)
Add agl-voiceagent-alexa feature
Add feature and associated recipes and bbappends to enable building the Amazon Alexa voice agent for the speech framework using the Alexa Automotive SDK 2.0 release. A separate feature is used to accomodate potentially building with a different voiceagent provider. Some follow on development is required to add PipeWire support to the new gstreamer extension added in AAC 2.0, see SPEC-2767. Bug-AGL: SPEC-2765 Change-Id: Ie6e8f6a7965f8014ca2e64a2535faec073e320bc Signed-off-by: Scott Murray <scott.murray@konsulko.com> (cherry picked from commit e4a71cfe9b53795dd456cb8bd776c5196e924acf)
Diffstat (limited to 'templates')
-rw-r--r--templates/feature/agl-speech-framework/50_local.conf.inc2
-rw-r--r--templates/feature/agl-voiceagent-alexa/50_bblayers.conf.inc10
-rw-r--r--templates/feature/agl-voiceagent-alexa/50_local.conf.inc2
-rw-r--r--templates/feature/agl-voiceagent-alexa/README_feature_agl-voiceagent-alexa.md8
-rw-r--r--templates/feature/agl-voiceagent-alexa/included.dep1
5 files changed, 23 insertions, 0 deletions
diff --git a/templates/feature/agl-speech-framework/50_local.conf.inc b/templates/feature/agl-speech-framework/50_local.conf.inc
new file mode 100644
index 00000000..c542f383
--- /dev/null
+++ b/templates/feature/agl-speech-framework/50_local.conf.inc
@@ -0,0 +1,2 @@
+#see meta-agl-devel/meta-speech-framework/conf/include/agl-speech-framework.inc
+require conf/include/agl-speech-framework.inc
diff --git a/templates/feature/agl-voiceagent-alexa/50_bblayers.conf.inc b/templates/feature/agl-voiceagent-alexa/50_bblayers.conf.inc
new file mode 100644
index 00000000..2397a1d7
--- /dev/null
+++ b/templates/feature/agl-voiceagent-alexa/50_bblayers.conf.inc
@@ -0,0 +1,10 @@
+BBLAYERS =+ " \
+ ${METADIR}/external/alexa-auto-sdk/builder/meta-aac \
+"
+
+# Per the SDK documentation, the module recipes need to be manually
+# added, as they sit outside of the layer.
+BBFILES += "${METADIR}/external/alexa-auto-sdk/modules/*/*.bb"
+
+# Include the recipe for the required gstreamer module as well
+BBFILES += "${METADIR}/external/alexa-auto-sdk/extensions/experimental/gstreamer/modules/*/*.bb"
diff --git a/templates/feature/agl-voiceagent-alexa/50_local.conf.inc b/templates/feature/agl-voiceagent-alexa/50_local.conf.inc
new file mode 100644
index 00000000..828b88d6
--- /dev/null
+++ b/templates/feature/agl-voiceagent-alexa/50_local.conf.inc
@@ -0,0 +1,2 @@
+#see meta-agl-devel/meta-speech-framework/conf/include/agl-voiceagent-alexa.inc
+require conf/include/agl-voiceagent-alexa.inc
diff --git a/templates/feature/agl-voiceagent-alexa/README_feature_agl-voiceagent-alexa.md b/templates/feature/agl-voiceagent-alexa/README_feature_agl-voiceagent-alexa.md
new file mode 100644
index 00000000..584042fe
--- /dev/null
+++ b/templates/feature/agl-voiceagent-alexa/README_feature_agl-voiceagent-alexa.md
@@ -0,0 +1,8 @@
+---
+description: Feature agl-voiceagent-alexa
+authors: Scott Murray <scott.murray@konsulko.com>
+---
+
+### Feature agl-voiceagent-alexa
+
+Enables building Amazon Alexa voice agent binding for the speech framework using the Alexa Automotive SDK.
diff --git a/templates/feature/agl-voiceagent-alexa/included.dep b/templates/feature/agl-voiceagent-alexa/included.dep
new file mode 100644
index 00000000..fde3c2de
--- /dev/null
+++ b/templates/feature/agl-voiceagent-alexa/included.dep
@@ -0,0 +1 @@
+agl-speech-framework