summaryrefslogtreecommitdiffstats
path: root/templates
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-12-29 19:01:24 -0500
committerScott Murray <scott.murray@konsulko.com>2019-12-30 00:04:16 +0000
commit0f1d405101e1419474de80658535dc34dc8d8b16 (patch)
treeee214e737d45fb61db37ead0f36c18f20388c779 /templates
parent40eb01c5c943509df2f4a52c3fe75a5d0cf0123b (diff)
alexa-voiceagent-service: support building in wakeword engine
Add support for building the "amazonlite" wakeword engine into the Alexa voiceagent. A new feature template, agl-voiceagent-alexa-wakeword, is added to pull in the extra layers/recipes from the additional wakeword engine files for the SDK that Amazon provides. The feature pulls in the existing agl-voiceagent-alexa feature as a dependency to simplify configuring a build. The existing patch to work around the Alexa SDK build's use of AAC_PREFIX as prefix for all packages has been updated to handle the pryon-lite wakeword engine library. Bug-AGL: SPEC-3077 Change-Id: I5549ea9000c6713e6becb191f4dcd957ebde18ac Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'templates')
-rw-r--r--templates/feature/agl-voiceagent-alexa-wakeword/50_bblayers.conf.inc6
-rw-r--r--templates/feature/agl-voiceagent-alexa-wakeword/50_local.conf.inc1
-rw-r--r--templates/feature/agl-voiceagent-alexa-wakeword/README_feature_agl-voiceagent-alexa-wakeword.md10
-rw-r--r--templates/feature/agl-voiceagent-alexa-wakeword/included.dep1
4 files changed, 18 insertions, 0 deletions
diff --git a/templates/feature/agl-voiceagent-alexa-wakeword/50_bblayers.conf.inc b/templates/feature/agl-voiceagent-alexa-wakeword/50_bblayers.conf.inc
new file mode 100644
index 00000000..31f4dca8
--- /dev/null
+++ b/templates/feature/agl-voiceagent-alexa-wakeword/50_bblayers.conf.inc
@@ -0,0 +1,6 @@
+BBLAYERS =+ " \
+ ${METADIR}/external/alexa-auto-sdk/extensions/extras/amazonlite/meta-aac-amazonlite \
+"
+
+# Include the recipe for the required module as well
+BBFILES += "${METADIR}/external/alexa-auto-sdk/extensions/extras/amazonlite/modules/*/*.bb"
diff --git a/templates/feature/agl-voiceagent-alexa-wakeword/50_local.conf.inc b/templates/feature/agl-voiceagent-alexa-wakeword/50_local.conf.inc
new file mode 100644
index 00000000..41af3db8
--- /dev/null
+++ b/templates/feature/agl-voiceagent-alexa-wakeword/50_local.conf.inc
@@ -0,0 +1 @@
+ALEXA_WAKEWORD = "true"
diff --git a/templates/feature/agl-voiceagent-alexa-wakeword/README_feature_agl-voiceagent-alexa-wakeword.md b/templates/feature/agl-voiceagent-alexa-wakeword/README_feature_agl-voiceagent-alexa-wakeword.md
new file mode 100644
index 00000000..e8491289
--- /dev/null
+++ b/templates/feature/agl-voiceagent-alexa-wakeword/README_feature_agl-voiceagent-alexa-wakeword.md
@@ -0,0 +1,10 @@
+---
+description: Feature agl-voiceagent-alexa-wakeword
+authors: Scott Murray <scott.murray@konsulko.com>
+---
+
+### Feature agl-voiceagent-alexa-wakeword
+
+Enables building the Amazon Alexa voiceagent binding with included wakeword engine support.
+
+Note that this features assumes that the amazonlite wakeword engine ZIP file (e.g. amazonlite-2.0.zip) containing the required additional files has been decompressed to external/alexa-auto-sdk/extensions/extras/amazonlite in the tree. Without this, attempting to build with bitbake will fail. Please contact your Amazon Alexa developer account representative if you wish to obtain the wakeword engine.
diff --git a/templates/feature/agl-voiceagent-alexa-wakeword/included.dep b/templates/feature/agl-voiceagent-alexa-wakeword/included.dep
new file mode 100644
index 00000000..71688dda
--- /dev/null
+++ b/templates/feature/agl-voiceagent-alexa-wakeword/included.dep
@@ -0,0 +1 @@
+agl-voiceagent-alexa