summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-uhmi/recipes-core/ucl-tools/ucl-tools_git.bb2
-rw-r--r--meta-uhmi/recipes-core/uhmi-ivi-wm/uhmi-ivi-wm_git.bb5
-rw-r--r--meta-uhmi/recipes-core/ula-tools/ula-tools_git.bb7
3 files changed, 4 insertions, 10 deletions
diff --git a/meta-uhmi/recipes-core/ucl-tools/ucl-tools_git.bb b/meta-uhmi/recipes-core/ucl-tools/ucl-tools_git.bb
index cc26678b..2c3111d7 100644
--- a/meta-uhmi/recipes-core/ucl-tools/ucl-tools_git.bb
+++ b/meta-uhmi/recipes-core/ucl-tools/ucl-tools_git.bb
@@ -28,7 +28,7 @@ inherit go
RDEPENDS:${PN} = "bash"
RDEPENDS:${PN}-dev = "bash"
-inherit systemd
+inherit systemd features_check
SRC_URI += " file://ucl-launcher.service"
REQUIRED_DISTRO_FEATURES = "systemd"
diff --git a/meta-uhmi/recipes-core/uhmi-ivi-wm/uhmi-ivi-wm_git.bb b/meta-uhmi/recipes-core/uhmi-ivi-wm/uhmi-ivi-wm_git.bb
index daa5fff4..57af74ef 100644
--- a/meta-uhmi/recipes-core/uhmi-ivi-wm/uhmi-ivi-wm_git.bb
+++ b/meta-uhmi/recipes-core/uhmi-ivi-wm/uhmi-ivi-wm_git.bb
@@ -19,10 +19,8 @@ PV = "0.0+git${SRCPV}"
S = "${WORKDIR}/git"
-inherit cmake
+inherit cmake systemd features_check
-
-inherit systemd
SRC_URI += " file://uhmi-ivi-wm.service"
REQUIRED_DISTRO_FEATURES = "systemd"
SYSTEMD_PACKAGES = "${PN}"
@@ -39,6 +37,5 @@ do_install:append() {
fi
}
-
FILES:${PN} += " /usr/bin/uhmi-ivi-wm"
FILES:${PN} += " /usr/share/*"
diff --git a/meta-uhmi/recipes-core/ula-tools/ula-tools_git.bb b/meta-uhmi/recipes-core/ula-tools/ula-tools_git.bb
index 9b945a3f..1dc26e20 100644
--- a/meta-uhmi/recipes-core/ula-tools/ula-tools_git.bb
+++ b/meta-uhmi/recipes-core/ula-tools/ula-tools_git.bb
@@ -18,18 +18,16 @@ PV = "0.0+git${SRCPV}"
S = "${WORKDIR}/git"
-
export GO111MODULE="auto"
GO_IMPORT = "ula-tools"
GO_INSTALL = " ${GO_IMPORT}/cmd/ula-distrib-com ${GO_IMPORT}/cmd/ula-node"
-
inherit go
RDEPENDS:${PN} = "jq bash"
RDEPENDS:${PN}-dev = "bash"
-inherit systemd
+inherit systemd features_check
SRC_URI += " \
file://ula-node.service \
@@ -47,10 +45,10 @@ FILES:${PN} += " \
do_compile:append() {
export CGO_ENABLED="1"
+ export GOFLAGS="-mod=vendor -trimpath"
${GO} build -buildmode=c-shared -o ${GOPATH}/pkg/libulaclient.so -v -ldflags '-extldflags "-Wl,-soname=libulaclient.so"' ${GO_IMPORT}/pkg/ula-client-lib
}
-
do_install:append() {
if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
install -d ${D}${systemd_system_unitdir}
@@ -65,7 +63,6 @@ do_install:append() {
install -d ${D}${includedir}
install -m 644 ${GOPATH}/pkg/libulaclient.h ${D}${includedir}
-
}
FILES:${PN} += "${libdir}"