summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--README.md5
-rw-r--r--meta-audio-4a-framework/conf/include/agl-audio-4a-framework.inc1
-rw-r--r--meta-audio-4a-framework/meta-agl-demo/recipes-multimedia/4a-mixer/4a-mixer_git.bb2
-rw-r--r--meta-audio-4a-framework/recipes-core/packagegroups/packagegroup-agl-audio.bb1
-rw-r--r--meta-audio-4a-framework/recipes-multimedia/pulseaudio/files/default.pa.4a88
-rw-r--r--meta-audio-4a-framework/recipes-multimedia/pulseaudio/pulseaudio-module-4a-client_git.bb20
-rw-r--r--meta-audio-soundmanager-framework/recipes-multimedia/agl-service-audio-soundmanager/agl-service-audio-soundmanager_1.0.bb (renamed from meta-audio-soundmanager-framework/recipes-multimedia/agl-service-audio-soundmanager/agl-service-audio-soundmanager_git.bb)5
-rw-r--r--meta-audio-soundmanager-framework/recipes-multimedia/libsoundmanager/libsoundmanager_0.9.bb (renamed from meta-audio-soundmanager-framework/recipes-multimedia/libsoundmanager/libsoundmanager_git.bb)5
-rw-r--r--meta-hmi-framework/recipes-demo-hmi/homescreen-2017/homescreen-2017_git.bb1
-rw-r--r--meta-hmi-framework/recipes-graphics/agl-service-windowmanager-2017/agl-service-windowmanager-2017_git.bb2
-rw-r--r--meta-hmi-framework/recipes-graphics/libwindowmanager/libwindowmanager_git.bb4
-rw-r--r--meta-hmi-framework/recipes-graphics/qlibwindowmanager/qlibwindowmanager_git.bb5
-rw-r--r--meta-renesas-kernel/conf/layer.conf10
-rw-r--r--meta-renesas-kernel/recipes-kernel/linux/files/fuse-rcar.cfg2
-rw-r--r--meta-renesas-kernel/recipes-kernel/linux/files/iptables-rcar.cfg18
-rw-r--r--meta-renesas-kernel/recipes-kernel/linux/linux-renesas_%.bbappend3
-rw-r--r--templates/feature/agl-audio-soundmanager-framework/50_local.conf.inc2
-rw-r--r--templates/feature/agl-renesas-kernel/50_bblayers.conf.inc4
18 files changed, 104 insertions, 74 deletions
diff --git a/README.md b/README.md
index 63bd9fc0..1a5b4861 100644
--- a/README.md
+++ b/README.md
@@ -19,8 +19,8 @@ visit the EG\_VIRT wiki page at: https://wiki.automotivelinux.org/eg-virt
The OEM needs library for AGL
======================================================
-There are some software package that the OEM needs, but not exist in the AGL source.
-This layer is add OEM needs library for AGL.
+There are some software package that the OEM needs, but not exist in the AGL source.
+This layer is add OEM needs library for AGL.
The software packages list:
* boost
@@ -68,7 +68,6 @@ Supported Machines
Reference hardware:
* QEMU (x86-64) - emulated machine: qemux86-64
-* Renesas R-Car Gen2 (R-Car M2) - machine: porter
HMI Framework
======================================================
diff --git a/meta-audio-4a-framework/conf/include/agl-audio-4a-framework.inc b/meta-audio-4a-framework/conf/include/agl-audio-4a-framework.inc
index 935b9ad1..12711f66 100644
--- a/meta-audio-4a-framework/conf/include/agl-audio-4a-framework.inc
+++ b/meta-audio-4a-framework/conf/include/agl-audio-4a-framework.inc
@@ -14,6 +14,7 @@ PACKAGES_pn-alsa-state_remove = "alsa-state-dev"
PACKAGES_pn-alsa-state_remove = "alsa-states-dev"
PACKAGES_pn-alsa-state = "alsa-state alsa-states"
+PREFERRED_PROVIDER_virtual/mixer ?= "4a-mixer"
PREFERRED_RPROVIDER_virtual/mixer ?= "4a-mixer"
PREFERRED_VERSION_alsa-lib = "1.1.6"
diff --git a/meta-audio-4a-framework/meta-agl-demo/recipes-multimedia/4a-mixer/4a-mixer_git.bb b/meta-audio-4a-framework/meta-agl-demo/recipes-multimedia/4a-mixer/4a-mixer_git.bb
index 93fd1b70..f5192ae3 100644
--- a/meta-audio-4a-framework/meta-agl-demo/recipes-multimedia/4a-mixer/4a-mixer_git.bb
+++ b/meta-audio-4a-framework/meta-agl-demo/recipes-multimedia/4a-mixer/4a-mixer_git.bb
@@ -15,11 +15,11 @@ S = "${WORKDIR}/git"
# build-time dependencies
DEPENDS += "qtquickcontrols2 \
qtwebsockets \
- pulseaudio \
virtual/libhomescreen \
qlibwindowmanager \
"
+PROVIDES += "virtual/mixer"
RPROVIDES_${PN} += "virtual/mixer"
inherit cmake_qt5 aglwgt
diff --git a/meta-audio-4a-framework/recipes-core/packagegroups/packagegroup-agl-audio.bb b/meta-audio-4a-framework/recipes-core/packagegroups/packagegroup-agl-audio.bb
index fde5f637..907cb1c4 100644
--- a/meta-audio-4a-framework/recipes-core/packagegroups/packagegroup-agl-audio.bb
+++ b/meta-audio-4a-framework/recipes-core/packagegroups/packagegroup-agl-audio.bb
@@ -18,4 +18,5 @@ RDEPENDS_${PN} += "\
4a-softmixer \
4a-hal-generic \
${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '4a-tools', '' , d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio-module-4a-client', '' , d)} \
"
diff --git a/meta-audio-4a-framework/recipes-multimedia/pulseaudio/files/default.pa.4a b/meta-audio-4a-framework/recipes-multimedia/pulseaudio/files/default.pa.4a
index 0afab22b..0efdacc2 100644
--- a/meta-audio-4a-framework/recipes-multimedia/pulseaudio/files/default.pa.4a
+++ b/meta-audio-4a-framework/recipes-multimedia/pulseaudio/files/default.pa.4a
@@ -1,33 +1,77 @@
#!/usr/bin/pulseaudio -nF
#
+# This file is part of PulseAudio.
+#
+# PulseAudio is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# PulseAudio is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.
+
+# This startup script is used only if PulseAudio is started per-user
+# (i.e. not in system mode)
.fail
-### Automatically load driver modules for Bluetooth hardware
-.ifexists module-bluetooth-policy.so
-load-module module-bluetooth-policy
+### Automatically augment property information from .desktop files
+### stored in /usr/share/application
+load-module module-augment-properties
+
+### Load several protocols
+.ifexists module-esound-protocol-unix.so
+load-module module-esound-protocol-unix
.endif
+load-module module-native-protocol-unix
+
+### Network access (may be configured with paprefs, so leave this commented
+### here if you plan to use paprefs)
+#load-module module-esound-protocol-tcp
+#load-module module-native-protocol-tcp
+
+### Load the RTP receiver module (also configured via paprefs, see above)
+#load-module module-rtp-recv
-.ifexists module-bluetooth-discover.so
-load-module module-bluetooth-discover headset=ofono
+### Load the RTP sender module (also configured via paprefs, see above)
+#load-module module-null-sink sink_name=rtp format=s16be channels=2 rate=44100 sink_properties="device.description='RTP Multicast Sink'"
+#load-module module-rtp-send source=rtp.monitor
+
+.ifexists module-4a-client.so
+load-module module-null-sink sink_name=aaaa_null_sink sink_properties="device.description='4A Null Output'"
+set-default-sink aaaa_null_sink
+load-module module-4a-client
+.else
+load-module module-udev-detect
.endif
-load-module module-native-protocol-unix
+### Automatically move streams to the default sink if the sink they are
+### connected to dies, similar for sources
+load-module module-rescue-streams
+
+### Make sure we always have a sink around, even if it is a null sink.
+load-module module-always-sink
### Automatically suspend sinks/sources that become idle for too long
-load-module module-suspend-on-idle timeout=0
-
-load-module module-alsa-sink device=Fallback
-#load-module module-alsa-sink device=CustomLow
-load-module module-alsa-sink device=Radio
-#load-module module-alsa-sink device=Multimedia
-#load-module module-alsa-sink device=Streaming
-load-module module-alsa-sink device=Video
-#load-module module-alsa-sink device=CustomMedium
-load-module module-alsa-sink device=Navigation
-load-module module-alsa-sink device=Phone
-#load-module module-alsa-sink device=CustomHigh
-#load-module module-alsa-sink device=Warning
-load-module module-alsa-sink device=Emergency
-
-set-default-sink alsa_output.Fallback
+load-module module-suspend-on-idle
+
+### If autoexit on idle is enabled we want to make sure we only quit
+### when no local session needs us anymore.
+.ifexists module-console-kit.so
+load-module module-console-kit
+.endif
+.ifexists module-systemd-login.so
+load-module module-systemd-login
+.endif
+
+### Modules to allow autoloading of filters (such as echo cancellation)
+### on demand. module-filter-heuristics tries to determine what filters
+### make sense, and module-filter-apply does the heavy-lifting of
+### loading modules and rerouting streams.
+load-module module-filter-heuristics
+load-module module-filter-apply
diff --git a/meta-audio-4a-framework/recipes-multimedia/pulseaudio/pulseaudio-module-4a-client_git.bb b/meta-audio-4a-framework/recipes-multimedia/pulseaudio/pulseaudio-module-4a-client_git.bb
new file mode 100644
index 00000000..0a763d88
--- /dev/null
+++ b/meta-audio-4a-framework/recipes-multimedia/pulseaudio/pulseaudio-module-4a-client_git.bb
@@ -0,0 +1,20 @@
+SUMMARY = "pulseaudio 4A client module"
+DESCRIPTION = "pulseaudio module to work with 4A (AGL Advanced Audio Agent)"
+HOMEPAGE = "https://gitlab.collabora.com/gkiagia/pulseaudio-module-4a"
+SECTION = "plugins"
+
+LICENSE = "LGPL-2.1+"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4fbd65380cdd255951079008b364516c"
+
+SRC_URI = "git://gitlab.collabora.com/gkiagia/pulseaudio-module-4a.git;protocol=https"
+SRCREV = "897f554324bbb031d6a482584b227f8400d2c624"
+
+PV = "0.1+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig
+
+DEPENDS += "af-binder systemd json-c pulseaudio"
+RDEPENDS_${PN} = "pulseaudio-module-alsa-sink"
+
+FILES_${PN} += "/usr/lib/pulse-*/modules/module-4a-client.so"
diff --git a/meta-audio-soundmanager-framework/recipes-multimedia/agl-service-audio-soundmanager/agl-service-audio-soundmanager_git.bb b/meta-audio-soundmanager-framework/recipes-multimedia/agl-service-audio-soundmanager/agl-service-audio-soundmanager_1.0.bb
index b561cf4e..a10e825e 100644
--- a/meta-audio-soundmanager-framework/recipes-multimedia/agl-service-audio-soundmanager/agl-service-audio-soundmanager_git.bb
+++ b/meta-audio-soundmanager-framework/recipes-multimedia/agl-service-audio-soundmanager/agl-service-audio-soundmanager_1.0.bb
@@ -14,6 +14,7 @@ RDEPENDS_${PN} = "audiomanager audiomanager-plugins"
inherit cmake aglwgt
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-soundmanager-2017;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "b1be03d9670f166af53f1d06275e2428e8c99779"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-soundmanager;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "5106b9d03108792b2594b553e00c149945ac6f97"
S = "${WORKDIR}/git"
+PV = "1.0+git${SRCPV}"
diff --git a/meta-audio-soundmanager-framework/recipes-multimedia/libsoundmanager/libsoundmanager_git.bb b/meta-audio-soundmanager-framework/recipes-multimedia/libsoundmanager/libsoundmanager_0.9.bb
index 4e9c84ad..bf6aa6a1 100644
--- a/meta-audio-soundmanager-framework/recipes-multimedia/libsoundmanager/libsoundmanager_git.bb
+++ b/meta-audio-soundmanager-framework/recipes-multimedia/libsoundmanager/libsoundmanager_0.9.bb
@@ -10,6 +10,7 @@ RDEPENDS_${PN} = "agl-service-audio-soundmanager"
inherit cmake
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/libsoundmanager.git;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "e920aae9f71c0823ab5754b2de8483e157368580"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/libsoundmanager.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "7322b823f40a5504baef9cdb69513e7dba306ed1"
S = "${WORKDIR}/git"
+PV = "0.9+git${SRCPV}"
diff --git a/meta-hmi-framework/recipes-demo-hmi/homescreen-2017/homescreen-2017_git.bb b/meta-hmi-framework/recipes-demo-hmi/homescreen-2017/homescreen-2017_git.bb
index 704dbce0..eabc5d09 100644
--- a/meta-hmi-framework/recipes-demo-hmi/homescreen-2017/homescreen-2017_git.bb
+++ b/meta-hmi-framework/recipes-demo-hmi/homescreen-2017/homescreen-2017_git.bb
@@ -9,7 +9,6 @@ DEPENDS = "\
qtbase \
qtdeclarative \
qtquickcontrols2 \
- pulseaudio \
agl-service-homescreen-2017 \
agl-service-windowmanager-2017 \
agl-service-weather \
diff --git a/meta-hmi-framework/recipes-graphics/agl-service-windowmanager-2017/agl-service-windowmanager-2017_git.bb b/meta-hmi-framework/recipes-graphics/agl-service-windowmanager-2017/agl-service-windowmanager-2017_git.bb
index da490198..50e6dd4a 100644
--- a/meta-hmi-framework/recipes-graphics/agl-service-windowmanager-2017/agl-service-windowmanager-2017_git.bb
+++ b/meta-hmi-framework/recipes-graphics/agl-service-windowmanager-2017/agl-service-windowmanager-2017_git.bb
@@ -15,7 +15,7 @@ DEPENDS = "af-binder json-c wayland wayland-ivi-extension wayland-native"
inherit cmake aglwgt
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-windowmanager-2017;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "e4fcbf1b100ec2d926f7fbba5b1246336d05d436"
+SRCREV = "a79b572a5f26d6ecdd97dff159c40bad330e1c4c"
PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
diff --git a/meta-hmi-framework/recipes-graphics/libwindowmanager/libwindowmanager_git.bb b/meta-hmi-framework/recipes-graphics/libwindowmanager/libwindowmanager_git.bb
index 89b37390..f0ffc54c 100644
--- a/meta-hmi-framework/recipes-graphics/libwindowmanager/libwindowmanager_git.bb
+++ b/meta-hmi-framework/recipes-graphics/libwindowmanager/libwindowmanager_git.bb
@@ -9,7 +9,7 @@ RDEPENDS_${PN} = "agl-service-windowmanager-2017"
inherit cmake
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/libwindowmanager.git;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "fa08aaf93eaaa6f09cbb325d6624b5dfb72fbbdc"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libwindowmanager.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "b306138515459445eb2173301e012f2848495f00"
S = "${WORKDIR}/git"
PV = "1.0+git${SRCPV}"
diff --git a/meta-hmi-framework/recipes-graphics/qlibwindowmanager/qlibwindowmanager_git.bb b/meta-hmi-framework/recipes-graphics/qlibwindowmanager/qlibwindowmanager_git.bb
index 0cdb987c..facbd074 100644
--- a/meta-hmi-framework/recipes-graphics/qlibwindowmanager/qlibwindowmanager_git.bb
+++ b/meta-hmi-framework/recipes-graphics/qlibwindowmanager/qlibwindowmanager_git.bb
@@ -8,6 +8,7 @@ RDEPENDS_${PN} = "libwindowmanager"
inherit qmake5
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/qlibwindowmanager.git;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "d5d31fe493c88756831e7cf36255acdccbbdde98"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libqtwindowmanager.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "744df8b7c6ccb4e2254e452eec82f5d0703417cf"
S = "${WORKDIR}/git"
+PV = "1.0+git${SRCPV}"
diff --git a/meta-renesas-kernel/conf/layer.conf b/meta-renesas-kernel/conf/layer.conf
deleted file mode 100644
index fa648fb3..00000000
--- a/meta-renesas-kernel/conf/layer.conf
+++ /dev/null
@@ -1,10 +0,0 @@
-# We have a conf and classes directory, add to BBPATH
-BBPATH =. "${LAYERDIR}:"
-
-# We have recipes-* directories, add to BBFILES
-BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
- ${LAYERDIR}/recipes-*/*/*.bbappend"
-
-BBFILE_COLLECTIONS += "renesas-kernel"
-BBFILE_PATTERN_renesas-kernel = "^${LAYERDIR}/"
-BBFILE_PRIORITY_renesas-kernel = "7"
diff --git a/meta-renesas-kernel/recipes-kernel/linux/files/fuse-rcar.cfg b/meta-renesas-kernel/recipes-kernel/linux/files/fuse-rcar.cfg
deleted file mode 100644
index 0cd162dd..00000000
--- a/meta-renesas-kernel/recipes-kernel/linux/files/fuse-rcar.cfg
+++ /dev/null
@@ -1,2 +0,0 @@
-CONFIG_FUSE_FS=y
-CONFIG_CUSE=m
diff --git a/meta-renesas-kernel/recipes-kernel/linux/files/iptables-rcar.cfg b/meta-renesas-kernel/recipes-kernel/linux/files/iptables-rcar.cfg
deleted file mode 100644
index 7b59bfdf..00000000
--- a/meta-renesas-kernel/recipes-kernel/linux/files/iptables-rcar.cfg
+++ /dev/null
@@ -1,18 +0,0 @@
-CONFIG_NETFILTER=y
-CONFIG_NF_CONNTRACK=y
-CONFIG_NF_CONNTRACK_PROCFS=y
-CONFIG_NF_NAT=y
-CONFIG_NF_NAT_NEEDED=y
-CONFIG_NETFILTER_XTABLES=y
-CONFIG_NETFILTER_XT_TARGET_CT=y
-CONFIG_NETFILTER_XT_TARGET_DSCP=y
-CONFIG_NETFILTER_XT_TARGET_NOTRACK=y
-CONFIG_NF_DEFRAG_IPV4=y
-CONFIG_NF_CONNTRACK_IPV4=y
-CONFIG_NF_CONNTRACK_PROC_COMPAT=y
-CONFIG_IP_NF_IPTABLES=y
-CONFIG_IP_NF_FILTER=y
-CONFIG_NF_NAT_IPV4=y
-CONFIG_IP_NF_TARGET_MASQUERADE=y
-CONFIG_IP_NF_MANGLE=y
-CONFIG_IP_NF_RAW=y
diff --git a/meta-renesas-kernel/recipes-kernel/linux/linux-renesas_%.bbappend b/meta-renesas-kernel/recipes-kernel/linux/linux-renesas_%.bbappend
deleted file mode 100644
index 24682fae..00000000
--- a/meta-renesas-kernel/recipes-kernel/linux/linux-renesas_%.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRC_URI_append_porter = " file://iptables-rcar.cfg \
- file://fuse-rcar.cfg"
diff --git a/templates/feature/agl-audio-soundmanager-framework/50_local.conf.inc b/templates/feature/agl-audio-soundmanager-framework/50_local.conf.inc
index 359928df..58a53389 100644
--- a/templates/feature/agl-audio-soundmanager-framework/50_local.conf.inc
+++ b/templates/feature/agl-audio-soundmanager-framework/50_local.conf.inc
@@ -1,4 +1,4 @@
-DISTRO_FEATURES_append = " agl-audio-soundmanager-framework"
+DISTRO_FEATURES_append = " agl-audio-soundmanager-framework pulseaudio"
PREFERRED_PROVIDER_virtual/audio-framework = "agl-service-audio-soundmanager"
PREFERRED_RPROVIDER_virtual/pulseaudio-config = "pulseaudio-config-soundmanager"
PREFERRED_RPROVIDER_virtual/audiomanager-plugins-config = "audiomanager-plugins-config-soundmanager"
diff --git a/templates/feature/agl-renesas-kernel/50_bblayers.conf.inc b/templates/feature/agl-renesas-kernel/50_bblayers.conf.inc
deleted file mode 100644
index 036e0d34..00000000
--- a/templates/feature/agl-renesas-kernel/50_bblayers.conf.inc
+++ /dev/null
@@ -1,4 +0,0 @@
-BBLAYERS =+ " \
- ${METADIR}/meta-agl-devel/meta-renesas-kernel \
- "
-