summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--templates/feature/agl-lxc/50_bblayers.conf.inc5
-rw-r--r--templates/feature/agl-lxc/50_local.conf.inc9
-rw-r--r--templates/feature/agl-lxc/included.dep2
3 files changed, 11 insertions, 5 deletions
diff --git a/templates/feature/agl-lxc/50_bblayers.conf.inc b/templates/feature/agl-lxc/50_bblayers.conf.inc
index 766d1da3..de0b2864 100644
--- a/templates/feature/agl-lxc/50_bblayers.conf.inc
+++ b/templates/feature/agl-lxc/50_bblayers.conf.inc
@@ -1,3 +1,8 @@
+AGL_META_PYTHON = "${METADIR}/external/meta-openembedded/meta-python"
+AGL_META_NETWORKING = "${METADIR}/external/meta-openembedded/meta-networking"
+AGL_META_FILESYSTEMS = "${METADIR}/external/meta-openembedded/meta-filesystems"
+AGL_META_VIRTUALIZATION = "${METADIR}/external/meta-virtualization"
+
BBLAYERS =+ " \
${METADIR}/external/meta-qt5 \
${METADIR}/meta-agl-devel/meta-agl-lxc \
diff --git a/templates/feature/agl-lxc/50_local.conf.inc b/templates/feature/agl-lxc/50_local.conf.inc
index 6f337415..3c652b41 100644
--- a/templates/feature/agl-lxc/50_local.conf.inc
+++ b/templates/feature/agl-lxc/50_local.conf.inc
@@ -1,7 +1,8 @@
BBMULTICONFIG = "agl-container-guest"
-# Disable the meta-virtualization configuration support enabled by
-# agl-virt. This should be revisited when upgrading past dunfell,
-# as less of the extra configuration may be enabled in the future.
-DISTRO_FEATURES_remove = "virtualization"
+# The meta-virtualization has a sanity-meta-virt check.
+# This checker check 'DISTRO_FEATURES has virtualization', but
+# in case of linux container is not necessary to the 'virtualization'.
+# This should be revisited when upgrading past dunfell, as less of
+# the extra configuration may be enabled in the future.
INHERIT_remove = "sanity-meta-virt"
diff --git a/templates/feature/agl-lxc/included.dep b/templates/feature/agl-lxc/included.dep
index df937c78..b7e96fbb 100644
--- a/templates/feature/agl-lxc/included.dep
+++ b/templates/feature/agl-lxc/included.dep
@@ -1 +1 @@
-agl-virt agl-drm-lease
+agl-drm-lease
9 } /* Name.Attribute */ .highlight .nb { color: #003388 } /* Name.Builtin */ .highlight .nc { color: #bb0066; font-weight: bold } /* Name.Class */ .highlight .no { color: #003366; font-weight: bold } /* Name.Constant */ .highlight .nd { color: #555555 } /* Name.Decorator */ .highlight .ne { color: #bb0066; font-weight: bold } /* Name.Exception */ .highlight .nf { color: #0066bb; font-weight: bold } /* Name.Function */ .highlight .nl { color: #336699; font-style: italic } /* Name.Label */ .highlight .nn { color: #bb0066; font-weight: bold } /* Name.Namespace */ .highlight .py { color: #336699; font-weight: bold } /* Name.Property */ .highlight .nt { color: #bb0066; font-weight: bold } /* Name.Tag */ .highlight .nv { color: #336699 } /* Name.Variable */ .highlight .ow { color: #008800 } /* Operator.Word */ .highlight .w { color: #bbbbbb } /* Text.Whitespace */ .highlight .mb { color: #0000DD; font-weight: bold } /* Literal.Number.Bin */ .highlight .mf { color: #0000DD; font-weight: bold } /* Literal.Number.Float */ .highlight .mh { color: #0000DD; font-weight: bold } /* Literal.Number.Hex */ .highlight .mi { color: #0000DD; font-weight: bold } /* Literal.Number.Integer */ .highlight .mo { color: #0000DD; font-weight: bold } /* Literal.Number.Oct */ .highlight .sa { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Affix */ .highlight .sb { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Backtick */ .highlight .sc { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Char */ .highlight .dl { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Delimiter */ .highlight .sd { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Doc */ .highlight .s2 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Double */ .highlight .se { color: #0044dd; background-color: #fff0f0 } /* Literal.String.Escape */ .highlight .sh { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Heredoc */ .highlight .si { color: #3333bb; background-color: #fff0f0 } /* Literal.String.Interpol */ .highlight .sx { color: #22bb22; background-color: #f0fff0 } /* Literal.String.Other */ .highlight .sr { color: #008800; background-color: #fff0ff } /* Literal.String.Regex */ .highlight .s1 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Single */ .highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */ .highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */ .highlight .vc { color: #336699 } /* Name.Variable.Class */ .highlight .vg { color: #dd7700 } /* Name.Variable.Global */ .highlight .vi { color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */ }
# We have a conf and classes directory, add to BBPATH
BBPATH =. "${LAYERDIR}:"

# We have recipes-* directories, add to BBFILES
BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
            ${LAYERDIR}/recipes-*/*/*.bbappend"

BBFILE_COLLECTIONS += "aglcontainermc"
BBFILE_PATTERN_aglcontainermc = "^${LAYERDIR}/"
BBFILE_PRIORITY_aglcontainermc = "100"

BBFILES_DYNAMIC += " \
    rcar-gen3:${LAYERDIR}/dynamic-layers/meta-rcar-gen3/*/*/*.bb \
    rcar-gen3:${LAYERDIR}/dynamic-layers/meta-rcar-gen3/*/*/*.bbappend \
    raspberrypi:${LAYERDIR}/dynamic-layers/meta-raspberrypi/*/*/*.bb \
    raspberrypi:${LAYERDIR}/dynamic-layers/meta-raspberrypi/*/*/*.bbappend \
    selinux:${LAYERDIR}/dynamic-layers/meta-selinux/*/*/*.bb \
    selinux:${LAYERDIR}/dynamic-layers/meta-selinux/*/*/*.bbappend \
"

LAYERSERIES_COMPAT_aglcontainermc = "scarthgap"
LAYERDEPENDS_aglcontainermc = "aglcore qt5-layer openembedded-layer virtualization-layer agl-drm-lease meta-pipewire"