summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-hmi-framework/recipes-graphics/agl-service-windowmanager-2017/agl-service-windowmanager-2017_git.bb28
-rw-r--r--meta-hmi-framework/recipes-graphics/libwindowmanager/libwindowmanager_git.bb12
2 files changed, 19 insertions, 21 deletions
diff --git a/meta-hmi-framework/recipes-graphics/agl-service-windowmanager-2017/agl-service-windowmanager-2017_git.bb b/meta-hmi-framework/recipes-graphics/agl-service-windowmanager-2017/agl-service-windowmanager-2017_git.bb
index addee324..3207b79b 100644
--- a/meta-hmi-framework/recipes-graphics/agl-service-windowmanager-2017/agl-service-windowmanager-2017_git.bb
+++ b/meta-hmi-framework/recipes-graphics/agl-service-windowmanager-2017/agl-service-windowmanager-2017_git.bb
@@ -1,32 +1,18 @@
-SUMMARY = "Window Manager binding and client library for application"
-DESCRIPTION = "Window Manager 2017 is the binding library \
- "
-HOMEPAGE = ""
-S = "${WORKDIR}/git"
+SUMMARY = "Window Manager service binding for applications"
+DESCRIPTION = "Window Manager 2017 is the service binding for controlling rendering rights \
+ Applications requests to render itself, then Window Manager check policy and notify layout to respective applications \
+ "
+HOMEPAGE = "https://wiki.automotivelinux.org/windowmanager"
SECTION = "graphics"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
DEPENDS = "af-binder json-c wayland wayland-ivi-extension wayland-native"
-RDEPENDS_${PN} = " \
- "
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-windowmanager-2017;protocol=https;branch=master"
-SRCREV = "d5eb8b53ed088db5a25451fc7e3009d3e44ae6bd"
+SRCREV = "9d25a6eaeb93ab7c732b3dbca28b6fa86b15347c"
+S = "${WORKDIR}/git"
inherit cmake aglwgt
#If you would like to output log, uncomment out
#EXTRA_OECMAKE = " -DENABLE_DEBUG_OUTPUT=ON "
-
-do_install_append() {
- install -d ${D}${sysconfdir}/windowmanager
- install -m 0644 ${S}/layers.json ${D}${sysconfdir}/windowmanager/
- install -d ${D}${libdir}/pkgconfig
- install -m 0644 ${B}/windowmanager.pc ${D}${libdir}/pkgconfig
- install -d ${D}${includedir}
- install -m 0644 ${S}/libwindowmanager/libwindowmanager.h ${D}${includedir}
-
- install -m -0755 ${B}/libwindowmanager/libwindowmanager.so ${D}${libdir}/libwindowmanager.so.0.1
- ln -sf libwindowmanager.so.0.1 ${D}${libdir}/libwindowmanager.so
-}
-FILES_${PN} += "${sysconfdir}/windowmanager/layers.json"
diff --git a/meta-hmi-framework/recipes-graphics/libwindowmanager/libwindowmanager_git.bb b/meta-hmi-framework/recipes-graphics/libwindowmanager/libwindowmanager_git.bb
new file mode 100644
index 00000000..4893ca32
--- /dev/null
+++ b/meta-hmi-framework/recipes-graphics/libwindowmanager/libwindowmanager_git.bb
@@ -0,0 +1,12 @@
+SUMMARY = "Window Manager client library for applications"
+SECTION = "graphics"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+DEPENDS = "af-binder json-c"
+RDEPENDS_${PN} = "agl-service-windowmanager-2017"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/libwindowmanager.git;protocol=https;branch=master"
+SRCREV = "922255ac97240980059979ab7975118f46c950a0"
+S = "${WORKDIR}/git"
+
+inherit cmake