summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--README.md5
-rw-r--r--meta-audio-4a-framework/conf/include/agl-audio-4a-framework.inc1
-rw-r--r--meta-audio-4a-framework/meta-agl-demo/recipes-multimedia/4a-mixer/4a-mixer_git.bb2
-rw-r--r--meta-hmi-framework/recipes-demo-hmi/homescreen-2017/homescreen-2017_git.bb1
-rw-r--r--meta-renesas-kernel/conf/layer.conf10
-rw-r--r--meta-renesas-kernel/recipes-kernel/linux/files/fuse-rcar.cfg2
-rw-r--r--meta-renesas-kernel/recipes-kernel/linux/files/iptables-rcar.cfg18
-rw-r--r--meta-renesas-kernel/recipes-kernel/linux/linux-renesas_%.bbappend3
-rw-r--r--templates/feature/agl-renesas-kernel/50_bblayers.conf.inc4
9 files changed, 4 insertions, 42 deletions
diff --git a/README.md b/README.md
index 63bd9fc0..1a5b4861 100644
--- a/README.md
+++ b/README.md
@@ -19,8 +19,8 @@ visit the EG\_VIRT wiki page at: https://wiki.automotivelinux.org/eg-virt
The OEM needs library for AGL
======================================================
-There are some software package that the OEM needs, but not exist in the AGL source.
-This layer is add OEM needs library for AGL.
+There are some software package that the OEM needs, but not exist in the AGL source.
+This layer is add OEM needs library for AGL.
The software packages list:
* boost
@@ -68,7 +68,6 @@ Supported Machines
Reference hardware:
* QEMU (x86-64) - emulated machine: qemux86-64
-* Renesas R-Car Gen2 (R-Car M2) - machine: porter
HMI Framework
======================================================
diff --git a/meta-audio-4a-framework/conf/include/agl-audio-4a-framework.inc b/meta-audio-4a-framework/conf/include/agl-audio-4a-framework.inc
index 935b9ad1..12711f66 100644
--- a/meta-audio-4a-framework/conf/include/agl-audio-4a-framework.inc
+++ b/meta-audio-4a-framework/conf/include/agl-audio-4a-framework.inc
@@ -14,6 +14,7 @@ PACKAGES_pn-alsa-state_remove = "alsa-state-dev"
PACKAGES_pn-alsa-state_remove = "alsa-states-dev"
PACKAGES_pn-alsa-state = "alsa-state alsa-states"
+PREFERRED_PROVIDER_virtual/mixer ?= "4a-mixer"
PREFERRED_RPROVIDER_virtual/mixer ?= "4a-mixer"
PREFERRED_VERSION_alsa-lib = "1.1.6"
diff --git a/meta-audio-4a-framework/meta-agl-demo/recipes-multimedia/4a-mixer/4a-mixer_git.bb b/meta-audio-4a-framework/meta-agl-demo/recipes-multimedia/4a-mixer/4a-mixer_git.bb
index 93fd1b70..f5192ae3 100644
--- a/meta-audio-4a-framework/meta-agl-demo/recipes-multimedia/4a-mixer/4a-mixer_git.bb
+++ b/meta-audio-4a-framework/meta-agl-demo/recipes-multimedia/4a-mixer/4a-mixer_git.bb
@@ -15,11 +15,11 @@ S = "${WORKDIR}/git"
# build-time dependencies
DEPENDS += "qtquickcontrols2 \
qtwebsockets \
- pulseaudio \
virtual/libhomescreen \
qlibwindowmanager \
"
+PROVIDES += "virtual/mixer"
RPROVIDES_${PN} += "virtual/mixer"
inherit cmake_qt5 aglwgt
diff --git a/meta-hmi-framework/recipes-demo-hmi/homescreen-2017/homescreen-2017_git.bb b/meta-hmi-framework/recipes-demo-hmi/homescreen-2017/homescreen-2017_git.bb
index 704dbce0..eabc5d09 100644
--- a/meta-hmi-framework/recipes-demo-hmi/homescreen-2017/homescreen-2017_git.bb
+++ b/meta-hmi-framework/recipes-demo-hmi/homescreen-2017/homescreen-2017_git.bb
@@ -9,7 +9,6 @@ DEPENDS = "\
qtbase \
qtdeclarative \
qtquickcontrols2 \
- pulseaudio \
agl-service-homescreen-2017 \
agl-service-windowmanager-2017 \
agl-service-weather \
diff --git a/meta-renesas-kernel/conf/layer.conf b/meta-renesas-kernel/conf/layer.conf
deleted file mode 100644
index fa648fb3..00000000
--- a/meta-renesas-kernel/conf/layer.conf
+++ /dev/null
@@ -1,10 +0,0 @@
-# We have a conf and classes directory, add to BBPATH
-BBPATH =. "${LAYERDIR}:"
-
-# We have recipes-* directories, add to BBFILES
-BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
- ${LAYERDIR}/recipes-*/*/*.bbappend"
-
-BBFILE_COLLECTIONS += "renesas-kernel"
-BBFILE_PATTERN_renesas-kernel = "^${LAYERDIR}/"
-BBFILE_PRIORITY_renesas-kernel = "7"
diff --git a/meta-renesas-kernel/recipes-kernel/linux/files/fuse-rcar.cfg b/meta-renesas-kernel/recipes-kernel/linux/files/fuse-rcar.cfg
deleted file mode 100644
index 0cd162dd..00000000
--- a/meta-renesas-kernel/recipes-kernel/linux/files/fuse-rcar.cfg
+++ /dev/null
@@ -1,2 +0,0 @@
-CONFIG_FUSE_FS=y
-CONFIG_CUSE=m
diff --git a/meta-renesas-kernel/recipes-kernel/linux/files/iptables-rcar.cfg b/meta-renesas-kernel/recipes-kernel/linux/files/iptables-rcar.cfg
deleted file mode 100644
index 7b59bfdf..00000000
--- a/meta-renesas-kernel/recipes-kernel/linux/files/iptables-rcar.cfg
+++ /dev/null
@@ -1,18 +0,0 @@
-CONFIG_NETFILTER=y
-CONFIG_NF_CONNTRACK=y
-CONFIG_NF_CONNTRACK_PROCFS=y
-CONFIG_NF_NAT=y
-CONFIG_NF_NAT_NEEDED=y
-CONFIG_NETFILTER_XTABLES=y
-CONFIG_NETFILTER_XT_TARGET_CT=y
-CONFIG_NETFILTER_XT_TARGET_DSCP=y
-CONFIG_NETFILTER_XT_TARGET_NOTRACK=y
-CONFIG_NF_DEFRAG_IPV4=y
-CONFIG_NF_CONNTRACK_IPV4=y
-CONFIG_NF_CONNTRACK_PROC_COMPAT=y
-CONFIG_IP_NF_IPTABLES=y
-CONFIG_IP_NF_FILTER=y
-CONFIG_NF_NAT_IPV4=y
-CONFIG_IP_NF_TARGET_MASQUERADE=y
-CONFIG_IP_NF_MANGLE=y
-CONFIG_IP_NF_RAW=y
diff --git a/meta-renesas-kernel/recipes-kernel/linux/linux-renesas_%.bbappend b/meta-renesas-kernel/recipes-kernel/linux/linux-renesas_%.bbappend
deleted file mode 100644
index 24682fae..00000000
--- a/meta-renesas-kernel/recipes-kernel/linux/linux-renesas_%.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRC_URI_append_porter = " file://iptables-rcar.cfg \
- file://fuse-rcar.cfg"
diff --git a/templates/feature/agl-renesas-kernel/50_bblayers.conf.inc b/templates/feature/agl-renesas-kernel/50_bblayers.conf.inc
deleted file mode 100644
index 036e0d34..00000000
--- a/templates/feature/agl-renesas-kernel/50_bblayers.conf.inc
+++ /dev/null
@@ -1,4 +0,0 @@
-BBLAYERS =+ " \
- ${METADIR}/meta-agl-devel/meta-renesas-kernel \
- "
-