summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-audio-4a-framework/recipes-multimedia/pulseaudio/files/default.pa.4a (renamed from meta-audio-4a-framework/recipes-multimedia/pulseaudio/files/90-4a-modules.pa)21
-rw-r--r--meta-audio-4a-framework/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend13
-rw-r--r--meta-hmi-framework/recipes-demo-hmi/homescreen-2017/homescreen-2017_git.bb3
-rw-r--r--meta-hmi-framework/recipes-graphics/agl-service-windowmanager-2017/agl-service-windowmanager-2017_git.bb3
-rw-r--r--meta-hmi-framework/recipes-graphics/libwindowmanager/libwindowmanager_git.bb3
5 files changed, 29 insertions, 14 deletions
diff --git a/meta-audio-4a-framework/recipes-multimedia/pulseaudio/files/90-4a-modules.pa b/meta-audio-4a-framework/recipes-multimedia/pulseaudio/files/default.pa.4a
index e041471d..0afab22b 100644
--- a/meta-audio-4a-framework/recipes-multimedia/pulseaudio/files/90-4a-modules.pa
+++ b/meta-audio-4a-framework/recipes-multimedia/pulseaudio/files/default.pa.4a
@@ -1,3 +1,22 @@
+#!/usr/bin/pulseaudio -nF
+#
+
+.fail
+
+### Automatically load driver modules for Bluetooth hardware
+.ifexists module-bluetooth-policy.so
+load-module module-bluetooth-policy
+.endif
+
+.ifexists module-bluetooth-discover.so
+load-module module-bluetooth-discover headset=ofono
+.endif
+
+load-module module-native-protocol-unix
+
+### Automatically suspend sinks/sources that become idle for too long
+load-module module-suspend-on-idle timeout=0
+
load-module module-alsa-sink device=Fallback
#load-module module-alsa-sink device=CustomLow
load-module module-alsa-sink device=Radio
@@ -10,3 +29,5 @@ load-module module-alsa-sink device=Phone
#load-module module-alsa-sink device=CustomHigh
#load-module module-alsa-sink device=Warning
load-module module-alsa-sink device=Emergency
+
+set-default-sink alsa_output.Fallback
diff --git a/meta-audio-4a-framework/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend b/meta-audio-4a-framework/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend
index 6b122f5e..d8a84990 100644
--- a/meta-audio-4a-framework/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend
+++ b/meta-audio-4a-framework/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend
@@ -1,16 +1,7 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRC_URI += "file://90-4a-modules.pa"
+SRC_URI += "file://default.pa.4a"
-# Add .include directive to default.pa so optional configuration can be added
do_install_append () {
- if [ ! -e ${D}${sysconfdir}/pulse/default.d/ ]; then
- echo ".include ${sysconfdir}/pulse/default.d" >> ${D}${sysconfdir}/pulse/default.pa
- install -d ${D}${sysconfdir}/pulse/default.d
- fi
- install -m 0644 ${WORKDIR}/90-4a-modules.pa ${D}${sysconfdir}/pulse/default.d/
-
- for m in module-udev-detect module-suspend-on-idle;do
- sed -i -e "s|^load-module ${m}|#load-module ${m}|" ${D}${sysconfdir}/pulse/default.pa
- done
+ cp ${WORKDIR}/default.pa.4a ${D}${sysconfdir}/pulse/default.pa
}
diff --git a/meta-hmi-framework/recipes-demo-hmi/homescreen-2017/homescreen-2017_git.bb b/meta-hmi-framework/recipes-demo-hmi/homescreen-2017/homescreen-2017_git.bb
index cffce1cb..a28e1ce3 100644
--- a/meta-hmi-framework/recipes-demo-hmi/homescreen-2017/homescreen-2017_git.bb
+++ b/meta-hmi-framework/recipes-demo-hmi/homescreen-2017/homescreen-2017_git.bb
@@ -19,7 +19,8 @@ DEPENDS = "\
inherit qmake5 systemd pkgconfig aglwgt
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/homescreen-2017;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "096c0729d0babd4adc3deeced69439ea38af8d7d"
+SRCREV = "db9f41d75fb4460f668117c69be05c4d4d4c7c7c"
+PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git/"
PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
diff --git a/meta-hmi-framework/recipes-graphics/agl-service-windowmanager-2017/agl-service-windowmanager-2017_git.bb b/meta-hmi-framework/recipes-graphics/agl-service-windowmanager-2017/agl-service-windowmanager-2017_git.bb
index f6ac8e42..b5245602 100644
--- a/meta-hmi-framework/recipes-graphics/agl-service-windowmanager-2017/agl-service-windowmanager-2017_git.bb
+++ b/meta-hmi-framework/recipes-graphics/agl-service-windowmanager-2017/agl-service-windowmanager-2017_git.bb
@@ -15,7 +15,8 @@ DEPENDS = "af-binder json-c wayland wayland-ivi-extension wayland-native"
inherit cmake aglwgt
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-windowmanager-2017;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "d6cd19121e0821cf40633533ae22c93c88f9e33b"
+SRCREV = "17339414fd26e831710b0b7f3a429b4dfb868d45"
+PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
#If you would like to output log, uncomment out
diff --git a/meta-hmi-framework/recipes-graphics/libwindowmanager/libwindowmanager_git.bb b/meta-hmi-framework/recipes-graphics/libwindowmanager/libwindowmanager_git.bb
index 4e34ace0..17a7ac11 100644
--- a/meta-hmi-framework/recipes-graphics/libwindowmanager/libwindowmanager_git.bb
+++ b/meta-hmi-framework/recipes-graphics/libwindowmanager/libwindowmanager_git.bb
@@ -10,5 +10,6 @@ RDEPENDS_${PN} = "agl-service-windowmanager-2017"
inherit cmake
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/libwindowmanager.git;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "68462c7180f69f2c9df1e161a0f86a1f52f33360"
+SRCREV = "026af4256b9b69ffd52972d6da0cb394dff2b0e6"
S = "${WORKDIR}/git"
+PV = "1.0+git${SRCPV}"