summaryrefslogtreecommitdiffstats
path: root/_to_remove/meta-speech-framework/conf/layer.conf
diff options
context:
space:
mode:
Diffstat (limited to '_to_remove/meta-speech-framework/conf/layer.conf')
-rw-r--r--_to_remove/meta-speech-framework/conf/layer.conf27
1 files changed, 27 insertions, 0 deletions
diff --git a/_to_remove/meta-speech-framework/conf/layer.conf b/_to_remove/meta-speech-framework/conf/layer.conf
new file mode 100644
index 00000000..b3f004ce
--- /dev/null
+++ b/_to_remove/meta-speech-framework/conf/layer.conf
@@ -0,0 +1,27 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# Let us add layer-specific bbappends which are only applied when that
+# layer is included in our configuration -
+# e.g. only add layers if a bsp is present.
+# This is based on the BBFILE_COLLECTIONS name of the layer.
+# We use either the BBFILE_COLLECTIONS name of the layer directly (meta-ti)
+BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bbappend' % layer \
+ for layer in BBFILE_COLLECTIONS.split())}"
+BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bb' % layer \
+ for layer in BBFILE_COLLECTIONS.split())}"
+# or we prepend it with meta- (e.g. rpi, fsl*)
+BBFILES += "${@' '.join('${LAYERDIR}/meta-%s/recipes*/*/*.bbappend' % layer \
+ for layer in BBFILE_COLLECTIONS.split())}"
+BBFILES += "${@' '.join('${LAYERDIR}/meta-%s/recipes*/*/*.bb' % layer \
+ for layer in BBFILE_COLLECTIONS.split())}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "speech-framework"
+BBFILE_PATTERN_speech-framework = "^${LAYERDIR}/"
+BBFILE_PRIORITY_speech-framework = "8"
+
+LAYERSERIES_COMPAT_speech-framework = "dunfell"