summaryrefslogtreecommitdiffstats
path: root/_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service
diff options
context:
space:
mode:
Diffstat (limited to '_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service')
-rw-r--r--_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voice-high-config/voice-high.json1
-rw-r--r--_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voice-high-config_1.0.bb20
-rw-r--r--_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config/AlexaAutoCoreEngineConfig.json.in64
-rw-r--r--_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb51
-rw-r--r--_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service/0001-remove-library-dependency-copying.patch33
-rw-r--r--_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service/0007-add-autobuild-scripts.patch286
-rw-r--r--_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service/alexa.json14
-rw-r--r--_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service_git.bb58
8 files changed, 527 insertions, 0 deletions
diff --git a/_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voice-high-config/voice-high.json b/_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voice-high-config/voice-high.json
new file mode 100644
index 00000000..f460ccfc
--- /dev/null
+++ b/_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voice-high-config/voice-high.json
@@ -0,0 +1 @@
+{ "default": "VA-001" }
diff --git a/_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voice-high-config_1.0.bb b/_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voice-high-config_1.0.bb
new file mode 100644
index 00000000..6b0203a9
--- /dev/null
+++ b/_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voice-high-config_1.0.bb
@@ -0,0 +1,20 @@
+SUMMARY = "High level voice service binding default voiceagent configuration for Alexa"
+DESCRIPTION = "Alexa default voiceagent JSON configuration file for agl-service-voice-high binding"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/agl-service-voice-high"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = "file://voice-high.json"
+
+inherit allarch
+
+do_compile[noexec] = "1"
+
+do_install () {
+ install -D -m 644 ${WORKDIR}/voice-high.json ${D}${sysconfdir}/xdg/AGL/voice-high.json
+}
+
+RPROVIDES:${PN} += "virtual/voice-high-config"
+
diff --git a/_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config/AlexaAutoCoreEngineConfig.json.in b/_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config/AlexaAutoCoreEngineConfig.json.in
new file mode 100644
index 00000000..4bf00f89
--- /dev/null
+++ b/_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config/AlexaAutoCoreEngineConfig.json.in
@@ -0,0 +1,64 @@
+{
+ "deviceInfo":
+ {
+ "clientId": "@@ALEXA_CLIENTID@@",
+ "deviceSerialNumber": "@@ALEXA_SERIALNUMBER@@",
+ "productId": "@@ALEXA_PRODUCTID@@",
+ "manufacturerName": "@@ALEXA_MFG_NAME@@",
+ "description": "@@ALEXA_DESCRIPTION@@"
+ },
+ "libcurlUtils":
+ {
+ "CURLOPT_CAPATH":"/etc/ssl/certs"
+ },
+ "deviceSettings": {
+ "defaultLocale":"@@ALEXA_LOCALE@@",
+ "defaultTimezone":"@@ALEXA_TIMEZONE@@"
+ },
+ "aace.vehicle": {
+ "info": {
+ "make": "Amazon",
+ "model": "AutoSDK",
+ "year": "2019",
+ "trim": "aac",
+ "geography": "US",
+ "version": "1.2.3",
+ "os": "AGL",
+ "arch": "aarch64",
+ "language": "en_US",
+ "microphone": "SingleArray",
+ "countries": "US,GB,IE,CA,DE,AT,IN,JP,AU,NZ,FR",
+ "vehicleIdentifier": "Sample Identifier ABC"
+ },
+ "operatingCountry": "US",
+ "currentLocation": "36.1363,-115.1513"
+ },
+ "aace.audio.input": {
+ "voice": "Default"
+ },
+ "aace.audio.output": {
+ "tts": "Speech-Low",
+ "music": "Speech-High",
+ "alarm": "Custom-Low"
+ },
+ "aace.wakeword": {
+ "enabled":@@ALEXA_WAKEWORD@@
+ },
+ "aace.cbl": {
+ "enabled": true
+ },
+ "aace.localmediasource": {
+ "enabled":false,
+ "sources": {
+ "bluetooth":true,
+ "usb":true,
+ "fmRadio":true,
+ "amRadio":true,
+ "satelliteRadio":false,
+ "lineIn":false,
+ "compactDisc":true,
+ "siriusXM":false,
+ "dab":false
+ }
+ }
+}
diff --git a/_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb b/_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb
new file mode 100644
index 00000000..13d259b8
--- /dev/null
+++ b/_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb
@@ -0,0 +1,51 @@
+SUMMARY = "Alexa service binding default configuration to connect to Alexa"
+DESCRIPTION = "Alexa alexa-voiceagent-service binding configuration files"
+HOMEPAGE = "https://github.com/alexa/alexa-auto-sdk/tree/master/platforms/agl/alexa-voiceagent-service"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = "file://AlexaAutoCoreEngineConfig.json.in"
+
+inherit allarch
+
+ALEXA_WAKEWORD ??= "false"
+ALEXA_LOCALE ??= "en-US"
+ALEXA_TIMEZONE ??= "America/Vancouver"
+
+do_compile[noexec] = "1"
+
+do_install () {
+ if [ -z "${ALEXA_CLIENTID}" ]; then
+ bbfatal "ALEXA_CLIENTID not defined in your environment e.g. conf/local.conf"
+ fi
+ if [ -z "${ALEXA_SERIALNUMBER}" ]; then
+ bbfatal "ALEXA_SERIALNUMBER not defined in your environment e.g. conf/local.conf"
+ fi
+ if [ -z "${ALEXA_PRODUCTID}" ]; then
+ bbfatal "ALEXA_PRODUCTID not defined in your environment e.g. conf/local.conf"
+ fi
+ if [ -z "${ALEXA_MFG_NAME}" ]; then
+ bbfatal "ALEXA_MFG_NAME not defined in your environment e.g. conf/local.conf"
+ fi
+ if [ -z "${ALEXA_DESCRIPTION}" ]; then
+ bbfatal "ALEXA_DESCRIPTION not defined in your environment e.g. conf/local.conf"
+ fi
+
+ #replace
+ sed -e "s|@@ALEXA_CLIENTID@@|${ALEXA_CLIENTID}|" \
+ -e "s|@@ALEXA_SERIALNUMBER@@|${ALEXA_SERIALNUMBER}|" \
+ -e "s|@@ALEXA_PRODUCTID@@|${ALEXA_PRODUCTID}|" \
+ -e "s|@@ALEXA_MFG_NAME@@|${ALEXA_MFG_NAME}|" \
+ -e "s|@@ALEXA_DESCRIPTION@@|${ALEXA_DESCRIPTION}|" \
+ -e "s|@@ALEXA_WAKEWORD@@|${ALEXA_WAKEWORD}|" \
+ -e "s|@@ALEXA_LOCALE@@|${ALEXA_LOCALE}|" \
+ -e "s|@@ALEXA_TIMEZONE@@|${ALEXA_TIMEZONE}|" \
+ ${WORKDIR}/AlexaAutoCoreEngineConfig.json.in > ${WORKDIR}/AlexaAutoCoreEngineConfig.json
+
+ # install
+ install -D -m 644 ${WORKDIR}/AlexaAutoCoreEngineConfig.json ${D}${sysconfdir}/xdg/AGL/AlexaAutoCoreEngineConfig.json
+}
+
+RPROVIDES:${PN} += "virtual/alexa-voiceagent-config"
diff --git a/_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service/0001-remove-library-dependency-copying.patch b/_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service/0001-remove-library-dependency-copying.patch
new file mode 100644
index 00000000..ee61ac20
--- /dev/null
+++ b/_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service/0001-remove-library-dependency-copying.patch
@@ -0,0 +1,33 @@
+Remove copying of library dependencies
+
+Since we are targeting building into an image, the widget build does
+not have to copy host library dependencies into the widget as it would
+when being built standalone with the SDK. Remove the copying, as
+runtime dependencies will be used to pull the libraries in.
+
+Upstream-Status: Inappropriate [embedded specific]
+
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
+
+diff --git a/libs/CMakeLists.txt b/libs/CMakeLists.txt
+index 8a955feb..5b097877 100644
+--- a/libs/CMakeLists.txt
++++ b/libs/CMakeLists.txt
+@@ -92,16 +92,11 @@ add_avs_library(SQLiteStorage ${AAC_HOME}/lib/libSQLiteStorage.so)
+ add_avs_library(SystemSoundPlayer ${AAC_HOME}/lib/libSystemSoundPlayer.so)
+ add_avs_library(TemplateRuntime ${AAC_HOME}/lib/libTemplateRuntime.so)
+ add_avs_library(ToggleController ${AAC_HOME}/lib/libToggleController.so)
+-add_avs_library(curl ${AAC_HOME}/lib/libcurl.so.4)
+-add_avs_library(nghttp2 ${AAC_HOME}/lib/libnghttp2.so.14)
+-add_avs_library(opus ${AAC_HOME}/lib/libopus.so.0)
+-add_avs_library(sqlite3 ${AAC_HOME}/lib/libsqlite3.so.0)
+
+-if(EXISTS ${AAC_HOME}/lib/libpryon_lite.so.1.13)
++if(EXISTS ${AAC_HOME}/lib/libAACEAmazonLiteEngine.so)
+ add_aace_library(AACEAmazonLiteEngine)
+ add_avs_library(AMAZONLITE ${AAC_HOME}/lib/libAMAZONLITE.so)
+ add_avs_library(KeywordDetectorProvider ${AAC_HOME}/lib/libKeywordDetectorProvider.so)
+- add_avs_library(pryon_lite ${AAC_HOME}/lib/libpryon_lite.so.1.13)
+ endif()
+
+ if(EXISTS ${AAC_HOME}/share/cmake/AACESystemAudio.cmake)
diff --git a/_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service/0007-add-autobuild-scripts.patch b/_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service/0007-add-autobuild-scripts.patch
new file mode 100644
index 00000000..5886709b
--- /dev/null
+++ b/_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service/0007-add-autobuild-scripts.patch
@@ -0,0 +1,286 @@
+Add autobuild scripts
+
+Add autobuild scripts and update .gitignore to not ignore them.
+The autobuild/agl/autobuild script will be required for building widgets
+in AGL, add the latest version to the voiceagent source tree.
+
+Upstream-Status: Pending
+
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
+
+diff --git a/.gitignore b/.gitignore
+index b3c1108..edbf1b5 100644
+--- a/.gitignore
++++ b/.gitignore
+@@ -1,3 +1,2 @@
+-autobuild/
+ build/
+ alexa-voiceagent-apidef.h
+diff --git a/autobuild/agl/autobuild b/autobuild/agl/autobuild
+new file mode 100755
+index 0000000..16181b8
+--- /dev/null
++++ b/autobuild/agl/autobuild
+@@ -0,0 +1,128 @@
++#!/usr/bin/make -f
++# Copyright (C) 2015 - 2018 "IoT.bzh"
++# Copyright (C) 2020 Konsulko Group
++# Author "Romain Forlot" <romain.forlot@iot.bzh>
++#
++# Licensed under the Apache License, Version 2.0 (the "License");
++# you may not use this file except in compliance with the License.
++# You may obtain a copy of the License at
++#
++# http://www.apache.org/licenses/LICENSE-2.0
++#
++# Unless required by applicable law or agreed to in writing, software
++# distributed under the License is distributed on an "AS IS" BASIS,
++# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
++# See the License for the specific language governing permissions and
++# limitations under the License.
++
++THISFILE := $(lastword $(MAKEFILE_LIST))
++ROOT_DIR := $(abspath $(dir $(THISFILE))/../..)
++
++# Build directories
++# Note that the debug/test/coverage directories are defined in relation
++# to the release directory (BUILD_DIR), this needs to be kept in mind
++# if over-riding it and building those widget types, the specific widget
++# type variable (e.g. BUILD_DIR_DEBUG) may also need to be specified
++# to yield the desired output hierarchy.
++BUILD_DIR = $(ROOT_DIR)/build
++BUILD_DIR_DEBUG = $(abspath $(BUILD_DIR)/../build-debug)
++BUILD_DIR_TEST = $(abspath $(BUILD_DIR)/../build-test)
++BUILD_DIR_COVERAGE = $(abspath $(BUILD_DIR)/../build-coverage)
++
++# Output directory variable for use in pattern rules.
++# This is intended for internal use only, hence the explicit override
++# definition.
++override OUTPUT_DIR = $(BUILD_DIR)
++
++# Final install directory for widgets
++DEST = $(OUTPUT_DIR)
++
++# Default build type for release/test builds
++BUILD_TYPE = RELEASE
++
++.PHONY: all help update install distclean
++.PHONY: clean clean-release clean-debug clean-test clean-coverage clean-all
++.PHONY: configure configure-release configure-debug configure-test configure-coverage
++.PHONY: build build-release build-debug build-test build-coverage build-all
++.PHONY: package package-release package-debug package-test package-coverage package-all
++
++help:
++ @echo "List of targets available:"
++ @echo ""
++ @echo "- all"
++ @echo "- help"
++ @echo "- clean"
++ @echo "- distclean"
++ @echo "- configure"
++ @echo "- build: compilation, link and prepare files for package into a widget"
++ @echo "- package: output a widget file '*.wgt'"
++ @echo "- install: install in your $(CMAKE_INSTALL_DIR) directory"
++ @echo ""
++ @echo "Usage: ./autobuild/agl/autobuild package DEST=${HOME}/opt"
++ @echo "Don't use your build dir as DEST as wgt file is generated at this location"
++
++all: package-all
++
++# Target specific variable over-rides so static pattern rules can be
++# used for the various type-specific targets.
++
++configure-test build-test package-test clean-test: OUTPUT_DIR = $(BUILD_DIR_TEST)
++
++configure-coverage build-coverage package-coverage clean-coverage: OUTPUT_DIR = $(BUILD_DIR_COVERAGE)
++configure-coverage build-coverage package-coverage: BUILD_TYPE = COVERAGE
++
++configure-debug build-debug package-debug clean-debug: OUTPUT_DIR = $(BUILD_DIR_DEBUG)
++configure-debug build-debug package-debug: BUILD_TYPE = DEBUG
++
++clean-release clean-test clean-debug clean-coverage:
++ @if [ -d $(OUTPUT_DIR) ]; then \
++ $(MAKE) -C $(OUTPUT_DIR) $(CLEAN_ARGS) clean; \
++ else \
++ echo Nothing to clean; \
++ fi
++
++clean: clean-release
++
++clean-all: clean-release clean-test clean-debug clean-coverage
++
++distclean: clean-all
++
++configure-release configure-test configure-debug configure-coverage:
++ @mkdir -p $(OUTPUT_DIR)
++ @if [ ! -f $(OUTPUT_DIR)/Makefile ]; then \
++ (cd $(OUTPUT_DIR) && cmake -S $(ROOT_DIR) -DCMAKE_BUILD_TYPE=$(BUILD_TYPE) $(CONFIGURE_ARGS)); \
++ fi
++
++configure: configure-release
++
++build-release build-debug build-coverage: build-%: configure-%
++ @cmake --build $(OUTPUT_DIR) $(BUILD_ARGS) --target all
++
++# Kept for consistency, empty to avoid building everything for test widget
++build-test: configure-test
++
++build: build-release
++
++build-all: build-release build-debug build-test build-coverage
++
++package-release package-debug package-coverage: package-%: build-%
++ @cmake --build $(OUTPUT_DIR) $(PACKAGE_ARGS) --target widget
++ @if [ "$(abspath $(DEST))" != "$(abspath $(OUTPUT_DIR))" ]; then \
++ mkdir -p $(DEST) && cp $(OUTPUT_DIR)/*.wgt $(DEST); \
++ fi
++
++package-test: build-test
++ @cmake --build $(OUTPUT_DIR) $(PACKAGE_ARGS) --target test_widget
++ @if [ "$(abspath $(DEST))" != "$(abspath $(OUTPUT_DIR))" ]; then \
++ mkdir -p $(DEST) && cp $(OUTPUT_DIR)/*.wgt $(DEST); \
++ fi
++
++package: package-release
++
++package-all: package-release package-test package-coverage package-debug
++
++update: configure
++ @cmake --build $(BUILD_DIR) --target autobuild
++
++install: build
++ @cmake --build $(BUILD_DIR) $(INSTALL_ARGS) --target install
+diff --git a/autobuild/linux/autobuild b/autobuild/linux/autobuild
+new file mode 100755
+index 0000000..16181b8
+--- /dev/null
++++ b/autobuild/linux/autobuild
+@@ -0,0 +1,128 @@
++#!/usr/bin/make -f
++# Copyright (C) 2015 - 2018 "IoT.bzh"
++# Copyright (C) 2020 Konsulko Group
++# Author "Romain Forlot" <romain.forlot@iot.bzh>
++#
++# Licensed under the Apache License, Version 2.0 (the "License");
++# you may not use this file except in compliance with the License.
++# You may obtain a copy of the License at
++#
++# http://www.apache.org/licenses/LICENSE-2.0
++#
++# Unless required by applicable law or agreed to in writing, software
++# distributed under the License is distributed on an "AS IS" BASIS,
++# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
++# See the License for the specific language governing permissions and
++# limitations under the License.
++
++THISFILE := $(lastword $(MAKEFILE_LIST))
++ROOT_DIR := $(abspath $(dir $(THISFILE))/../..)
++
++# Build directories
++# Note that the debug/test/coverage directories are defined in relation
++# to the release directory (BUILD_DIR), this needs to be kept in mind
++# if over-riding it and building those widget types, the specific widget
++# type variable (e.g. BUILD_DIR_DEBUG) may also need to be specified
++# to yield the desired output hierarchy.
++BUILD_DIR = $(ROOT_DIR)/build
++BUILD_DIR_DEBUG = $(abspath $(BUILD_DIR)/../build-debug)
++BUILD_DIR_TEST = $(abspath $(BUILD_DIR)/../build-test)
++BUILD_DIR_COVERAGE = $(abspath $(BUILD_DIR)/../build-coverage)
++
++# Output directory variable for use in pattern rules.
++# This is intended for internal use only, hence the explicit override
++# definition.
++override OUTPUT_DIR = $(BUILD_DIR)
++
++# Final install directory for widgets
++DEST = $(OUTPUT_DIR)
++
++# Default build type for release/test builds
++BUILD_TYPE = RELEASE
++
++.PHONY: all help update install distclean
++.PHONY: clean clean-release clean-debug clean-test clean-coverage clean-all
++.PHONY: configure configure-release configure-debug configure-test configure-coverage
++.PHONY: build build-release build-debug build-test build-coverage build-all
++.PHONY: package package-release package-debug package-test package-coverage package-all
++
++help:
++ @echo "List of targets available:"
++ @echo ""
++ @echo "- all"
++ @echo "- help"
++ @echo "- clean"
++ @echo "- distclean"
++ @echo "- configure"
++ @echo "- build: compilation, link and prepare files for package into a widget"
++ @echo "- package: output a widget file '*.wgt'"
++ @echo "- install: install in your $(CMAKE_INSTALL_DIR) directory"
++ @echo ""
++ @echo "Usage: ./autobuild/agl/autobuild package DEST=${HOME}/opt"
++ @echo "Don't use your build dir as DEST as wgt file is generated at this location"
++
++all: package-all
++
++# Target specific variable over-rides so static pattern rules can be
++# used for the various type-specific targets.
++
++configure-test build-test package-test clean-test: OUTPUT_DIR = $(BUILD_DIR_TEST)
++
++configure-coverage build-coverage package-coverage clean-coverage: OUTPUT_DIR = $(BUILD_DIR_COVERAGE)
++configure-coverage build-coverage package-coverage: BUILD_TYPE = COVERAGE
++
++configure-debug build-debug package-debug clean-debug: OUTPUT_DIR = $(BUILD_DIR_DEBUG)
++configure-debug build-debug package-debug: BUILD_TYPE = DEBUG
++
++clean-release clean-test clean-debug clean-coverage:
++ @if [ -d $(OUTPUT_DIR) ]; then \
++ $(MAKE) -C $(OUTPUT_DIR) $(CLEAN_ARGS) clean; \
++ else \
++ echo Nothing to clean; \
++ fi
++
++clean: clean-release
++
++clean-all: clean-release clean-test clean-debug clean-coverage
++
++distclean: clean-all
++
++configure-release configure-test configure-debug configure-coverage:
++ @mkdir -p $(OUTPUT_DIR)
++ @if [ ! -f $(OUTPUT_DIR)/Makefile ]; then \
++ (cd $(OUTPUT_DIR) && cmake -S $(ROOT_DIR) -DCMAKE_BUILD_TYPE=$(BUILD_TYPE) $(CONFIGURE_ARGS)); \
++ fi
++
++configure: configure-release
++
++build-release build-debug build-coverage: build-%: configure-%
++ @cmake --build $(OUTPUT_DIR) $(BUILD_ARGS) --target all
++
++# Kept for consistency, empty to avoid building everything for test widget
++build-test: configure-test
++
++build: build-release
++
++build-all: build-release build-debug build-test build-coverage
++
++package-release package-debug package-coverage: package-%: build-%
++ @cmake --build $(OUTPUT_DIR) $(PACKAGE_ARGS) --target widget
++ @if [ "$(abspath $(DEST))" != "$(abspath $(OUTPUT_DIR))" ]; then \
++ mkdir -p $(DEST) && cp $(OUTPUT_DIR)/*.wgt $(DEST); \
++ fi
++
++package-test: build-test
++ @cmake --build $(OUTPUT_DIR) $(PACKAGE_ARGS) --target test_widget
++ @if [ "$(abspath $(DEST))" != "$(abspath $(OUTPUT_DIR))" ]; then \
++ mkdir -p $(DEST) && cp $(OUTPUT_DIR)/*.wgt $(DEST); \
++ fi
++
++package: package-release
++
++package-all: package-release package-test package-coverage package-debug
++
++update: configure
++ @cmake --build $(BUILD_DIR) --target autobuild
++
++install: build
++ @cmake --build $(BUILD_DIR) $(INSTALL_ARGS) --target install
diff --git a/_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service/alexa.json b/_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service/alexa.json
new file mode 100644
index 00000000..48918015
--- /dev/null
+++ b/_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service/alexa.json
@@ -0,0 +1,14 @@
+{
+ "id": "VA-001",
+ "active": true,
+ "name": "Alexa",
+ "api": "alexa-voiceagent",
+ "wakewords": [
+ "alexa",
+ "computer",
+ "echo"
+ ],
+ "activewakeword": "alexa",
+ "description": "Alexa voice assistant by Amazon.",
+ "vendor": "Amazon.com Services Inc"
+}
diff --git a/_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service_git.bb b/_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service_git.bb
new file mode 100644
index 00000000..c08377cd
--- /dev/null
+++ b/_to_remove/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service_git.bb
@@ -0,0 +1,58 @@
+SUMMARY = "Alexa voice agent binding"
+DESCRIPTION = "alexa-voiceagent-service is an Alexa Auto SDK based voiceagent binding"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/agl-service-voice-high"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://License.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+DEPENDS = " \
+ libafb-helpers \
+ libappcontroller \
+ avs-device-sdk \
+ aac-module-core \
+ aac-module-alexa \
+ aac-module-address-book \
+ aac-module-car-control \
+ aac-module-cbl \
+ aac-module-contact-uploader \
+ aac-module-navigation \
+ aac-module-phone-control \
+ aac-module-system-audio \
+ ${@bb.utils.contains("ALEXA_WAKEWORD", "true", "aac-module-amazonlite pryon-lite", "", d)} \
+"
+
+SRC_URI = "git://github.com/alexa/alexa-auto-sdk.git;protocol=https;branch=2.3 \
+ file://alexa.json \
+ file://0001-remove-library-dependency-copying.patch \
+ file://0007-add-autobuild-scripts.patch \
+"
+SRCREV = "d46f22b453f528868b483e39bc7a057ca68a5199"
+
+PV = "2.3+git${SRCPV}"
+S = "${WORKDIR}/git/platforms/agl/alexa-voiceagent-service"
+
+inherit cmake aglwgt
+
+EXTRA_OECMAKE += "-DAAC_HOME=${RECIPE_SYSROOT}/${AAC_PREFIX}"
+
+ALEXA_WAKEWORD ??= "false"
+
+do_install:append() {
+ install -D -m 0644 ${WORKDIR}/alexa.json ${D}${sysconfdir}/xdg/AGL/voiceagents/alexa.json
+}
+
+PACKAGES =+ "${PN}-conf"
+
+FILES:${PN}-conf = "${sysconfdir}/xdg/AGL/voiceagents/*"
+
+# NOTE: curl and opus are from the base SDK libraries, sqlite3 from the
+# core module
+RDEPENDS:${PN} += " \
+ libcurl \
+ libopus \
+ libsqlite3 \
+ ${PN}-conf \
+ ${@bb.utils.contains("ALEXA_WAKEWORD", "true", "pryon-lite", "", d)} \
+ gstreamer1.0-plugins-bad-hls \
+"