summaryrefslogtreecommitdiffstats
path: root/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-app-pumped-fuel-ped_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-flutter/recipes-graphics/flutter-apps/flutter-app-pumped-fuel-ped_git.bb')
-rw-r--r--meta-agl-flutter/recipes-graphics/flutter-apps/flutter-app-pumped-fuel-ped_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-app-pumped-fuel-ped_git.bb b/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-app-pumped-fuel-ped_git.bb
new file mode 100644
index 00000000..541bc8ec
--- /dev/null
+++ b/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-app-pumped-fuel-ped_git.bb
@@ -0,0 +1,34 @@
+SUMMARY = "Pumped End Device"
+DESCRIPTION = "Pumped is a combination of 3 core projects to connect \
+ vehicle drivers with retail merchants, initially starting \
+ with fuel stations. Our objective is to offer the best fuel \
+ prices, closest stations, friendliest service, cleanest restrooms, \
+ tastiest coffee and so much more, direct to vehicle drivers."
+AUTHOR = "Pumped Fuel"
+HOMEPAGE = "https://github.com/bernardpumped/ped"
+BUGTRACKER = "https://github.com/bernardpumped/ped/issues"
+SECTION = "graphics"
+
+RDEPENDS:${PN} += "\
+ geoclue \
+ libsecret \
+ xdg-user-dirs \
+ "
+
+LICENSE = "GPL-3.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=e49f4652534af377a713df3d9dec60cb"
+
+SRC_URI = "git://github.com/bernardpumped/ped.git;protocol=https;branch=main"
+
+SRCREV = "7a670295d5a94508862316e045e789e0dfd01b20"
+
+S = "${WORKDIR}/git"
+
+PUBSPEC_APPNAME = "pumped_end_device"
+FLUTTER_APPLICATION_INSTALL_PREFIX = "/flutter"
+
+FLUTTER_BUILD_ARGS = "bundle -v"
+
+inherit flutter-app
+
+BBCLASSEXTEND += "flutterrelease flutterdebug flutterprofile"