summaryrefslogtreecommitdiffstats
path: root/meta-agl-flutter/recipes-platform/images
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-flutter/recipes-platform/images')
-rw-r--r--meta-agl-flutter/recipes-platform/images/agl-image-flutter-runtimeprofile.bb26
-rw-r--r--meta-agl-flutter/recipes-platform/images/agl-image-flutter-runtimerelease.bb22
-rw-r--r--meta-agl-flutter/recipes-platform/images/agl-image-flutter.bb (renamed from meta-agl-flutter/recipes-platform/images/agl-image-flutter-runtimedebug.bb)9
3 files changed, 7 insertions, 50 deletions
diff --git a/meta-agl-flutter/recipes-platform/images/agl-image-flutter-runtimeprofile.bb b/meta-agl-flutter/recipes-platform/images/agl-image-flutter-runtimeprofile.bb
deleted file mode 100644
index 8b819922..00000000
--- a/meta-agl-flutter/recipes-platform/images/agl-image-flutter-runtimeprofile.bb
+++ /dev/null
@@ -1,26 +0,0 @@
-SUMMARY = "Baseline Flutter Image for Profiling"
-
-LICENSE = "MIT"
-
-require agl-image-flutter.inc
-
-IMAGE_INSTALL:append = "\
- weston-ini-conf-landscape \
- \
- flutter-auto-runtimeprofile \
- \
- flutter-engine-runtimeprofile-sdk-dev \
- \
- flutter-gallery-runtimeprofile \
- flutter-test-animated-background-runtimeprofile \
- flutter-test-texture-egl-runtimeprofile \
- flutter-test-secure-storage-runtimeprofile \
- flutter-test-localization-runtimeprofile \
- \
- flutter-app-igalia-homescreen-runtimeprofile \
- flutter-app-pumped-fuel-ped-runtimeprofile \
- "
-
-IMAGE_FEATURES:append = "\
- ssh-server-openssh \
- "
diff --git a/meta-agl-flutter/recipes-platform/images/agl-image-flutter-runtimerelease.bb b/meta-agl-flutter/recipes-platform/images/agl-image-flutter-runtimerelease.bb
deleted file mode 100644
index ffc19e84..00000000
--- a/meta-agl-flutter/recipes-platform/images/agl-image-flutter-runtimerelease.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-SUMMARY = "Baseline Flutter Image for Release"
-
-LICENSE = "MIT"
-
-require agl-image-flutter.inc
-
-IMAGE_INSTALL:append = "\
- weston-ini-conf-landscape \
- \
- flutter-auto-runtimerelease \
- \
- flutter-engine-runtimerelease-sdk-dev \
- \
- flutter-gallery-runtimerelease \
- flutter-test-animated-background-runtimerelease \
- flutter-test-texture-egl-runtimerelease \
- flutter-test-secure-storage-runtimerelease \
- flutter-test-localization-runtimerelease \
- \
- flutter-app-igalia-homescreen-runtimerelease \
- flutter-app-pumped-fuel-ped-runtimerelease \
- "
diff --git a/meta-agl-flutter/recipes-platform/images/agl-image-flutter-runtimedebug.bb b/meta-agl-flutter/recipes-platform/images/agl-image-flutter.bb
index b9260bf3..37b0f4e6 100644
--- a/meta-agl-flutter/recipes-platform/images/agl-image-flutter-runtimedebug.bb
+++ b/meta-agl-flutter/recipes-platform/images/agl-image-flutter.bb
@@ -7,9 +7,14 @@ require agl-image-flutter.inc
IMAGE_INSTALL:append = "\
weston-ini-conf-landscape \
\
- flutter-auto-runtimedebug \
+ flutter-auto-with-logging \
+ \
+ flutter-engine-sdk-dev \
+ \
+ flutter-gallery \
+ flutter-test-animated-background \
+ flutter-test-texture-egl \
\
- flutter-engine-runtimedebug-sdk-dev \
"
IMAGE_FEATURES:append = "\
teral.String.Heredoc */ .highlight .si { color: #3333bb; background-color: #fff0f0 } /* Literal.String.Interpol */ .highlight .sx { color: #22bb22; background-color: #f0fff0 } /* Literal.String.Other */ .highlight .sr { color: #008800; background-color: #fff0ff } /* Literal.String.Regex */ .highlight .s1 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Single */ .highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */ .highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */ .highlight .vc { color: #336699 } /* Name.Variable.Class */ .highlight .vg { color: #dd7700 } /* Name.Variable.Global */ .highlight .vi { color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */ }
Overview
========

The
[AGL Project](https://www.automotivelinux.org/) is an automotive-specific
development environment that provides a Linux distribution
[AGL UCB](https://www.automotivelinux.org/software/unified-code-base).

AGL uses layers designed to be compatible with the
[Yocto Project](https://www.yoctoproject.org) and the
[OpenEmbedded Project (OE)](https://www.openembedded.org/wiki/Main_Page).

This section provides information about the layers used by the AGL Project:

* **`meta-agl`**: Minimal set of software needed to create an AGL distribution
  used to boot a system.
  AGL profiles are built on top of this minimal set of software.

* **`meta-agl-demo`**: Provides a reference or demo platform and applications
  for the AGL Distribution.
  The reference UI is part of the `meta-agl-demo` layer.

* **`meta-agl-devel`**: Contains components under development or being tested.
  This layer also contains software packages that OEMs need but do not exist
  in AGL.


**WRITER NOTES:** The content for this section is the `README-AGL.md`
  file that is in the `meta-agl` layer, which is a Gerrit layer.
  You can clone the layer using this command:

    ```
    $ git clone https://gerrit.automotivelinux.org/gerrit/AGL/meta-agl