summaryrefslogtreecommitdiffstats
path: root/meta-agl-flutter/recipes-platform/images
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-flutter/recipes-platform/images')
-rw-r--r--meta-agl-flutter/recipes-platform/images/agl-image-flutter-debug.bb29
-rw-r--r--meta-agl-flutter/recipes-platform/images/agl-image-flutter.bb16
2 files changed, 34 insertions, 11 deletions
diff --git a/meta-agl-flutter/recipes-platform/images/agl-image-flutter-debug.bb b/meta-agl-flutter/recipes-platform/images/agl-image-flutter-debug.bb
new file mode 100644
index 00000000..c9c1f298
--- /dev/null
+++ b/meta-agl-flutter/recipes-platform/images/agl-image-flutter-debug.bb
@@ -0,0 +1,29 @@
+require recipes-platform/images/agl-image-compositor.bb
+
+SUMMARY = "Example Flutter application debug image for development"
+LICENSE = "MIT"
+
+CLANGSDK = "1"
+
+# NOTES:
+# - the package-management IMAGE_FEATURE and packagegroup-agl-core-devel
+# are explicitly added here to cover the usecase of building without
+# passing agl-devel to aglsetup.sh. This is explicitly a debug image
+# where those are are always desired.
+# - Getting the debug version of the application requires changing
+# the value of FLUTTER_APP_RUNTIME_MODES to include "debug",
+# which is outside the scope of this image recipe.
+
+IMAGE_FEATURES += "ssh-server-openssh package-management dbg-pkgs"
+
+IMAGE_INSTALL += "\
+ packagegroup-agl-core-devel \
+ \
+ weston-ini-conf-landscape \
+ \
+ flutter-auto-verbose-logs \
+ \
+ flutter-engine-sdk-dev \
+ \
+ flutter-gallery \
+"
diff --git a/meta-agl-flutter/recipes-platform/images/agl-image-flutter.bb b/meta-agl-flutter/recipes-platform/images/agl-image-flutter.bb
index 697bca3e..0fdb7da0 100644
--- a/meta-agl-flutter/recipes-platform/images/agl-image-flutter.bb
+++ b/meta-agl-flutter/recipes-platform/images/agl-image-flutter.bb
@@ -1,22 +1,16 @@
require recipes-platform/images/agl-image-compositor.bb
-SUMMARY = "Baseline Flutter Image for Development"
+SUMMARY = "Example Flutter application image"
LICENSE = "MIT"
CLANGSDK = "1"
+IMAGE_FEATURES += "ssh-server-openssh"
+
IMAGE_INSTALL += "\
weston-ini-conf-landscape \
\
- flutter-auto-verbose-logs \
- \
- flutter-engine-sdk-dev \
+ flutter-auto \
\
flutter-gallery \
- flutter-test-texture-egl \
- \
- "
-
-IMAGE_FEATURES += "\
- ssh-server-openssh \
- "
+"