summaryrefslogtreecommitdiffstats
path: root/meta-agl-flutter
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-flutter')
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/files/0001-The-ivi-homescreen-is-using-eglGetPlatformDisplay-di.patch32
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/flutter-auto_%.bbappend1
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/flutter-auto_aglflutter.inc6
3 files changed, 0 insertions, 39 deletions
diff --git a/meta-agl-flutter/recipes-graphics/toyota/files/0001-The-ivi-homescreen-is-using-eglGetPlatformDisplay-di.patch b/meta-agl-flutter/recipes-graphics/toyota/files/0001-The-ivi-homescreen-is-using-eglGetPlatformDisplay-di.patch
deleted file mode 100644
index 58e920e4..00000000
--- a/meta-agl-flutter/recipes-graphics/toyota/files/0001-The-ivi-homescreen-is-using-eglGetPlatformDisplay-di.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 29d93f244f5483062f163c366d31f6a1da5be05e Mon Sep 17 00:00:00 2001
-From: Joel Winarske <joel.winarske@gmail.com>
-Date: Tue, 6 Jun 2023 14:39:17 -0700
-Subject: [PATCH] The ivi-homescreen is using eglGetPlatformDisplay directly
- that possible to use in EGL version is 1.5 or greater. On the other hand
- R-CarH3/M3 is not supporting EGL version is 1.5, only a EGL version is 1.4.
- This situation cause build error in R-Car H3/M3.
-
-This patch fix that build error.
-
-Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>
----
- shell/view/compositor_surface.cc | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/shell/view/compositor_surface.cc b/shell/view/compositor_surface.cc
-index 51b13c5..7991c3f 100644
---- a/shell/view/compositor_surface.cc
-+++ b/shell/view/compositor_surface.cc
-@@ -57,8 +57,7 @@ CompositorSurface::CompositorSurface(
- auto parent_surface = window->GetBaseSurface();
-
- if (type == CompositorSurface::egl) {
-- m_wl.egl_display = eglGetPlatformDisplay(EGL_PLATFORM_WAYLAND_KHR,
-- display->GetDisplay(), nullptr);
-+ m_wl.egl_display = eglGetDisplay((NativeDisplayType)display->GetDisplay());
- m_wl.egl_window = wl_egl_window_create(m_wl.surface, width, height);
- assert(m_wl.egl_display);
- assert(m_wl.egl_window);
---
-2.41.0
-
diff --git a/meta-agl-flutter/recipes-graphics/toyota/flutter-auto_%.bbappend b/meta-agl-flutter/recipes-graphics/toyota/flutter-auto_%.bbappend
deleted file mode 100644
index dbc82bc3..00000000
--- a/meta-agl-flutter/recipes-graphics/toyota/flutter-auto_%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-require ${@bb.utils.contains('AGL_FEATURES', 'agl-flutter', 'flutter-auto_aglflutter.inc', '', d)}
diff --git a/meta-agl-flutter/recipes-graphics/toyota/flutter-auto_aglflutter.inc b/meta-agl-flutter/recipes-graphics/toyota/flutter-auto_aglflutter.inc
deleted file mode 100644
index 869b3a4f..00000000
--- a/meta-agl-flutter/recipes-graphics/toyota/flutter-auto_aglflutter.inc
+++ /dev/null
@@ -1,6 +0,0 @@
-FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
-
-SRC_URI += "file://0001-The-ivi-homescreen-is-using-eglGetPlatformDisplay-di.patch"
-
-# NOTE: Cannot use += here due to ??= use in the recipe
-PACKAGECONFIG:append = " client-agl"
#336699; font-style: italic } /* Name.Label */ .highlight .nn { color: #bb0066; font-weight: bold } /* Name.Namespace */ .highlight .py { color: #336699; font-weight: bold } /* Name.Property */ .highlight .nt { color: #bb0066; font-weight: bold } /* Name.Tag */ .highlight .nv { color: #336699 } /* Name.Variable */ .highlight .ow { color: #008800 } /* Operator.Word */ .highlight .w { color: #bbbbbb } /* Text.Whitespace */ .highlight .mb { color: #0000DD; font-weight: bold } /* Literal.Number.Bin */ .highlight .mf { color: #0000DD; font-weight: bold } /* Literal.Number.Float */ .highlight .mh { color: #0000DD; font-weight: bold } /* Literal.Number.Hex */ .highlight .mi { color: #0000DD; font-weight: bold } /* Literal.Number.Integer */ .highlight .mo { color: #0000DD; font-weight: bold } /* Literal.Number.Oct */ .highlight .sa { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Affix */ .highlight .sb { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Backtick */ .highlight .sc { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Char */ .highlight .dl { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Delimiter */ .highlight .sd { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Doc */ .highlight .s2 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Double */ .highlight .se { color: #0044dd; background-color: #fff0f0 } /* Literal.String.Escape */ .highlight .sh { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Heredoc */ .highlight .si { color: #3333bb; background-color: #fff0f0 } /* Literal.String.Interpol */ .highlight .sx { color: #22bb22; background-color: #f0fff0 } /* Literal.String.Other */ .highlight .sr { color: #008800; background-color: #fff0ff } /* Literal.String.Regex */ .highlight .s1 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Single */ .highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */ .highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */ .highlight .vc { color: #336699 } /* Name.Variable.Class */ .highlight .vg { color: #dd7700 } /* Name.Variable.Global */ .highlight .vi { color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */ }
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html><head><title></title>
<meta http-equiv="Content-Type" content="text/xhtml;charset=UTF-8"/>
<meta name="generator" content="Doxygen 1.8.11"/>
<link rel="stylesheet" type="text/css" href="search.css"/>
<script type="text/javascript" src="variables_9.js"></script>
<script type="text/javascript" src="search.js"></script>
</head>
<body class="SRPage">
<div id="SRIndex">
<div class="SRStatus" id="Loading">Loading...</div>
<div id="SRResults"></div>
<script type="text/javascript"><!--
createResults();
--></script>
<div class="SRStatus" id="Searching">Searching...</div>
<div class="SRStatus" id="NoMatches">No Matches</div>
<script type="text/javascript"><!--
document.getElementById("Loading").style.display="none";
document.getElementById("NoMatches").style.display="none";
var searchResults = new SearchResults("searchResults");
searchResults.Search();
--></script>
</div>
</body>
</html>