summaryrefslogtreecommitdiffstats
path: root/meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb')
-rw-r--r--meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb18
1 files changed, 9 insertions, 9 deletions
diff --git a/meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb b/meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb
index 2a7e37ed..2b6f4a65 100644
--- a/meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb
+++ b/meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb
@@ -13,7 +13,7 @@ LIC_FILES_CHKSUM = " \
SRCREV = "4ce7658dddfd5a1682a379d5ac46657e93fe1ff0"
PV = "0.12+git${SRCPV}"
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
SRC_URI = "git://github.com/siemens/jailhouse;branch=master;protocol=https \
file://0001-configs-arm64-Add-support-for-RPi4-with-more-than-1G.patch \
@@ -84,15 +84,15 @@ do_install() {
}
PACKAGE_BEFORE_PN = "kernel-module-jailhouse pyjailhouse ${PN}-tools ${PN}-demos"
-FILES_${PN} = "${base_libdir}/firmware ${libexecdir} ${sbindir} ${JH_DATADIR}"
-FILES_pyjailhouse = "${PYTHON_SITEPACKAGES_DIR}"
-FILES_${PN}-tools = "${libexecdir}/${BPN}/${BPN}-* ${JH_DATADIR}/*.tmpl"
-FILES_${PN}-demos = "${JH_DATADIR}/ ${sbindir}/ivshmem-demo"
+FILES:${PN} = "${base_libdir}/firmware ${libexecdir} ${sbindir} ${JH_DATADIR}"
+FILES:pyjailhouse = "${PYTHON_SITEPACKAGES_DIR}"
+FILES:${PN}-tools = "${libexecdir}/${BPN}/${BPN}-* ${JH_DATADIR}/*.tmpl"
+FILES:${PN}-demos = "${JH_DATADIR}/ ${sbindir}/ivshmem-demo"
-RDEPENDS_${PN}-tools = "pyjailhouse python3-mmap python3-math python3-datetime python3-curses python3-compression python3-mako"
-RDEPENDS_pyjailhouse = "python3-core python3-ctypes python3-fcntl"
-RDEPENDS_${PN}-demos = "jailhouse"
+RDEPENDS:${PN}-tools = "pyjailhouse python3-mmap python3-math python3-datetime python3-curses python3-compression python3-mako"
+RDEPENDS:pyjailhouse = "python3-core python3-ctypes python3-fcntl"
+RDEPENDS:${PN}-demos = "jailhouse"
-RRECOMMENDS_${PN} = "${PN}-tools"
+RRECOMMENDS:${PN} = "${PN}-tools"
KERNEL_MODULE_AUTOLOAD += "jailhouse"