summaryrefslogtreecommitdiffstats
path: root/meta-agl-jailhouse/recipes-extended/jailhouse/virtio-ivshmem-console.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-jailhouse/recipes-extended/jailhouse/virtio-ivshmem-console.bb')
-rw-r--r--meta-agl-jailhouse/recipes-extended/jailhouse/virtio-ivshmem-console.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/meta-agl-jailhouse/recipes-extended/jailhouse/virtio-ivshmem-console.bb b/meta-agl-jailhouse/recipes-extended/jailhouse/virtio-ivshmem-console.bb
new file mode 100644
index 00000000..3d046f14
--- /dev/null
+++ b/meta-agl-jailhouse/recipes-extended/jailhouse/virtio-ivshmem-console.bb
@@ -0,0 +1,54 @@
+SUMMARY = "virtio-ivshmem-console built out of the kernel tree"
+DESCRIPTION = "virtio-ivshmem-console built out of the kernel tree."
+HOMEPAGE = "https://kernel.org"
+
+LICENSE = "GPLv2"
+
+PR = "r1"
+
+DEPENDS = " \
+ virtual/${MLPREFIX}libc \
+ ${MLPREFIX}elfutils \
+ ${MLPREFIX}binutils \
+ bison-native flex-native xz \
+"
+
+do_configure[depends] += "virtual/kernel:do_shared_workdir"
+
+PROVIDES = "virtual/virtio-ivshmem-console"
+
+inherit linux-kernel-base kernel-arch
+
+#kernel 3.1+ supports WERROR to disable warnings as errors
+export WERROR = "0"
+
+do_populate_lic[depends] += "virtual/kernel:do_shared_workdir"
+
+inherit kernelsrc
+
+
+#PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+S = "${WORKDIR}"
+
+RDEPENDS:${PN}-dev = ""
+
+EXTRA_OEMAKE = " CC="${CC} ${CFLAGS} ${LDFLAGS}" CPP="${CPP}""
+
+do_configure() {
+ echo "configure"
+}
+
+do_compile() {
+
+ oe_runmake CC="${CC} -I${STAGING_DIR_TARGET}/usr/include/ " LD="${LD}" AR="${AR}" \
+ -C ${STAGING_KERNEL_DIR}/tools/virtio/ O=${S} virtio-ivshmem-console
+
+}
+
+do_install(){
+
+ install -d ${D}${bindir}/
+ install -m 0755 ${STAGING_KERNEL_DIR}/tools/virtio/virtio-ivshmem-console ${D}${bindir}
+
+} \ No newline at end of file