summaryrefslogtreecommitdiffstats
path: root/meta-agl-jailhouse
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-jailhouse')
-rw-r--r--meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend2
-rw-r--r--meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend2
-rw-r--r--meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-extended/jailhouse/jailhouse_%.bbappend2
-rw-r--r--meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4%.bbappend2
-rw-r--r--meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb18
-rw-r--r--meta-agl-jailhouse/recipes-kernel/linux/linux-jailhouse-5.4.inc6
6 files changed, 16 insertions, 16 deletions
diff --git a/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend b/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
index 687980cf..ce7b0227 100644
--- a/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
+++ b/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
@@ -1,5 +1,5 @@
-do_deploy_append_raspberrypi4() {
+do_deploy:append:raspberrypi4() {
# if ARMSTUB is set, it should be set in config.txt by earlier recipes, so replace it
if [ -n "${ARMSTUB}" ]; then
sed -i 's/^armstub=.*/armstub=bl31.bin/' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
diff --git a/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend b/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
index 158eb6e8..e84d2409 100644
--- a/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
+++ b/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
@@ -6,7 +6,7 @@ TFA_PLATFORM = "rpi4"
# partition that is generated from the files in DEPLOYDIR
do_install[noexec] = "1"
-FILES_${PN} = ""
+FILES:${PN} = ""
do_deploy() {
if ${@"true" if d.getVar('TFA_DEBUG') == '1' else "false"}; then
diff --git a/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-extended/jailhouse/jailhouse_%.bbappend b/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-extended/jailhouse/jailhouse_%.bbappend
index 1d8ea6b7..b1f29275 100644
--- a/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-extended/jailhouse/jailhouse_%.bbappend
+++ b/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-extended/jailhouse/jailhouse_%.bbappend
@@ -1,2 +1,2 @@
-DEPENDS_append_raspberrypi4 = " trusted-firmware-a"
+DEPENDS:append:raspberrypi4 = " trusted-firmware-a"
diff --git a/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4%.bbappend b/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4%.bbappend
index 1456fdc8..ba3505fe 100644
--- a/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4%.bbappend
+++ b/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4%.bbappend
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
SRC_URI += "file://0001-dt-dtoverlays-Add-jailhouse-memory-DT-overlay.patch"
diff --git a/meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb b/meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb
index 2a7e37ed..2b6f4a65 100644
--- a/meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb
+++ b/meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb
@@ -13,7 +13,7 @@ LIC_FILES_CHKSUM = " \
SRCREV = "4ce7658dddfd5a1682a379d5ac46657e93fe1ff0"
PV = "0.12+git${SRCPV}"
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
SRC_URI = "git://github.com/siemens/jailhouse;branch=master;protocol=https \
file://0001-configs-arm64-Add-support-for-RPi4-with-more-than-1G.patch \
@@ -84,15 +84,15 @@ do_install() {
}
PACKAGE_BEFORE_PN = "kernel-module-jailhouse pyjailhouse ${PN}-tools ${PN}-demos"
-FILES_${PN} = "${base_libdir}/firmware ${libexecdir} ${sbindir} ${JH_DATADIR}"
-FILES_pyjailhouse = "${PYTHON_SITEPACKAGES_DIR}"
-FILES_${PN}-tools = "${libexecdir}/${BPN}/${BPN}-* ${JH_DATADIR}/*.tmpl"
-FILES_${PN}-demos = "${JH_DATADIR}/ ${sbindir}/ivshmem-demo"
+FILES:${PN} = "${base_libdir}/firmware ${libexecdir} ${sbindir} ${JH_DATADIR}"
+FILES:pyjailhouse = "${PYTHON_SITEPACKAGES_DIR}"
+FILES:${PN}-tools = "${libexecdir}/${BPN}/${BPN}-* ${JH_DATADIR}/*.tmpl"
+FILES:${PN}-demos = "${JH_DATADIR}/ ${sbindir}/ivshmem-demo"
-RDEPENDS_${PN}-tools = "pyjailhouse python3-mmap python3-math python3-datetime python3-curses python3-compression python3-mako"
-RDEPENDS_pyjailhouse = "python3-core python3-ctypes python3-fcntl"
-RDEPENDS_${PN}-demos = "jailhouse"
+RDEPENDS:${PN}-tools = "pyjailhouse python3-mmap python3-math python3-datetime python3-curses python3-compression python3-mako"
+RDEPENDS:pyjailhouse = "python3-core python3-ctypes python3-fcntl"
+RDEPENDS:${PN}-demos = "jailhouse"
-RRECOMMENDS_${PN} = "${PN}-tools"
+RRECOMMENDS:${PN} = "${PN}-tools"
KERNEL_MODULE_AUTOLOAD += "jailhouse"
diff --git a/meta-agl-jailhouse/recipes-kernel/linux/linux-jailhouse-5.4.inc b/meta-agl-jailhouse/recipes-kernel/linux/linux-jailhouse-5.4.inc
index 4b571ffd..4b810182 100644
--- a/meta-agl-jailhouse/recipes-kernel/linux/linux-jailhouse-5.4.inc
+++ b/meta-agl-jailhouse/recipes-kernel/linux/linux-jailhouse-5.4.inc
@@ -1,8 +1,8 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/linux:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/linux:"
-SRC_URI_append = " file://jailhouse.cfg"
+SRC_URI:append = " file://jailhouse.cfg"
-SRC_URI_append = " \
+SRC_URI:append = " \
file://0001-x86-jailhouse-Improve-setup-data-version-comparison.patch \
file://0002-x86-jailhouse-Only-enable-platform-UARTs-if-availabl.patch \
file://0003-jailhouse-Add-simple-debug-console-via-the-hyperviso.patch \