summaryrefslogtreecommitdiffstats
path: root/meta-agl-lxc/recipes-graphics/wayland/weston-init-guest_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-lxc/recipes-graphics/wayland/weston-init-guest_0.1.bb')
-rw-r--r--meta-agl-lxc/recipes-graphics/wayland/weston-init-guest_0.1.bb19
1 files changed, 9 insertions, 10 deletions
diff --git a/meta-agl-lxc/recipes-graphics/wayland/weston-init-guest_0.1.bb b/meta-agl-lxc/recipes-graphics/wayland/weston-init-guest_0.1.bb
index e18dbe52..c95f92e0 100644
--- a/meta-agl-lxc/recipes-graphics/wayland/weston-init-guest_0.1.bb
+++ b/meta-agl-lxc/recipes-graphics/wayland/weston-init-guest_0.1.bb
@@ -2,9 +2,7 @@ SUMMARY = "Startup script and systemd unit file for the Weston Wayland composito
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-
SRC_URI = "file://weston.env \
- file://weston.ini \
file://weston.service \
"
@@ -13,7 +11,6 @@ S = "${WORKDIR}"
inherit features_check systemd
do_install() {
- install -D -p -m0644 ${WORKDIR}/weston.ini ${D}${sysconfdir}/xdg/weston/weston.ini
install -Dm644 ${WORKDIR}/weston.env ${D}${sysconfdir}/default/weston
# Install Weston systemd service and accompanying udev rule
@@ -26,22 +23,24 @@ do_install() {
PACKAGE_ARCH = "${MACHINE_ARCH}"
-# rdepends on weston which depends on virtual/egl
+# rdepends on weston-init-guest which depends on wayland
REQUIRED_DISTRO_FEATURES = "wayland"
-FILES_${PN} += " \
+FILES:${PN} += " \
${sysconfdir}/xdg/weston/weston.ini \
${systemd_system_unitdir}/weston.service \
${sysconfdir}/default/weston \
"
-CONFFILES_${PN} += " \
+CONFFILES:${PN} += " \
${sysconfdir}/xdg/weston/weston.ini \
${sysconfdir}/default/weston \
"
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "weston.service"
+SYSTEMD_SERVICE:${PN} = "weston.service"
SYSTEMD_AUTO_ENABLE = "enable"
-RDEPENDS_${PN} = "weston"
-
-RCONFLICTS_${PN} = "weston-init"
+RDEPENDS:${PN} = " \
+ weston \
+ weston-ini \
+ "
+RCONFLICTS:${PN} = "weston-init"