summaryrefslogtreecommitdiffstats
path: root/meta-agl-lxc/recipes-platform
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-lxc/recipes-platform')
-rw-r--r--meta-agl-lxc/recipes-platform/images/lxc-host-image-demo.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-agl-lxc/recipes-platform/images/lxc-host-image-demo.bb b/meta-agl-lxc/recipes-platform/images/lxc-host-image-demo.bb
index 0be9c591..c7424f57 100644
--- a/meta-agl-lxc/recipes-platform/images/lxc-host-image-demo.bb
+++ b/meta-agl-lxc/recipes-platform/images/lxc-host-image-demo.bb
@@ -15,4 +15,17 @@ IMAGE_INSTALL += " \
wireplumber-config-agl \
"
+# packages required for network bridge settings via lxc-net
+IMAGE_INSTALL += " \
+ lxc-networking \
+ iptables-modules \
+ dnsmasq \
+ systemd-netif-config \
+ kernel-module-xt-addrtype \
+ kernel-module-xt-multiport \
+"
+
+# network manager to use
+VIRTUAL-RUNTIME_net_manager = "systemd"
+
IMAGE_INSTALL:append:rcar-gen3 = " kernel-module-gles "