summaryrefslogtreecommitdiffstats
path: root/meta-audio-4a-framework/recipes-connectivity/bluez-alsa/bluez-alsa/0001-build-and-link-with-a-shared-library.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-audio-4a-framework/recipes-connectivity/bluez-alsa/bluez-alsa/0001-build-and-link-with-a-shared-library.patch')
-rw-r--r--meta-audio-4a-framework/recipes-connectivity/bluez-alsa/bluez-alsa/0001-build-and-link-with-a-shared-library.patch102
1 files changed, 44 insertions, 58 deletions
diff --git a/meta-audio-4a-framework/recipes-connectivity/bluez-alsa/bluez-alsa/0001-build-and-link-with-a-shared-library.patch b/meta-audio-4a-framework/recipes-connectivity/bluez-alsa/bluez-alsa/0001-build-and-link-with-a-shared-library.patch
index 3d2c4f60..53ee3ad0 100644
--- a/meta-audio-4a-framework/recipes-connectivity/bluez-alsa/bluez-alsa/0001-build-and-link-with-a-shared-library.patch
+++ b/meta-audio-4a-framework/recipes-connectivity/bluez-alsa/bluez-alsa/0001-build-and-link-with-a-shared-library.patch
@@ -1,4 +1,4 @@
-From 032917320d339e44a3981c347887b220e98e369e Mon Sep 17 00:00:00 2001
+From 7625b67a687b7a365d9d758a86ed05e84b2b3a61 Mon Sep 17 00:00:00 2001
From: Thierry Bultel <thierry.bultel@iot.bzh>
Date: Mon, 3 Dec 2018 14:29:07 +0100
Subject: [PATCH 1/3] build and link with a shared library
@@ -40,12 +40,11 @@ Signed-off-by: Thierry Bultel <thierry.bultel@iot.bzh>
test/test-at.c | 1 -
test/test-bluealsalib.c | 96 ++++++++++++++++++++++++++
test/test-io.c | 3 -
- test/test-pcm.c | 4 +-
test/test-utils.c | 8 +--
utils/Makefile.am | 11 ++-
utils/aplay.c | 8 +--
utils/rfcomm.c | 4 +-
- 40 files changed, 254 insertions(+), 75 deletions(-)
+ 39 files changed, 252 insertions(+), 73 deletions(-)
create mode 100644 includes/bluealsa/bluealsa.h
rename {src/shared => includes/bluealsa}/ctl-client.h (98%)
rename {src/shared => includes/bluealsa}/ctl-proto.h (100%)
@@ -58,10 +57,10 @@ Signed-off-by: Thierry Bultel <thierry.bultel@iot.bzh>
create mode 100644 test/test-bluealsalib.c
diff --git a/configure.ac b/configure.ac
-index 734fb59..fc52531 100644
+index 0bb9452..6323d60 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -158,8 +158,10 @@ AC_CONFIG_FILES([
+@@ -152,8 +152,10 @@ AC_CONFIG_FILES([
Makefile
src/Makefile
src/asound/Makefile
@@ -104,7 +103,7 @@ diff --git a/src/shared/ctl-client.h b/includes/bluealsa/ctl-client.h
similarity index 98%
rename from src/shared/ctl-client.h
rename to includes/bluealsa/ctl-client.h
-index 18f724d..36b537c 100644
+index 3dc93a6..b8af154 100644
--- a/src/shared/ctl-client.h
+++ b/includes/bluealsa/ctl-client.h
@@ -12,7 +12,7 @@
@@ -218,7 +217,7 @@ index 923d884..24618f1 100644
@ALSA_LIBS@ \
@BLUEZ_LIBS@
diff --git a/src/asound/bluealsa-ctl.c b/src/asound/bluealsa-ctl.c
-index 76cbe6a..3c931ca 100644
+index f4a0181..1b9d124 100644
--- a/src/asound/bluealsa-ctl.c
+++ b/src/asound/bluealsa-ctl.c
@@ -19,9 +19,9 @@
@@ -235,7 +234,7 @@ index 76cbe6a..3c931ca 100644
enum ctl_elem_type {
diff --git a/src/asound/bluealsa-pcm.c b/src/asound/bluealsa-pcm.c
-index 46788f5..2136964 100644
+index 258aebd..42cb61d 100644
--- a/src/asound/bluealsa-pcm.c
+++ b/src/asound/bluealsa-pcm.c
@@ -23,11 +23,11 @@
@@ -271,18 +270,18 @@ index e3d1703..bda2255 100644
/**
diff --git a/src/bluealsa.h b/src/bluealsa.h
-index 3249439..b73241e 100644
+index 7968ba9..7eee34f 100644
--- a/src/bluealsa.h
+++ b/src/bluealsa.h
-@@ -28,7 +28,7 @@
+@@ -27,7 +27,7 @@
#include "bluez.h"
#include "bluez-a2dp.h"
#include "transport.h"
-#include "shared/ctl-proto.h"
+#include <bluealsa/ctl-proto.h>
- /* Maximal number of clients connected to the controller. */
- #define BLUEALSA_MAX_CLIENTS 7
+ struct ba_config {
+
diff --git a/src/bluealsalib/Makefile.am b/src/bluealsalib/Makefile.am
new file mode 100644
index 0000000..11d9e00
@@ -371,7 +370,7 @@ index 5f81e6e..4c7b07b 100644
static const a2dp_sbc_t a2dp_sbc = {
.frequency =
diff --git a/src/bluez.c b/src/bluez.c
-index 35f1b36..1478d6f 100644
+index 537f0fe..591fdce 100644
--- a/src/bluez.c
+++ b/src/bluez.c
@@ -24,7 +24,7 @@
@@ -384,10 +383,10 @@ index 35f1b36..1478d6f 100644
/**
diff --git a/src/ctl.c b/src/ctl.c
-index b35afc7..82666b9 100644
+index ae2b812..dd3ab45 100644
--- a/src/ctl.c
+++ b/src/ctl.c
-@@ -31,8 +31,8 @@
+@@ -32,8 +32,8 @@
#include "hfp.h"
#include "transport.h"
#include "utils.h"
@@ -396,10 +395,10 @@ index b35afc7..82666b9 100644
+#include <bluealsa/defs.h>
+#include <bluealsa/log.h>
-
- /**
+ /* Special PCM type for internal usage only. */
+ #define BA_PCM_TYPE_RFCOMM 0x1F
diff --git a/src/ctl.h b/src/ctl.h
-index 5fd92ed..7f185a4 100644
+index 0e3c46b..593a9fd 100644
--- a/src/ctl.h
+++ b/src/ctl.h
@@ -11,7 +11,7 @@
@@ -409,10 +408,10 @@ index 5fd92ed..7f185a4 100644
-#include "shared/ctl-proto.h"
+#include <bluealsa/ctl-proto.h>
- int bluealsa_ctl_thread_init(void);
- void bluealsa_ctl_free(void);
+ /* Indexes of special file descriptors in the poll array. */
+ #define CTL_IDX_SRV 0
diff --git a/src/io.c b/src/io.c
-index 5b098c4..e567bdb 100644
+index b3d7ac9..f81eeb0 100644
--- a/src/io.c
+++ b/src/io.c
@@ -44,10 +44,10 @@
@@ -446,10 +445,10 @@ index 35e6702..9cef402 100644
static char *get_a2dp_codecs(
diff --git a/src/ofono.c b/src/ofono.c
-index 4331e03..63c8685 100644
+index 902d099..bfd4e39 100644
--- a/src/ofono.c
+++ b/src/ofono.c
-@@ -26,7 +26,7 @@
+@@ -27,7 +27,7 @@
#include "ctl.h"
#include "ofono-iface.h"
#include "transport.h"
@@ -459,7 +458,7 @@ index 4331e03..63c8685 100644
#define OFONO_FAKE_DEV_ID 0xffff
diff --git a/src/rfcomm.c b/src/rfcomm.c
-index f2a904a..b1edf84 100644
+index a86ae61..2d76725 100644
--- a/src/rfcomm.c
+++ b/src/rfcomm.c
@@ -17,11 +17,11 @@
@@ -477,7 +476,7 @@ index f2a904a..b1edf84 100644
/**
diff --git a/src/shared/ctl-client.c b/src/shared/ctl-client.c
-index 121689d..01ceecb 100644
+index 6cf9402..2da9a54 100644
--- a/src/shared/ctl-client.c
+++ b/src/shared/ctl-client.c
@@ -8,7 +8,7 @@
@@ -547,7 +546,7 @@ index edcbebc..40bd721 100644
#include <stdlib.h>
diff --git a/src/transport.c b/src/transport.c
-index aca8038..823316b 100644
+index 7253925..1617dd1 100644
--- a/src/transport.c
+++ b/src/transport.c
@@ -34,7 +34,7 @@
@@ -573,34 +572,38 @@ index 70d069e..27459d2 100644
/**
diff --git a/test/Makefile.am b/test/Makefile.am
-index 27a646a..3d67809 100644
+index 104dc63..8f7b2eb 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
-@@ -4,7 +4,8 @@
- TESTS = \
- test-at \
+@@ -6,7 +6,8 @@ TESTS = \
+ test-ctl \
test-io \
+ test-pcm \
- test-utils
+ test-utils \
+ test-bluealsalib
- if ENABLE_TEST_PCM
- TESTS += test-pcm
-@@ -15,10 +16,12 @@ check_PROGRAMS = \
- test-at \
+ check_PROGRAMS = \
+ server-mock \
+@@ -14,7 +15,8 @@ check_PROGRAMS = \
+ test-ctl \
test-io \
test-pcm \
- test-utils
+ test-utils \
+ test-bluealsalib
+ check_LTLIBRARIES = \
+ aloader.la
+@@ -25,6 +27,7 @@ aloader_la_LDFLAGS = \
+
AM_CFLAGS = \
-I$(top_srcdir)/src \
+ -I$(top_srcdir)/includes \
@AAC_CFLAGS@ \
@ALSA_CFLAGS@ \
@APTX_CFLAGS@ \
-@@ -40,4 +43,5 @@ LDADD = \
+@@ -46,4 +49,5 @@ LDADD = \
@GLIB2_LIBS@ \
@LDAC_ABR_LIBS@ \
@LDAC_LIBS@ \
@@ -608,10 +611,10 @@ index 27a646a..3d67809 100644
+ @SBC_LIBS@ \
+ ../src/bluealsalib/libbluealsa.la
diff --git a/test/server-mock.c b/test/server-mock.c
-index a27b59d..418e3a0 100644
+index 8c3a90e..c88fa35 100644
--- a/test/server-mock.c
+++ b/test/server-mock.c
-@@ -33,9 +33,6 @@
+@@ -31,9 +31,6 @@
#include "../src/rfcomm.c"
#include "../src/transport.c"
#include "../src/utils.c"
@@ -622,7 +625,7 @@ index a27b59d..418e3a0 100644
static const a2dp_sbc_t cconfig = {
.frequency = SBC_SAMPLING_FREQ_44100,
diff --git a/test/test-at.c b/test/test-at.c
-index 177cceb..8d5e2f3 100644
+index 8cff264..a847c22 100644
--- a/test/test-at.c
+++ b/test/test-at.c
@@ -11,7 +11,6 @@
@@ -749,25 +752,8 @@ index d913d2f..8ebb1d8 100644
static const a2dp_sbc_t config_sbc_44100_stereo = {
.frequency = SBC_SAMPLING_FREQ_44100,
-diff --git a/test/test-pcm.c b/test/test-pcm.c
-index 1a4d02d..43e30e1 100644
---- a/test/test-pcm.c
-+++ b/test/test-pcm.c
-@@ -18,10 +18,10 @@
- #include <check.h>
- #include <alsa/asoundlib.h>
-
-+#include <bluealsa/log.h>
-+
- #include "inc/server.inc"
- #include "inc/sine.inc"
--#include "../src/shared/ffb.c"
--#include "../src/shared/log.c"
-
- #define buffer_test_frames 1024
- #define dumprv(fn) fprintf(stderr, #fn " = %d\n", (int)fn)
diff --git a/test/test-utils.c b/test/test-utils.c
-index 767ca4e..98b5b42 100644
+index b704b42..46475f1 100644
--- a/test/test-utils.c
+++ b/test/test-utils.c
@@ -10,11 +10,11 @@
@@ -829,7 +815,7 @@ index 256689a..a6d132c 100644
endif
diff --git a/utils/aplay.c b/utils/aplay.c
-index 7b71860..5211e7f 100644
+index f792ce6..4b1372e 100644
--- a/utils/aplay.c
+++ b/utils/aplay.c
@@ -25,10 +25,10 @@
@@ -848,7 +834,7 @@ index 7b71860..5211e7f 100644
struct pcm_worker {
struct ba_msg_transport transport;
diff --git a/utils/rfcomm.c b/utils/rfcomm.c
-index 6794fc4..f5f045c 100644
+index cc31f46..38e3b30 100644
--- a/utils/rfcomm.c
+++ b/utils/rfcomm.c
@@ -24,8 +24,8 @@