aboutsummaryrefslogtreecommitdiffstats
path: root/meta-audio-4a-framework/recipes-multimedia/4a-hal-unicens/4a-hal-unicens_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-audio-4a-framework/recipes-multimedia/4a-hal-unicens/4a-hal-unicens_git.bb')
-rw-r--r--meta-audio-4a-framework/recipes-multimedia/4a-hal-unicens/4a-hal-unicens_git.bb23
1 files changed, 17 insertions, 6 deletions
diff --git a/meta-audio-4a-framework/recipes-multimedia/4a-hal-unicens/4a-hal-unicens_git.bb b/meta-audio-4a-framework/recipes-multimedia/4a-hal-unicens/4a-hal-unicens_git.bb
index 4090b298..bc95bc8a 100644
--- a/meta-audio-4a-framework/recipes-multimedia/4a-hal-unicens/4a-hal-unicens_git.bb
+++ b/meta-audio-4a-framework/recipes-multimedia/4a-hal-unicens/4a-hal-unicens_git.bb
@@ -1,18 +1,29 @@
SUMMARY = "4A - Unicens (MOST) Binding"
DESCRIPTION = "Unicens binding (MOST audio network support) for 4A (AGL Advanced Audio Agent)"
-HOMEPAGE = "https://git.automotivelinux.org/src/4a-hal-unicens/"
+HOMEPAGE = "https://github.com/tjahnk/4a-hal-unicens"
SECTION = "apps"
LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=dab9a7a261563ca5dafa097c91369074"
+
+DEPENDS += "lua"
+
+SRC_URI = "gitsm://github.com/tjahnk/4a-hal-unicens;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "a873bb0f053a56d8eb68217a901e3c5e7ca77f9b"
-SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/src/4a-hal-unicens;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "178a830b8ad85813b7bf0b271be79f3a8d3a6277"
PV = "0.1+git${SRCPV}"
S = "${WORKDIR}/git"
inherit afb-system-cmake
-FILES_${PN}-dev += "${INSTALL_PREFIX}/afb-aaaa/htdocs"
-FILES_${PN} += "${INSTALL_PREFIX}/afb-aaaa"
+do_install_append () {
+ # installation folder for this plugin is '4a-hal'
+ # get pkgdir - note that '4a-hal' comes from project ${project_git_repo}/conf.d/cmake/config.cmake
+ PKGDIR=${D}/${INSTALL_PREFIX}/4a-hal
+
+ # move all config files to a 'available' dir
+ mv $PKGDIR/etc $PKGDIR/etc.available
+}
+
+