summaryrefslogtreecommitdiffstats
path: root/meta-egvirt/recipes-extended/vhost-device-can/vhost-device-can-0.1.0/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'meta-egvirt/recipes-extended/vhost-device-can/vhost-device-can-0.1.0/Cargo.toml')
-rw-r--r--meta-egvirt/recipes-extended/vhost-device-can/vhost-device-can-0.1.0/Cargo.toml35
1 files changed, 0 insertions, 35 deletions
diff --git a/meta-egvirt/recipes-extended/vhost-device-can/vhost-device-can-0.1.0/Cargo.toml b/meta-egvirt/recipes-extended/vhost-device-can/vhost-device-can-0.1.0/Cargo.toml
deleted file mode 100644
index 08d012c2..00000000
--- a/meta-egvirt/recipes-extended/vhost-device-can/vhost-device-can-0.1.0/Cargo.toml
+++ /dev/null
@@ -1,35 +0,0 @@
-[package]
-name = "vhost-device-can"
-version = "0.0.1"
-authors = ["Timos Ampelikiotis <t.ampelikiotis@virtualopensystems.com>"]
-description = "vhost can backend device"
-repository = "https://github.com/rust-vmm/vhost-device"
-readme = "README.md"
-keywords = ["can", "vhost", "virt", "backend"]
-license = "Apache-2.0 OR BSD-3-Clause"
-edition = "2021"
-
-# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
-
-[features]
-xen = ["vm-memory/xen", "vhost/xen", "vhost-user-backend/xen"]
-
-[dependencies]
-queues = "1.0.2"
-socketcan = "3.2"
-clap = { version = "4.2.5", features = ["derive"] }
-env_logger = "0.10"
-libc = "0.2"
-log = "0.4"
-thiserror = "1.0"
-vhost = { version = "0.8", features = ["vhost-user-slave"] }
-vhost-user-backend = "0.10"
-virtio-bindings = "0.2.1"
-virtio-queue = "0.9"
-vm-memory = "0.12"
-vmm-sys-util = "0.11"
-
-[dev-dependencies]
-assert_matches = "1.5"
-virtio-queue = { version = "0.9", features = ["test-utils"] }
-vm-memory = { version = "0.12", features = ["backend-mmap", "backend-atomic"] }