summaryrefslogtreecommitdiffstats
path: root/meta-gstrecorder-rcar-gen3/recipes-graphics/wayland/weston/0001-remoting-Fix-remoting-gbm-dependency.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gstrecorder-rcar-gen3/recipes-graphics/wayland/weston/0001-remoting-Fix-remoting-gbm-dependency.patch')
-rw-r--r--meta-gstrecorder-rcar-gen3/recipes-graphics/wayland/weston/0001-remoting-Fix-remoting-gbm-dependency.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-gstrecorder-rcar-gen3/recipes-graphics/wayland/weston/0001-remoting-Fix-remoting-gbm-dependency.patch b/meta-gstrecorder-rcar-gen3/recipes-graphics/wayland/weston/0001-remoting-Fix-remoting-gbm-dependency.patch
new file mode 100644
index 00000000..a4334750
--- /dev/null
+++ b/meta-gstrecorder-rcar-gen3/recipes-graphics/wayland/weston/0001-remoting-Fix-remoting-gbm-dependency.patch
@@ -0,0 +1,41 @@
+From edc292341e037f9646dd183dfc110ad850184a4d Mon Sep 17 00:00:00 2001
+From: Harunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>
+Date: Fri, 7 Jun 2019 12:18:07 +0900
+Subject: [PATCH] remoting: Fix remoting gbm dependency
+
+Add missing dependency for gbm.
+
+Signed-off-by: Harunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>
+---
+ configure.ac | 1 +
+ remoting/remoting-plugin.c | 2 +-
+ 2 files changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index c05ad01..0483ecd 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -246,6 +246,7 @@ if test x$enable_remoting = xyes; then
+ if test x$enable_drm_compositor != xyes; then
+ AC_MSG_WARN([The remoting-plugin.so module requires the DRM backend.])
+ fi
++ PKG_CHECK_MODULES(REMOTING_GBM, [gbm])
+ PKG_CHECK_MODULES(REMOTING_GST, [gstreamer-1.0 gstreamer-allocators-1.0 gstreamer-app-1.0 gstreamer-video-1.0])
+ fi
+
+diff --git a/remoting/remoting-plugin.c b/remoting/remoting-plugin.c
+index e99d61e..f076825 100644
+--- a/remoting/remoting-plugin.c
++++ b/remoting/remoting-plugin.c
+@@ -36,7 +36,7 @@
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <fcntl.h>
+-#include <gbm.h>
++#include <gbm/gbm.h>
+
+ #include <gst/gst.h>
+ #include <gst/allocators/gstdmabuf.h>
+--
+2.7.4
+