summaryrefslogtreecommitdiffstats
path: root/meta-gstrecorder-rcar-gen3
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gstrecorder-rcar-gen3')
-rw-r--r--meta-gstrecorder-rcar-gen3/recipes-graphics/wayland/weston/0002-main-change-remoting-initialization-timing.patch39
-rw-r--r--meta-gstrecorder-rcar-gen3/recipes-graphics/wayland/weston_6.0.0.bbappend1
2 files changed, 40 insertions, 0 deletions
diff --git a/meta-gstrecorder-rcar-gen3/recipes-graphics/wayland/weston/0002-main-change-remoting-initialization-timing.patch b/meta-gstrecorder-rcar-gen3/recipes-graphics/wayland/weston/0002-main-change-remoting-initialization-timing.patch
new file mode 100644
index 00000000..db5060d2
--- /dev/null
+++ b/meta-gstrecorder-rcar-gen3/recipes-graphics/wayland/weston/0002-main-change-remoting-initialization-timing.patch
@@ -0,0 +1,39 @@
+From 0a0103f20437d9ed63b6cec500027a6d7bf6185f Mon Sep 17 00:00:00 2001
+From: Harunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>
+Date: Mon, 20 May 2019 18:31:32 +0900
+Subject: [PATCH] main: change remoting initialization timing
+
+Signed-off-by: Tomohito Esaki <etom@igel.co.jp>
+Signed-off-by: Harunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>
+---
+ compositor/main.c | 7 ++++---
+ 1 file changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/compositor/main.c b/compositor/main.c
+index 248298e..de7190b 100644
+--- a/compositor/main.c
++++ b/compositor/main.c
+@@ -2018,9 +2018,6 @@ load_drm_backend(struct weston_compositor *c,
+ ret = weston_compositor_load_backend(c, WESTON_BACKEND_DRM,
+ &config.base);
+
+- /* remoting */
+- load_remoting(c, wc);
+-
+ free(config.gbm_format);
+ free(config.seat_id);
+
+@@ -2664,6 +2661,10 @@ int main(int argc, char *argv[])
+ if (wet.init_failed)
+ goto out;
+
++ /* remoting: only support on drm-backend */
++ if (strstr(backend, "drm-backend.so"))
++ load_remoting(wet.compositor, config);
++
+ if (idle_time < 0)
+ weston_config_section_get_int(section, "idle-time", &idle_time, -1);
+ if (idle_time < 0)
+--
+2.9.2
+
diff --git a/meta-gstrecorder-rcar-gen3/recipes-graphics/wayland/weston_6.0.0.bbappend b/meta-gstrecorder-rcar-gen3/recipes-graphics/wayland/weston_6.0.0.bbappend
index 7e7d9942..72723ded 100644
--- a/meta-gstrecorder-rcar-gen3/recipes-graphics/wayland/weston_6.0.0.bbappend
+++ b/meta-gstrecorder-rcar-gen3/recipes-graphics/wayland/weston_6.0.0.bbappend
@@ -8,4 +8,5 @@ PACKAGECONFIG[remoting] = " --enable-remoting"
SRC_URI_append = " \
file://0001-remoting-Fix-remoting-gbm-dependency.patch \
+ file://0002-main-change-remoting-initialization-timing.patch \
"