aboutsummaryrefslogtreecommitdiffstats
path: root/meta-hmi-framework
diff options
context:
space:
mode:
Diffstat (limited to 'meta-hmi-framework')
-rw-r--r--meta-hmi-framework/recipes-demo-hmi/homescreen-2017/homescreen-2017_git.bb3
-rwxr-xr-xmeta-hmi-framework/recipes-demo-hmi/navigation/navigation_git.bbappend10
-rw-r--r--meta-hmi-framework/recipes-demo-hmi/runxdg/runxdg_git.bb17
-rw-r--r--meta-hmi-framework/recipes-graphics/agl-service-windowmanager-2017/agl-service-windowmanager-2017_git.bb3
-rw-r--r--meta-hmi-framework/recipes-graphics/libwindowmanager/libwindowmanager_git.bb3
-rw-r--r--meta-hmi-framework/recipes-multimedia/agl-service-soundmanager-2017/agl-service-soundmanager-2017_git.bb19
-rw-r--r--meta-hmi-framework/recipes-multimedia/libsoundmanager/libsoundmanager_git.bb15
-rw-r--r--meta-hmi-framework/recipes-platform/packagegroups/packagegroup-hmi-framework.bb1
8 files changed, 24 insertions, 47 deletions
diff --git a/meta-hmi-framework/recipes-demo-hmi/homescreen-2017/homescreen-2017_git.bb b/meta-hmi-framework/recipes-demo-hmi/homescreen-2017/homescreen-2017_git.bb
index 1a566aec..a28e1ce3 100644
--- a/meta-hmi-framework/recipes-demo-hmi/homescreen-2017/homescreen-2017_git.bb
+++ b/meta-hmi-framework/recipes-demo-hmi/homescreen-2017/homescreen-2017_git.bb
@@ -19,7 +19,8 @@ DEPENDS = "\
inherit qmake5 systemd pkgconfig aglwgt
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/homescreen-2017;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "2c179df8e22fd1434c88b8595ddd65ec0ed48622"
+SRCREV = "db9f41d75fb4460f668117c69be05c4d4d4c7c7c"
+PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git/"
PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
diff --git a/meta-hmi-framework/recipes-demo-hmi/navigation/navigation_git.bbappend b/meta-hmi-framework/recipes-demo-hmi/navigation/navigation_git.bbappend
deleted file mode 100755
index f0785935..00000000
--- a/meta-hmi-framework/recipes-demo-hmi/navigation/navigation_git.bbappend
+++ /dev/null
@@ -1,10 +0,0 @@
-# AGL HMI Framework adaptation of navigation
-# This recipe is integrated into navigation_git.bb when the meta-hmi-framework is integrated into meta-agl-demo.
-
-SRCREV = "${AUTOREV}"
-SRC_URI="git://github.com/AGLExport/gpsnavi.git;branch=newwm2 \
- file://download_mapdata_jp.sh \
- file://download_mapdata_uk.sh \
-"
-DEPENDS_append = " af-binder libwindowmanager virtual/libhomescreen "
-
diff --git a/meta-hmi-framework/recipes-demo-hmi/runxdg/runxdg_git.bb b/meta-hmi-framework/recipes-demo-hmi/runxdg/runxdg_git.bb
new file mode 100644
index 00000000..629575c5
--- /dev/null
+++ b/meta-hmi-framework/recipes-demo-hmi/runxdg/runxdg_git.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Launcher of XDG application on AGL HMI Framework (2017)"
+DESCRIPTION = "The command 'runxdg' is a launcher to execute XDG application \
+ on AGL HMI Framework which using wayland-ivi-extension"
+HOMEPAGE = "https://git.automotivelinux.org/staging/xdg-launcher"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+DEPENDS = "json-c wayland wayland-ivi-extension virtual/libhomescreen libwindowmanager"
+
+inherit cmake
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/xdg-launcher;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
diff --git a/meta-hmi-framework/recipes-graphics/agl-service-windowmanager-2017/agl-service-windowmanager-2017_git.bb b/meta-hmi-framework/recipes-graphics/agl-service-windowmanager-2017/agl-service-windowmanager-2017_git.bb
index bab60cd2..b5245602 100644
--- a/meta-hmi-framework/recipes-graphics/agl-service-windowmanager-2017/agl-service-windowmanager-2017_git.bb
+++ b/meta-hmi-framework/recipes-graphics/agl-service-windowmanager-2017/agl-service-windowmanager-2017_git.bb
@@ -15,7 +15,8 @@ DEPENDS = "af-binder json-c wayland wayland-ivi-extension wayland-native"
inherit cmake aglwgt
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-windowmanager-2017;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "7fb167a27e9e12ef38c5942cf73679bff12a5b25"
+SRCREV = "17339414fd26e831710b0b7f3a429b4dfb868d45"
+PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
#If you would like to output log, uncomment out
diff --git a/meta-hmi-framework/recipes-graphics/libwindowmanager/libwindowmanager_git.bb b/meta-hmi-framework/recipes-graphics/libwindowmanager/libwindowmanager_git.bb
index d2b5c223..17a7ac11 100644
--- a/meta-hmi-framework/recipes-graphics/libwindowmanager/libwindowmanager_git.bb
+++ b/meta-hmi-framework/recipes-graphics/libwindowmanager/libwindowmanager_git.bb
@@ -10,5 +10,6 @@ RDEPENDS_${PN} = "agl-service-windowmanager-2017"
inherit cmake
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/libwindowmanager.git;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "9b8407501c13275a831942578bf52e3a7b0b3248"
+SRCREV = "026af4256b9b69ffd52972d6da0cb394dff2b0e6"
S = "${WORKDIR}/git"
+PV = "1.0+git${SRCPV}"
diff --git a/meta-hmi-framework/recipes-multimedia/agl-service-soundmanager-2017/agl-service-soundmanager-2017_git.bb b/meta-hmi-framework/recipes-multimedia/agl-service-soundmanager-2017/agl-service-soundmanager-2017_git.bb
deleted file mode 100644
index 9f9e5643..00000000
--- a/meta-hmi-framework/recipes-multimedia/agl-service-soundmanager-2017/agl-service-soundmanager-2017_git.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-SUMMARY = "Sound Manager binding"
-DESCRIPTION = "Sound Manager is the service binding to communicate \
- with Genivi Audio Manager. Genivi Audio Manager is \
- the policy manager for sound. It controls volume \
- and routing according to various situations. \
- "
-HOMEPAGE = "https://wiki.automotivelinux.org/soundmanager"
-SECTION = "multimedia"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-
-DEPENDS = "dbus glib-2.0 af-binder json-c"
-RDEPENDS_${PN} = "audiomanager audiomanager-plugins"
-
-inherit cmake aglwgt
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-soundmanager-2017;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "71e9700fe906fff4f111bc70d025912ee5dd095a"
-S = "${WORKDIR}/git"
diff --git a/meta-hmi-framework/recipes-multimedia/libsoundmanager/libsoundmanager_git.bb b/meta-hmi-framework/recipes-multimedia/libsoundmanager/libsoundmanager_git.bb
deleted file mode 100644
index e6943701..00000000
--- a/meta-hmi-framework/recipes-multimedia/libsoundmanager/libsoundmanager_git.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-SUMMARY = "Sound Manager client library for applications"
-DESCRIPTION = "Sound Manager client library for applications built with recipe"
-HOMEPAGE = "https://wiki.automotivelinux.org/soundmanager"
-SECTION = "multimedia"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-
-DEPENDS = "af-binder json-c"
-RDEPENDS_${PN} = "agl-service-soundmanager-2017"
-
-inherit cmake
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/libsoundmanager.git;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "cda4a958e85d397bae142fbe6068a3e17d4aa935"
-S = "${WORKDIR}/git"
diff --git a/meta-hmi-framework/recipes-platform/packagegroups/packagegroup-hmi-framework.bb b/meta-hmi-framework/recipes-platform/packagegroups/packagegroup-hmi-framework.bb
index 1adbee86..d935e6c1 100644
--- a/meta-hmi-framework/recipes-platform/packagegroups/packagegroup-hmi-framework.bb
+++ b/meta-hmi-framework/recipes-platform/packagegroups/packagegroup-hmi-framework.bb
@@ -12,4 +12,5 @@ RDEPENDS_${PN} += " \
libwindowmanager \
qlibwindowmanager \
libhomescreen-2017 \
+ runxdg \
"