summaryrefslogtreecommitdiffstats
path: root/meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libxml-xpath-perl_1.44.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libxml-xpath-perl_1.44.bb')
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libxml-xpath-perl_1.44.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libxml-xpath-perl_1.44.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libxml-xpath-perl_1.44.bb
index 3f130550..3049ceda 100644
--- a/meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libxml-xpath-perl_1.44.bb
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libxml-xpath-perl_1.44.bb
@@ -14,7 +14,7 @@ S = "${WORKDIR}/XML-XPath-${PV}"
inherit cpan ptest-perl
-do_install_append_class-native() {
+do_install:append:class-native() {
# Fix xpath script shebang to work inside native environment
sed -i 's|#!.*/perl|#!/usr/bin/env perl|' ${D}${bindir}/xpath
}
@@ -24,7 +24,7 @@ do_install_ptest() {
install -m 0644 ${S}/examples/test.xml ${D}${PTEST_PATH}/examples/
}
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
perl-module-carp \
perl-module-data-dumper \
perl-module-file-spec \
@@ -38,7 +38,7 @@ RDEPENDS_${PN} += " \
libscalar-list-utils-perl \
"
-RDEPENDS_${PN}-ptest += " \
+RDEPENDS:${PN}-ptest += " \
libpath-tiny-perl \
"