summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb')
-rw-r--r--meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb15
1 files changed, 11 insertions, 4 deletions
diff --git a/meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb b/meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb
index edcb9fe4..67263790 100644
--- a/meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb
+++ b/meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb
@@ -8,12 +8,13 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=4202492ed9afcab3aaecc4a9ec32adb2"
SRC_URI = "\
git://gerrit.automotivelinux.org/gerrit/apps/flutter-speechrecognition-demo;protocol=https;branch=${AGL_BRANCH} \
- "
-
+ file://agl-app-flutter@flutter_voiceassistant.service \
+"
+
SRCREV = "${AUTOREV}"
S = "${WORKDIR}/git"
-inherit agl-app flutter-app
+inherit agl-app flutter-app
# flutter-app
#############
@@ -25,4 +26,10 @@ FLUTTER_BUILD_ARGS = "bundle -v"
#########
AGL_APP_TEMPLATE = "agl-app-flutter"
AGL_APP_ID = "flutter_voiceassistant"
-AGL_APP_NAME = "Voice Assistant" \ No newline at end of file
+AGL_APP_NAME = "Voice Assistant"
+
+do_install:append() {
+ install -D -m 0644 ${WORKDIR}/agl-app-flutter@flutter_voiceassistant.service ${D}${systemd_system_unitdir}/agl-app-flutter@flutter_voiceassistant.service
+}
+
+FILES:${PN} += "${datadir} "