summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-assistant
diff options
context:
space:
mode:
Diffstat (limited to 'meta-offline-voice-agent/recipes-assistant')
-rw-r--r--meta-offline-voice-agent/recipes-assistant/voiceagent-app/files/agl-app-flutter@flutter_voiceassistant.service2
-rw-r--r--meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb8
2 files changed, 4 insertions, 6 deletions
diff --git a/meta-offline-voice-agent/recipes-assistant/voiceagent-app/files/agl-app-flutter@flutter_voiceassistant.service b/meta-offline-voice-agent/recipes-assistant/voiceagent-app/files/agl-app-flutter@flutter_voiceassistant.service
index 101326b3..889c5768 100644
--- a/meta-offline-voice-agent/recipes-assistant/voiceagent-app/files/agl-app-flutter@flutter_voiceassistant.service
+++ b/meta-offline-voice-agent/recipes-assistant/voiceagent-app/files/agl-app-flutter@flutter_voiceassistant.service
@@ -6,4 +6,4 @@ Type=simple
User=agl-driver
EnvironmentFile=/etc/default/flutter
Environment=XDG_RUNTIME_DIR=/run/user/1001/
-ExecStart=/usr/bin/flutter-auto --b=/flutter/flutter_voiceassistant/${FLUTTER_VERSION}/${FLUTTER_RUNTIME} --xdg-shell-app-id=flutter_voiceassistant
+ExecStart=/usr/bin/flutter-auto -b /usr/share/flutter/flutter_voiceassistant/${FLUTTER_VERSION}/${FLUTTER_RUNTIME} --xdg-shell-app-id flutter_voiceassistant
diff --git a/meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb b/meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb
index cdb9d3d8..be3edc0f 100644
--- a/meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb
+++ b/meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb
@@ -6,10 +6,9 @@ SECTION = "graphics"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=4202492ed9afcab3aaecc4a9ec32adb2"
-SRC_URI = "\
- git://gerrit.automotivelinux.org/gerrit/apps/flutter-speechrecognition-demo;protocol=https;branch=${AGL_BRANCH} \
- file://agl-app-flutter@flutter_voiceassistant.service \
-"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-speechrecognition-demo;protocol=https;branch=${AGL_BRANCH} \
+ file://agl-app-flutter@flutter_voiceassistant.service \
+ "
SRCREV = "${AUTOREV}"
S = "${WORKDIR}/git"
@@ -19,7 +18,6 @@ inherit agl-app flutter-app
# flutter-app
#############
PUBSPEC_APPNAME = "flutter_voiceassistant"
-FLUTTER_APPLICATION_INSTALL_PREFIX = "/flutter"
FLUTTER_BUILD_ARGS = "bundle -v"
# agl-app