summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-devtools/recipes-intel/intel-compute-runtime
diff options
context:
space:
mode:
Diffstat (limited to 'meta-offline-voice-agent/recipes-devtools/recipes-intel/intel-compute-runtime')
-rw-r--r--meta-offline-voice-agent/recipes-devtools/recipes-intel/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch51
-rw-r--r--meta-offline-voice-agent/recipes-devtools/recipes-intel/intel-compute-runtime/disable-werror.patch16
-rw-r--r--meta-offline-voice-agent/recipes-devtools/recipes-intel/intel-compute-runtime/external-ocloc.patch40
3 files changed, 0 insertions, 107 deletions
diff --git a/meta-offline-voice-agent/recipes-devtools/recipes-intel/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch b/meta-offline-voice-agent/recipes-devtools/recipes-intel/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch
deleted file mode 100644
index 265fcfa2..00000000
--- a/meta-offline-voice-agent/recipes-devtools/recipes-intel/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-From a6361d635e5f3046853883f3ac06fb175116933c Mon Sep 17 00:00:00 2001
-From: Dongwon Kim <dongwon.kim@intel.com>
-Date: Sat, 21 Aug 2021 16:09:39 -0700
-Subject: [PATCH] Build not able to locate cpp_generation_tool.
-
-Upstream-Status: Inappropriate [oe specific]
-
-Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
-Signed-off-by: Dongwon Kim <dongwon.kim@intel.com>
----
- shared/source/built_ins/kernels/CMakeLists.txt | 10 +++++-----
- 1 file changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/shared/source/built_ins/kernels/CMakeLists.txt b/shared/source/built_ins/kernels/CMakeLists.txt
-index ed85a37c52..f7c9e79137 100644
---- a/shared/source/built_ins/kernels/CMakeLists.txt
-+++ b/shared/source/built_ins/kernels/CMakeLists.txt
-@@ -107,9 +107,9 @@ function(compile_builtin core_type platform_it builtin bits builtin_options mode
- )
- add_custom_command(
- OUTPUT ${OUTPUT_FILE_CPP}
-- COMMAND $<TARGET_FILE:cpp_generate_tool> --file ${BINARY_OUTPUT}.bin --output ${OUTPUT_FILE_CPP} --array ${mode}_${BASENAME} --device ${RELEASE_FILENAME}
-+ COMMAND cpp_generate_tool --file ${BINARY_OUTPUT}.bin --output ${OUTPUT_FILE_CPP} --array ${mode}_${BASENAME} --device ${RELEASE_FILENAME}
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
-- DEPENDS ${OUTPUT_FILES_BINARIES} $<TARGET_FILE:cpp_generate_tool>
-+ DEPENDS ${OUTPUT_FILES_BINARIES} cpp_generate_tool
- )
- list(APPEND BUILTINS_COMMANDS "${OUTPUT_FILE_CPP}")
- else()
-@@ -159,9 +159,9 @@ function(generate_cpp_spirv builtin)
- )
- add_custom_command(
- OUTPUT ${OUTPUT_FILE_CPP}
-- COMMAND $<TARGET_FILE:cpp_generate_tool> --file ${GENERATED_SPV_INPUT} --output ${OUTPUT_FILE_CPP} --array ${BASENAME}
-+ COMMAND cpp_generate_tool --file ${GENERATED_SPV_INPUT} --output ${OUTPUT_FILE_CPP} --array ${BASENAME}
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
-- DEPENDS ${GENERATED_SPV_INPUT} $<TARGET_FILE:cpp_generate_tool>
-+ DEPENDS ${GENERATED_SPV_INPUT} cpp_generate_tool
- )
- set(OUTPUT_LIST_CPP_FILES ${OUTPUT_LIST_CPP_FILES} ${OUTPUT_FILE_CPP} PARENT_SCOPE)
- else()
-@@ -277,4 +277,4 @@ if(NOT "${OUTPUT_LIST_CPP_FILES}" STREQUAL "")
- )
- endif()
-
--apply_macro_for_each_core_type("SUPPORTED")
-\ No newline at end of file
-+apply_macro_for_each_core_type("SUPPORTED")
---
-2.43.2
-
diff --git a/meta-offline-voice-agent/recipes-devtools/recipes-intel/intel-compute-runtime/disable-werror.patch b/meta-offline-voice-agent/recipes-devtools/recipes-intel/intel-compute-runtime/disable-werror.patch
deleted file mode 100644
index 20d9b847..00000000
--- a/meta-offline-voice-agent/recipes-devtools/recipes-intel/intel-compute-runtime/disable-werror.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Upstream-Status: Inappropriate
-Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index d52e089778..bc0cf35014 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -727,7 +727,7 @@ if(NOT MSVC)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-noexcept-type") # Added for gtest
- endif()
- endif()
-- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror -Werror=vla")
-+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror=vla")
-
- if(USE_SANITIZE_UB)
- check_cxx_compiler_flag(-fsanitize=undefined COMPILER_SUPPORTS_UNDEFINED_BEHAVIOR_SANITIZER)
diff --git a/meta-offline-voice-agent/recipes-devtools/recipes-intel/intel-compute-runtime/external-ocloc.patch b/meta-offline-voice-agent/recipes-devtools/recipes-intel/intel-compute-runtime/external-ocloc.patch
deleted file mode 100644
index 5f93b7b6..00000000
--- a/meta-offline-voice-agent/recipes-devtools/recipes-intel/intel-compute-runtime/external-ocloc.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From 1f58c22992ddea4167b01b44448528de427f50d5 Mon Sep 17 00:00:00 2001
-From: Dongwon Kim <dongwon.kim@intel.com>
-Date: Wed, 2 Mar 2022 15:52:45 -0800
-Subject: [PATCH] external ocloc
-
-Upstream-Status: Inappropriate
-
-Signed-off-by: Dongwon Kim <dongwon.kim@intel.com>
----
- cmake/ocloc_cmd_prefix.cmake | 14 ++++++++------
- 1 file changed, 8 insertions(+), 6 deletions(-)
-
-diff --git a/cmake/ocloc_cmd_prefix.cmake b/cmake/ocloc_cmd_prefix.cmake
-index 2b44330831..03067c9df0 100644
---- a/cmake/ocloc_cmd_prefix.cmake
-+++ b/cmake/ocloc_cmd_prefix.cmake
-@@ -4,12 +4,14 @@
- # SPDX-License-Identifier: MIT
- #
-
--if(WIN32)
-- set(ocloc_cmd_prefix ocloc)
--else()
-- if(DEFINED NEO__IGC_LIBRARY_PATH)
-- set(ocloc_cmd_prefix ${CMAKE_COMMAND} -E env "LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:${NEO__IGC_LIBRARY_PATH}:$<TARGET_FILE_DIR:ocloc_lib>" $<TARGET_FILE:ocloc>)
-+if(NOT DEFINED ocloc_cmd_prefix)
-+ if(WIN32)
-+ set(ocloc_cmd_prefix ocloc)
- else()
-- set(ocloc_cmd_prefix ${CMAKE_COMMAND} -E env "LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:$<TARGET_FILE_DIR:ocloc_lib>" $<TARGET_FILE:ocloc>)
-+ if(DEFINED NEO__IGC_LIBRARY_PATH)
-+ set(ocloc_cmd_prefix LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:${NEO__IGC_LIBRARY_PATH}:$<TARGET_FILE_DIR:ocloc_lib> $<TARGET_FILE:ocloc>)
-+ else()
-+ set(ocloc_cmd_prefix LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:$<TARGET_FILE_DIR:ocloc_lib> $<TARGET_FILE:ocloc>)
-+ endif()
- endif()
- endif()
---
-2.37.3
-