summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-numpy
diff options
context:
space:
mode:
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-numpy')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-numpy/python3-numpy/0001-Disable-runtimelibdirs-for-cross-compile.patch25
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-numpy/python3-numpy/0001-Remove-using-library-directories-as-runtime-library-.patch48
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-numpy/python3-numpy_%.bbappend6
3 files changed, 0 insertions, 79 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-numpy/python3-numpy/0001-Disable-runtimelibdirs-for-cross-compile.patch b/meta-offline-voice-agent/recipes-python/python3-numpy/python3-numpy/0001-Disable-runtimelibdirs-for-cross-compile.patch
deleted file mode 100644
index c96bb64d..00000000
--- a/meta-offline-voice-agent/recipes-python/python3-numpy/python3-numpy/0001-Disable-runtimelibdirs-for-cross-compile.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 9729175ae0ee7b2c8641483b9dfd16051cc4ad23 Mon Sep 17 00:00:00 2001
-From: Greg Anders <greg@gpanders.com>
-Date: Mon, 2 Mar 2020 14:34:04 +0000
-Subject: [PATCH] Disable runtime_lib_dirs for cross compile
-
----
- numpy/distutils/system_info.py | 5 +----
- 1 file changed, 1 insertion(+), 4 deletions(-)
-
-diff --git a/numpy/distutils/system_info.py b/numpy/distutils/system_info.py
-index 28c7b92..d1a92ab 100644
---- a/numpy/distutils/system_info.py
-+++ b/numpy/distutils/system_info.py
-@@ -669,10 +669,7 @@ class system_info(object):
- return self.get_paths(self.section, key)
-
- def get_runtime_lib_dirs(self, key='runtime_library_dirs'):
-- path = self.get_paths(self.section, key)
-- if path == ['']:
-- path = []
-- return path
-+ return []
-
- def get_include_dirs(self, key='include_dirs'):
- return self.get_paths(self.section, key) \ No newline at end of file
diff --git a/meta-offline-voice-agent/recipes-python/python3-numpy/python3-numpy/0001-Remove-using-library-directories-as-runtime-library-.patch b/meta-offline-voice-agent/recipes-python/python3-numpy/python3-numpy/0001-Remove-using-library-directories-as-runtime-library-.patch
deleted file mode 100644
index d7e818a8..00000000
--- a/meta-offline-voice-agent/recipes-python/python3-numpy/python3-numpy/0001-Remove-using-library-directories-as-runtime-library-.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From b14d1c1b684014a65b8b7ea0030f7f070a34e6c5 Mon Sep 17 00:00:00 2001
-From: Scott Murray <scott.murray@konsulko.com>
-Date: Tue, 4 Jul 2023 10:24:11 -0400
-Subject: [PATCH] Remove using library directories as runtime library
- directories
-
-The code in calc_libraries_info in distutils/system_info.py converts
-library directories to runtime library directories, which seems to
-only make sense in an environment when the external libraries are not
-coming from standard system locations. It is actively harmful in the
-OE build environment since it results in sysroot paths getting put
-into RPATH in the resulting binaries. Remove that snippet of code so
-that module .so's do not trigger the rpath QA sanity checking.
-
-Upstream-Status: Inappropriate
-
-Signed-off-by: Scott Murray <scott.murray@konsulko.com>
----
- numpy/distutils/system_info.py | 13 -------------
- 1 file changed, 13 deletions(-)
-
-diff --git a/numpy/distutils/system_info.py b/numpy/distutils/system_info.py
-index 656bc37..fb075a1 100644
---- a/numpy/distutils/system_info.py
-+++ b/numpy/distutils/system_info.py
-@@ -728,19 +728,6 @@ class system_info:
- else:
- log.info('Library %s was not found. Ignoring' % (lib))
-
-- if r_dirs:
-- i = self.check_libs(r_dirs, [lib])
-- if i is not None:
-- # Swap library keywords found to runtime_library_dirs
-- # the libraries are insisting on the user having defined
-- # them using the library_dirs, and not necessarily by
-- # runtime_library_dirs
-- del i['libraries']
-- i['runtime_library_dirs'] = i.pop('library_dirs')
-- dict_append(info, **i)
-- else:
-- log.info('Runtime library %s was not found. Ignoring' % (lib))
--
- return info
-
- def set_info(self, **info):
---
-2.40.1
-
diff --git a/meta-offline-voice-agent/recipes-python/python3-numpy/python3-numpy_%.bbappend b/meta-offline-voice-agent/recipes-python/python3-numpy/python3-numpy_%.bbappend
deleted file mode 100644
index b8d1f144..00000000
--- a/meta-offline-voice-agent/recipes-python/python3-numpy/python3-numpy_%.bbappend
+++ /dev/null
@@ -1,6 +0,0 @@
-FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
-
-SRC_URI += " \
- file://0001-Disable-runtimelibdirs-for-cross-compile.patch \
- file://0001-Remove-using-library-directories-as-runtime-library-.patch \
- "