summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-rasa/files
diff options
context:
space:
mode:
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-rasa/files')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-anyio-add-setup-file.patch76
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-exceptiongroup-add-setup-file.patch46
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-magic-filter-add-setup-file.patch72
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-rasa-remove-group-from-poetry-as-its-not-supported.patch23
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-rasa-sdk-remove-group-from-poetry-as-its-not-support.patch31
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-structlog-add-setup-file.patch61
6 files changed, 309 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-anyio-add-setup-file.patch b/meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-anyio-add-setup-file.patch
new file mode 100644
index 00000000..5f44d2d4
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-anyio-add-setup-file.patch
@@ -0,0 +1,76 @@
+From 4a1ad21ba577466ae70a8b6ed6d8c4e12b0cb851 Mon Sep 17 00:00:00 2001
+From: Malik Talha <talhamalik727x@gmail.com>
+Date: Tue, 8 Aug 2023 17:26:30 +0500
+Subject: [PATCH] anyio add setup file
+
+add setup.py to replace build_meta system as its not working properly
+---
+ setup.py | 59 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++
+ 1 file changed, 59 insertions(+)
+ create mode 100644 setup.py
+
+diff --git a/setup.py b/setup.py
+new file mode 100644
+index 0000000..f15d18b
+--- /dev/null
++++ b/setup.py
+@@ -0,0 +1,59 @@
++from setuptools import setup, find_packages
++
++setup(
++ name="anyio",
++ description="High level compatibility layer for multiple asynchronous event loop implementations",
++ version="3.7.1",
++ classifiers=[
++ "Development Status :: 5 - Production/Stable",
++ "Intended Audience :: Developers",
++ "License :: OSI Approved :: MIT License",
++ "Framework :: AnyIO",
++ "Typing :: Typed",
++ "Programming Language :: Python",
++ "Programming Language :: Python :: 3",
++ "Programming Language :: Python :: 3.8",
++ "Programming Language :: Python :: 3.9",
++ "Programming Language :: Python :: 3.10",
++ "Programming Language :: Python :: 3.11",
++ "Programming Language :: Python :: 3.12",
++ ],
++ author="Alex Grönholm",
++ author_email="alex.gronholm@nextday.fi",
++ license="MIT",
++ python_requires=">=3.8",
++ install_requires=[
++ "exceptiongroup >= 1.0.2; python_version < '3.11'",
++ "idna >= 2.8",
++ "sniffio >= 1.1",
++ ],
++ packages=find_packages(where="src", exclude=["tests", "debug"]),
++ package_dir={"": "src"},
++ include_package_data=True,
++ extras_require={
++ "trio": ["trio >= 0.22"],
++ "test": [
++ "anyio[trio]",
++ "coverage[toml] >= 4.5",
++ "hypothesis >= 4.0",
++ "psutil >= 5.9",
++ "pytest >= 7.0",
++ "pytest-mock >= 3.6.1",
++ "trustme",
++ "uvloop >= 0.17; python_version < '3.12' and platform_python_implementation == 'CPython' and platform_system != 'Windows'",
++ ],
++ "doc": [
++ "packaging",
++ "Sphinx ~= 6.1.0",
++ "sphinx_rtd_theme",
++ "sphinxcontrib-jquery",
++ "sphinx-autodoc-typehints >= 1.2.0",
++ ],
++ },
++ project_urls={
++ "Documentation": "https://anyio.readthedocs.io/en/latest/",
++ "Changelog": "https://anyio.readthedocs.io/en/stable/versionhistory.html",
++ "Source code": "https://github.com/agronholm/anyio",
++ "Issue tracker": "https://github.com/agronholm/anyio/issues",
++ },
++)
diff --git a/meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-exceptiongroup-add-setup-file.patch b/meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-exceptiongroup-add-setup-file.patch
new file mode 100644
index 00000000..579b2b78
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-exceptiongroup-add-setup-file.patch
@@ -0,0 +1,46 @@
+From e3f45073c4898fc99cab6f78da1cb3e8a3df9aae Mon Sep 17 00:00:00 2001
+From: Malik Talha <talhamalik727x@gmail.com>
+Date: Tue, 8 Aug 2023 16:40:54 +0500
+Subject: [PATCH] exceptiongroup add setup file
+
+add setup.py to replace flit_scm build system as its not supported
+---
+ setup.py | 29 +++++++++++++++++++++++++++++
+ 1 file changed, 29 insertions(+)
+ create mode 100644 setup.py
+
+diff --git a/setup.py b/setup.py
+new file mode 100644
+index 0000000..2a7b6ff
+--- /dev/null
++++ b/setup.py
+@@ -0,0 +1,29 @@
++from setuptools import setup, find_packages
++
++setup(
++ name="exceptiongroup",
++ version="1.1.2",
++ description="Backport of PEP 654 (exception groups)",
++ classifiers=[
++ "Development Status :: 5 - Production/Stable",
++ "Intended Audience :: Developers",
++ "License :: OSI Approved :: MIT License",
++ "Programming Language :: Python",
++ "Programming Language :: Python :: 3 :: Only",
++ "Typing :: Typed",
++ ],
++ author="Alex Grönholm",
++ author_email="alex.gronholm@nextday.fi",
++ license="MIT",
++ python_requires=">=3.7",
++ packages=find_packages(where="src", exclude=["tests", "debug"]),
++ package_dir={"": "src"},
++ include_package_data=True,
++ install_requires=[],
++ extras_require={"test": ["pytest >= 6"]},
++ project_urls={
++ "Changelog": "https://github.com/agronholm/exceptiongroup/blob/main/CHANGES.rst",
++ "Source code": "https://github.com/agronholm/exceptiongroup",
++ "Issue Tracker": "https://github.com/agronholm/exceptiongroup/issues",
++ },
++)
diff --git a/meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-magic-filter-add-setup-file.patch b/meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-magic-filter-add-setup-file.patch
new file mode 100644
index 00000000..457a91df
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-magic-filter-add-setup-file.patch
@@ -0,0 +1,72 @@
+From d5a4cba0199c269e13cf6f25daf49438cd1b5c32 Mon Sep 17 00:00:00 2001
+From: Malik Talha <talhamalik727x@gmail.com>
+Date: Sun, 6 Aug 2023 23:54:27 +0500
+Subject: [PATCH] magic-filter add setup file
+
+setup.py backend instead of hatchling which is not supported
+---
+ setup.py | 55 +++++++++++++++++++++++++++++++++++++++++++++++++++++++
+ 1 file changed, 55 insertions(+)
+ create mode 100644 setup.py
+
+diff --git a/setup.py b/setup.py
+new file mode 100644
+index 0000000..b98f77a
+--- /dev/null
++++ b/setup.py
+@@ -0,0 +1,55 @@
++from setuptools import setup, find_packages
++
++packages = [p for p in find_packages()
++ if "tests" not in p and "debug" not in p]
++
++setup(
++ name="magic-filter",
++ version="0.1.0", # Set the appropriate version number
++ description="",
++ long_description="", # Add your long description here
++ long_description_content_type="text/markdown",
++ author="Alex Root Junior",
++ author_email="pypi@aiogram.dev",
++ url="https://github.com/aiogram/magic-filter",
++ classifiers=[
++ "Development Status :: 3 - Alpha",
++ "License :: OSI Approved :: MIT License",
++ "Programming Language :: Python",
++ "Programming Language :: Python :: 3.7",
++ "Programming Language :: Python :: 3.8",
++ "Programming Language :: Python :: 3.9",
++ "Programming Language :: Python :: 3.10",
++ "Programming Language :: Python :: 3.11",
++ "Programming Language :: Python :: Implementation :: CPython",
++ "Topic :: Utilities",
++ "Typing :: Typed",
++ ],
++ keywords=["magic", "filter", "validation"],
++ license="MIT",
++ python_requires=">=3.7",
++ install_requires=[
++ 'wheel',
++ ],
++ extras_require={
++ "dev": [
++ "pre-commit~=2.20.0",
++ "pytest~=7.1.3",
++ "pytest-cov~=3.0.0",
++ "pytest-html~=3.1.1",
++ "flake8~=5.0.4",
++ "mypy~=0.971",
++ "black~=22.8.0",
++ "isort~=5.10.1",
++ "types-setuptools~=65.3.0",
++ ]
++ },
++ project_urls={
++ "Documentation": "https://docs.aiogram.dev/en/dev-3.x/dispatcher/filters/magic_filters.html",
++ "Issues": "https://github.com/aiogram/magic-filter/issues",
++ "Source": "https://github.com/aiogram/magic-filter",
++ },
++ packages=packages,
++ include_package_data=True,
++ zip_safe=False,
++)
diff --git a/meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-rasa-remove-group-from-poetry-as-its-not-supported.patch b/meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-rasa-remove-group-from-poetry-as-its-not-supported.patch
new file mode 100644
index 00000000..ad7f2bb8
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-rasa-remove-group-from-poetry-as-its-not-supported.patch
@@ -0,0 +1,23 @@
+From db7ca896e22ae838385d5928fb5a0e8b80630360 Mon Sep 17 00:00:00 2001
+From: Malik Talha <talhamalik727x@gmail.com>
+Date: Mon, 24 Jul 2023 12:17:35 +0500
+Subject: [PATCH] rasa remove group from poetry as its not supported
+
+poetry version < 1.20 deos not support group in pyproject.toml
+---
+ pyproject.toml | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/pyproject.toml b/pyproject.toml
+index 9fe32cb..9ee4b5f 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -300,7 +300,7 @@ extras = [ "tls", "srv",]
+ git = "https://github.com/RasaHQ/pytest-sanic"
+ branch = "fix_signal_issue"
+
+-[tool.poetry.group.dev.dependencies]
++[tool.poetry.dev-dependencies]
+ ruff = ">=0.0.255,<0.0.256"
+ docker = "^6.0.1"
+ pytest-cov = "^4.0.0"
diff --git a/meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-rasa-sdk-remove-group-from-poetry-as-its-not-support.patch b/meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-rasa-sdk-remove-group-from-poetry-as-its-not-support.patch
new file mode 100644
index 00000000..7c92d9be
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-rasa-sdk-remove-group-from-poetry-as-its-not-support.patch
@@ -0,0 +1,31 @@
+From 39db336c60f5499568802b878acb864008739d48 Mon Sep 17 00:00:00 2001
+From: Malik Talha <talhamalik727x@gmail.com>
+Date: Mon, 7 Aug 2023 02:14:25 +0500
+Subject: [PATCH] rasa-sdk remove group from poetry as its not supported
+
+poetry version < 1.20 does not support group in pyproject.toml
+---
+ pyproject.toml | 6 ++----
+ 1 file changed, 2 insertions(+), 4 deletions(-)
+
+diff --git a/pyproject.toml b/pyproject.toml
+index e8882e1..f3e0dec 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -96,6 +96,8 @@ pep440-version-utils = "^0.3.0"
+ semantic_version = "^2.8.5"
+ mypy = "^1.3"
+ sanic-testing = "^22.3.0, <22.9.0"
++ruff = ">=0.0.256,<0.0.276"
++pytest-asyncio = "^0.21.0"
+
+ [tool.ruff.pydocstyle]
+ convention = "google"
+@@ -103,7 +105,3 @@ convention = "google"
+ [tool.pytest.ini_options]
+ python_functions = "test_"
+ asyncio_mode = "auto"
+-
+-[tool.poetry.group.dev.dependencies]
+-ruff = ">=0.0.256,<0.0.276"
+-pytest-asyncio = "^0.21.0"
diff --git a/meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-structlog-add-setup-file.patch b/meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-structlog-add-setup-file.patch
new file mode 100644
index 00000000..955bde2a
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-structlog-add-setup-file.patch
@@ -0,0 +1,61 @@
+From dedd112f7607ad9f4edd3e2aba60d9cb2cb59b2e Mon Sep 17 00:00:00 2001
+From: Malik Talha <talhamalik727x@gmail.com>
+Date: Mon, 7 Aug 2023 00:19:14 +0500
+Subject: [PATCH] structlog add setup file
+
+add setup.py to replace hatchling build system as its not supported
+---
+ setup.py | 44 ++++++++++++++++++++++++++++++++++++++++++++
+ 1 file changed, 44 insertions(+)
+ create mode 100644 setup.py
+
+diff --git a/setup.py b/setup.py
+new file mode 100644
+index 0000000..4bc2b79
+--- /dev/null
++++ b/setup.py
+@@ -0,0 +1,44 @@
++from setuptools import setup, find_packages
++
++setup(
++ name="structlog",
++ version="23.1.0",
++ dynamic=["readme", "version"],
++ description="Structured Logging for Python",
++ author="Hynek Schlawack",
++ author_email="hs@ox.cx",
++ url="https://github.com/hynek/structlog",
++ classifiers=[
++ "Development Status :: 5 - Production/Stable",
++ "License :: OSI Approved :: Apache Software License",
++ "License :: OSI Approved :: MIT License",
++ "Operating System :: OS Independent",
++ "Programming Language :: Python :: 3.8",
++ "Programming Language :: Python :: 3.9",
++ "Programming Language :: Python :: 3.10",
++ "Programming Language :: Python :: 3.11",
++ "Programming Language :: Python :: 3.12",
++ "Programming Language :: Python :: Implementation :: CPython",
++ "Programming Language :: Python :: Implementation :: PyPy",
++ "Topic :: System :: Logging",
++ "Typing :: Typed",
++ ],
++ keywords=["logging", "structured", "structure", "log"],
++ license="MIT OR Apache-2.0",
++ python_requires=">=3.8",
++ install_requires=[
++ "wheel",
++ ],
++ project_urls={
++ "Documentation": "https://www.structlog.org/",
++ "Changelog": "https://www.structlog.org/en/stable/changelog.html",
++ "Bug Tracker": "https://github.com/hynek/structlog/issues",
++ "Source Code": "https://github.com/hynek/structlog",
++ "Funding": "https://github.com/sponsors/hynek",
++ "Tidelift": "https://tidelift.com/subscription/pkg/pypi-structlog?utm_source=pypi-structlog&utm_medium=pypi",
++ },
++ packages=find_packages(where="src", exclude=["tests", "debug"]),
++ package_dir={"": "src"},
++ include_package_data=True,
++ zip_safe=False,
++)