summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-rasa/python3-boto3_1.28.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-rasa/python3-boto3_1.28.9.bb')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-rasa/python3-boto3_1.28.9.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-rasa/python3-boto3_1.28.9.bb b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-boto3_1.28.9.bb
new file mode 100644
index 00000000..4cb31220
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-boto3_1.28.9.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Boto3 is the Amazon Web Services (AWS) Software Development Kit (SDK) for Python, which allows Python developers to write software that makes use of services like Amazon S3 and Amazon EC2."
+HOMEPAGE = "https://github.com/boto/boto3"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+SRC_URI = "\
+ git://github.com/boto/boto3.git;protocol=https;branch=master \
+ "
+
+PV = "1.28.9+git${SRCPV}"
+S = "${WORKDIR}/git"
+SRCREV = "59b3da9b9c12de8c13bdb51d9aed6e9db4ff170d"
+
+DEPENDS += "\
+ python3 \
+ python3-botocore \
+ python3-jmespath \
+ python3-s3transfer \
+ "
+
+inherit setuptools3
+
+# python3 needs to be included since there are core dependencies such
+# as getpass.
+RDEPENDS:${PN} += "\
+ python3 \
+ python3-botocore \
+ python3-jmespath \
+ python3-s3transfer \
+ "