summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-rasa/python3-pydantic_1.10.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-rasa/python3-pydantic_1.10.9.bb')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-rasa/python3-pydantic_1.10.9.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-rasa/python3-pydantic_1.10.9.bb b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-pydantic_1.10.9.bb
new file mode 100644
index 00000000..44ada305
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-pydantic_1.10.9.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Data validation using Python type hints"
+HOMEPAGE = "https://github.com/pydantic/pydantic"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2c02ea30650b91528657db64baea1757"
+
+PYPI_PACKAGE = "pydantic"
+
+SRC_URI[md5sum] = "d8135717be5067f7acfdeb4905d318ab"
+SRC_URI[sha256sum] = "95c70da2cd3b6ddf3b9645ecaa8d98f3d80c606624b6d245558d202cd23ea3be"
+
+DEPENDS += " \
+ python3-typing-extensions \
+ python3-setuptools-native \
+"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-typing-extensions \
+"