summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-rasa/python3-s3transfer_0.6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-rasa/python3-s3transfer_0.6.1.bb')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-rasa/python3-s3transfer_0.6.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-rasa/python3-s3transfer_0.6.1.bb b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-s3transfer_0.6.1.bb
new file mode 100644
index 00000000..0d72cf48
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-s3transfer_0.6.1.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Amazon S3 Transfer Manager for Python"
+HOMEPAGE = "https://github.com/boto/s3transfer"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI = "\
+ git://github.com/boto/s3transfer.git;protocol=https;branch=master \
+ "
+
+PV = "0.6.1+git${SRCPV}"
+S = "${WORKDIR}/git"
+SRCREV = "f53a45d286834799207c4e225f3676bfa8eb4e1a"
+
+DEPENDS += "\
+ python3-botocore \
+ python3-urllib3 \
+ "
+
+inherit setuptools3
+
+RDEPENDS:${PN} += "\
+ python3-botocore \
+ python3-urllib3 \
+ "