summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-rasa/python3-twilio_8.2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-rasa/python3-twilio_8.2.2.bb')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-rasa/python3-twilio_8.2.2.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-rasa/python3-twilio_8.2.2.bb b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-twilio_8.2.2.bb
new file mode 100644
index 00000000..36d0258d
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-twilio_8.2.2.bb
@@ -0,0 +1,27 @@
+SUMMARY = "A Python module for communicating with the Twilio API and generating TwiML."
+HOMEPAGE = "https://github.com/twilio/twilio-python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=98e410977eaccb4352beb8e4048b421e"
+
+PYPI_PACKAGE = "twilio"
+
+SRC_URI[md5sum] = "1dfe879f10e0919b21d77d8ed9252039"
+SRC_URI[sha256sum] = "6470a8bb6b1e240dd48c77f17e29fc1ee9041b75707bf437f880a585b6c722bc"
+
+DEPENDS += " \
+ python3-pytz \
+ python3-requests \
+ python3-pyjwt \
+ python3-aiohttp \
+ python3-aiohttp-retry \
+ "
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-pytz \
+ python3-requests \
+ python3-pyjwt \
+ python3-aiohttp \
+ python3-aiohttp-retry \
+ "