summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-snips-nlu-parsers_0.4.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-snips-nlu-parsers_0.4.3.bb')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-snips-nlu-parsers_0.4.3.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-snips-nlu-parsers_0.4.3.bb b/meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-snips-nlu-parsers_0.4.3.bb
new file mode 100644
index 00000000..d7ced8eb
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-snips-nlu-parsers_0.4.3.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Python wrapper of the snips-nlu-parsers Rust crate"
+HOMEPAGE = "https://github.com/snipsco/snips-nlu-parsers"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = " \
+ file://../LICENSE-APACHE;md5=1836efb2eb779966696f473ee8540542 \
+ file://../LICENSE-MIT;md5=b377b220f43d747efdec40d69fcaa69d \
+ "
+
+SRC_URI += " \
+ git://github.com/snipsco/snips-nlu-parsers;protocol=https;branch=master \
+ "
+
+PV = "0.4.3+git${SRCPV}"
+SRCREV = "8cfdae50437732fcf906af90626c8db196729d30"
+S = "${WORKDIR}/git/python"
+
+DEPENDS += "python3-future python3-setuptools-rust-native"
+
+require ${BPN}-crates.inc
+
+inherit cargo python_setuptools3_rust
+
+do_compile[network] = "1"
+
+RDEPENDS:${PN} += "python3-future"