summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-python')
-rw-r--r--meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-python/llvmlite/files/LICENSE24
-rw-r--r--meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-python/llvmlite/llvmlite_0.43.0.bb34
-rw-r--r--meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-python/numba/python3-numba_%.bbappend6
-rw-r--r--meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-python/pytorch/python3-pytorch_%.bbappend7
-rw-r--r--meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-python/tiktoken/python3-tiktoken-crates.inc100
-rw-r--r--meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-python/tiktoken/python3-tiktoken_0.7.0.bb21
6 files changed, 192 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-python/llvmlite/files/LICENSE b/meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-python/llvmlite/files/LICENSE
new file mode 100644
index 00000000..8e94a016
--- /dev/null
+++ b/meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-python/llvmlite/files/LICENSE
@@ -0,0 +1,24 @@
+Copyright (c) 2014-, Continuum Analytics, Inc.
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are
+met:
+
+Redistributions of source code must retain the above copyright notice,
+this list of conditions and the following disclaimer.
+
+Redistributions in binary form must reproduce the above copyright
+notice, this list of conditions and the following disclaimer in the
+documentation and/or other materials provided with the distribution.
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-python/llvmlite/llvmlite_0.43.0.bb b/meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-python/llvmlite/llvmlite_0.43.0.bb
new file mode 100644
index 00000000..e34abd59
--- /dev/null
+++ b/meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-python/llvmlite/llvmlite_0.43.0.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "llvmlite prebuilt binary"
+HOMEPAGE = "https://github.com/numba/llvmlite"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=a15ea9843f27327e08f3c5fbf8043a2b"
+
+SRCURIWHEEL:aarch64 += "https://files.pythonhosted.org/packages/bf/f1/4c205a48488e574ee9f6505d50e84370a978c90f08dab41a42d8f2c576b6/llvmlite-0.43.0-cp312-cp312-manylinux_2_17_aarch64.manylinux2014_aarch64.whl"
+SRCURIWHEEL:x86-64 += "https://files.pythonhosted.org/packages/00/5f/323c4d56e8401c50185fd0e875fcf06b71bf825a863699be1eb10aa2a9cb/llvmlite-0.43.0-cp312-cp312-manylinux_2_17_x86_64.manylinux2014_x86_64.whl"
+SRC_URI = " ${SRCURIWHEEL} "
+SRC_URI:append = " file://LICENSE "
+
+SRCURICHECKSUM:x86-64 = "df6509e1507ca0760787a199d19439cc887bfd82226f5af746d6977bd9f66844"
+SRCURICHECKSUM:aarch64 = "eccce86bba940bae0d8d48ed925f21dbb813519169246e2ab292b5092aba121f"
+SRC_URI[sha256sum] = "${SRCURICHECKSUM}"
+
+COMPATIBLE_MACHINE = "null"
+COMPATIBLE_MACHINE:aarch64 = "(.*)"
+COMPATIBLE_MACHINE:x86-64 = "(.*)"
+
+DEPENDS += " unzip-native"
+
+RDEPENDS:${PN} += " zlib"
+
+do_install() {
+ mkdir -p ${WORKDIR}/llvmlite-0.43.0
+ unzip ${WORKDIR}/$(basename ${SRC_URI}) -d ${WORKDIR}/llvmlite-0.43.0
+ install -d ${D}/usr/lib/python3.12/site-packages
+ cp -R ${WORKDIR}/llvmlite-0.43.0/* ${D}/usr/lib/python3.12/site-packages/
+}
+
+do_configure:prepend() {
+ export LD_LIBRARY_PATH="${D}/usr/lib/python3.12/site-packages/llvmlite/binding:${LD_LIBRARY_PATH}"
+}
+
+FILES:${PN} += "/usr/lib/python3.12/site-packages/* "
diff --git a/meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-python/numba/python3-numba_%.bbappend b/meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-python/numba/python3-numba_%.bbappend
new file mode 100644
index 00000000..4bc055b5
--- /dev/null
+++ b/meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-python/numba/python3-numba_%.bbappend
@@ -0,0 +1,6 @@
+# remove the python3-llvmlite present in the meta-python-ai because it requires LLVM 15 to compile but AGL is using LLVM 18 rn
+RDEPENDS:${PN}:remove = "python3-llvmlite"
+
+# adding a precompile wheel for llvmlite-0.43.0 for x86_64 only
+RDEPENDS:${PN} += "llvmlite"
+
diff --git a/meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-python/pytorch/python3-pytorch_%.bbappend b/meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-python/pytorch/python3-pytorch_%.bbappend
new file mode 100644
index 00000000..6a971f70
--- /dev/null
+++ b/meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-python/pytorch/python3-pytorch_%.bbappend
@@ -0,0 +1,7 @@
+# pytorch_%.bbappend
+
+DEPENDS:remove = "gloo"
+
+EXTRA_OECMAKE:remove = "-DUSE_SYSTEM_GLOO=ON"
+
+RDEPENDS:${PN}:remove = "python3-onnx"
diff --git a/meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-python/tiktoken/python3-tiktoken-crates.inc b/meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-python/tiktoken/python3-tiktoken-crates.inc
new file mode 100644
index 00000000..1b4d3588
--- /dev/null
+++ b/meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-python/tiktoken/python3-tiktoken-crates.inc
@@ -0,0 +1,100 @@
+# Autogenerated with 'bitbake -c update_crates python3-tiktoken'
+
+# from Cargo.lock
+SRC_URI += " \
+ crate://crates.io/aho-corasick/1.1.3 \
+ crate://crates.io/autocfg/1.3.0 \
+ crate://crates.io/bit-set/0.5.3 \
+ crate://crates.io/bit-vec/0.6.3 \
+ crate://crates.io/bitflags/2.5.0 \
+ crate://crates.io/bstr/1.9.1 \
+ crate://crates.io/cfg-if/1.0.0 \
+ crate://crates.io/fancy-regex/0.11.0 \
+ crate://crates.io/heck/0.4.1 \
+ crate://crates.io/indoc/2.0.5 \
+ crate://crates.io/libc/0.2.155 \
+ crate://crates.io/lock_api/0.4.12 \
+ crate://crates.io/memchr/2.7.2 \
+ crate://crates.io/memoffset/0.9.1 \
+ crate://crates.io/once_cell/1.19.0 \
+ crate://crates.io/parking_lot/0.12.3 \
+ crate://crates.io/parking_lot_core/0.9.10 \
+ crate://crates.io/portable-atomic/1.6.0 \
+ crate://crates.io/proc-macro2/1.0.84 \
+ crate://crates.io/pyo3/0.20.3 \
+ crate://crates.io/pyo3-build-config/0.20.3 \
+ crate://crates.io/pyo3-ffi/0.20.3 \
+ crate://crates.io/pyo3-macros/0.20.3 \
+ crate://crates.io/pyo3-macros-backend/0.20.3 \
+ crate://crates.io/quote/1.0.36 \
+ crate://crates.io/redox_syscall/0.5.1 \
+ crate://crates.io/regex/1.10.4 \
+ crate://crates.io/regex-automata/0.4.6 \
+ crate://crates.io/regex-syntax/0.8.3 \
+ crate://crates.io/rustc-hash/1.1.0 \
+ crate://crates.io/scopeguard/1.2.0 \
+ crate://crates.io/serde/1.0.203 \
+ crate://crates.io/serde_derive/1.0.203 \
+ crate://crates.io/smallvec/1.13.2 \
+ crate://crates.io/syn/2.0.66 \
+ crate://crates.io/target-lexicon/0.12.14 \
+ crate://crates.io/unicode-ident/1.0.12 \
+ crate://crates.io/unindent/0.2.3 \
+ crate://crates.io/windows-targets/0.52.5 \
+ crate://crates.io/windows_aarch64_gnullvm/0.52.5 \
+ crate://crates.io/windows_aarch64_msvc/0.52.5 \
+ crate://crates.io/windows_i686_gnu/0.52.5 \
+ crate://crates.io/windows_i686_gnullvm/0.52.5 \
+ crate://crates.io/windows_i686_msvc/0.52.5 \
+ crate://crates.io/windows_x86_64_gnu/0.52.5 \
+ crate://crates.io/windows_x86_64_gnullvm/0.52.5 \
+ crate://crates.io/windows_x86_64_msvc/0.52.5 \
+"
+
+SRC_URI[aho-corasick-1.1.3.sha256sum] = "8e60d3430d3a69478ad0993f19238d2df97c507009a52b3c10addcd7f6bcb916"
+SRC_URI[autocfg-1.3.0.sha256sum] = "0c4b4d0bd25bd0b74681c0ad21497610ce1b7c91b1022cd21c80c6fbdd9476b0"
+SRC_URI[bit-set-0.5.3.sha256sum] = "0700ddab506f33b20a03b13996eccd309a48e5ff77d0d95926aa0210fb4e95f1"
+SRC_URI[bit-vec-0.6.3.sha256sum] = "349f9b6a179ed607305526ca489b34ad0a41aed5f7980fa90eb03160b69598fb"
+SRC_URI[bitflags-2.5.0.sha256sum] = "cf4b9d6a944f767f8e5e0db018570623c85f3d925ac718db4e06d0187adb21c1"
+SRC_URI[bstr-1.9.1.sha256sum] = "05efc5cfd9110c8416e471df0e96702d58690178e206e61b7173706673c93706"
+SRC_URI[cfg-if-1.0.0.sha256sum] = "baf1de4339761588bc0619e3cbc0120ee582ebb74b53b4efbf79117bd2da40fd"
+SRC_URI[fancy-regex-0.11.0.sha256sum] = "b95f7c0680e4142284cf8b22c14a476e87d61b004a3a0861872b32ef7ead40a2"
+SRC_URI[heck-0.4.1.sha256sum] = "95505c38b4572b2d910cecb0281560f54b440a19336cbbcb27bf6ce6adc6f5a8"
+SRC_URI[indoc-2.0.5.sha256sum] = "b248f5224d1d606005e02c97f5aa4e88eeb230488bcc03bc9ca4d7991399f2b5"
+SRC_URI[libc-0.2.155.sha256sum] = "97b3888a4aecf77e811145cadf6eef5901f4782c53886191b2f693f24761847c"
+SRC_URI[lock_api-0.4.12.sha256sum] = "07af8b9cdd281b7915f413fa73f29ebd5d55d0d3f0155584dade1ff18cea1b17"
+SRC_URI[memchr-2.7.2.sha256sum] = "6c8640c5d730cb13ebd907d8d04b52f55ac9a2eec55b440c8892f40d56c76c1d"
+SRC_URI[memoffset-0.9.1.sha256sum] = "488016bfae457b036d996092f6cb448677611ce4449e970ceaf42695203f218a"
+SRC_URI[once_cell-1.19.0.sha256sum] = "3fdb12b2476b595f9358c5161aa467c2438859caa136dec86c26fdd2efe17b92"
+SRC_URI[parking_lot-0.12.3.sha256sum] = "f1bf18183cf54e8d6059647fc3063646a1801cf30896933ec2311622cc4b9a27"
+SRC_URI[parking_lot_core-0.9.10.sha256sum] = "1e401f977ab385c9e4e3ab30627d6f26d00e2c73eef317493c4ec6d468726cf8"
+SRC_URI[portable-atomic-1.6.0.sha256sum] = "7170ef9988bc169ba16dd36a7fa041e5c4cbeb6a35b76d4c03daded371eae7c0"
+SRC_URI[proc-macro2-1.0.84.sha256sum] = "ec96c6a92621310b51366f1e28d05ef11489516e93be030060e5fc12024a49d6"
+SRC_URI[pyo3-0.20.3.sha256sum] = "53bdbb96d49157e65d45cc287af5f32ffadd5f4761438b527b055fb0d4bb8233"
+SRC_URI[pyo3-build-config-0.20.3.sha256sum] = "deaa5745de3f5231ce10517a1f5dd97d53e5a2fd77aa6b5842292085831d48d7"
+SRC_URI[pyo3-ffi-0.20.3.sha256sum] = "62b42531d03e08d4ef1f6e85a2ed422eb678b8cd62b762e53891c05faf0d4afa"
+SRC_URI[pyo3-macros-0.20.3.sha256sum] = "7305c720fa01b8055ec95e484a6eca7a83c841267f0dd5280f0c8b8551d2c158"
+SRC_URI[pyo3-macros-backend-0.20.3.sha256sum] = "7c7e9b68bb9c3149c5b0cade5d07f953d6d125eb4337723c4ccdb665f1f96185"
+SRC_URI[quote-1.0.36.sha256sum] = "0fa76aaf39101c457836aec0ce2316dbdc3ab723cdda1c6bd4e6ad4208acaca7"
+SRC_URI[redox_syscall-0.5.1.sha256sum] = "469052894dcb553421e483e4209ee581a45100d31b4018de03e5a7ad86374a7e"
+SRC_URI[regex-1.10.4.sha256sum] = "c117dbdfde9c8308975b6a18d71f3f385c89461f7b3fb054288ecf2a2058ba4c"
+SRC_URI[regex-automata-0.4.6.sha256sum] = "86b83b8b9847f9bf95ef68afb0b8e6cdb80f498442f5179a29fad448fcc1eaea"
+SRC_URI[regex-syntax-0.8.3.sha256sum] = "adad44e29e4c806119491a7f06f03de4d1af22c3a680dd47f1e6e179439d1f56"
+SRC_URI[rustc-hash-1.1.0.sha256sum] = "08d43f7aa6b08d49f382cde6a7982047c3426db949b1424bc4b7ec9ae12c6ce2"
+SRC_URI[scopeguard-1.2.0.sha256sum] = "94143f37725109f92c262ed2cf5e59bce7498c01bcc1502d7b9afe439a4e9f49"
+SRC_URI[serde-1.0.203.sha256sum] = "7253ab4de971e72fb7be983802300c30b5a7f0c2e56fab8abfc6a214307c0094"
+SRC_URI[serde_derive-1.0.203.sha256sum] = "500cbc0ebeb6f46627f50f3f5811ccf6bf00643be300b4c3eabc0ef55dc5b5ba"
+SRC_URI[smallvec-1.13.2.sha256sum] = "3c5e1a9a646d36c3599cd173a41282daf47c44583ad367b8e6837255952e5c67"
+SRC_URI[syn-2.0.66.sha256sum] = "c42f3f41a2de00b01c0aaad383c5a45241efc8b2d1eda5661812fda5f3cdcff5"
+SRC_URI[target-lexicon-0.12.14.sha256sum] = "e1fc403891a21bcfb7c37834ba66a547a8f402146eba7265b5a6d88059c9ff2f"
+SRC_URI[unicode-ident-1.0.12.sha256sum] = "3354b9ac3fae1ff6755cb6db53683adb661634f67557942dea4facebec0fee4b"
+SRC_URI[unindent-0.2.3.sha256sum] = "c7de7d73e1754487cb58364ee906a499937a0dfabd86bcb980fa99ec8c8fa2ce"
+SRC_URI[windows-targets-0.52.5.sha256sum] = "6f0713a46559409d202e70e28227288446bf7841d3211583a4b53e3f6d96e7eb"
+SRC_URI[windows_aarch64_gnullvm-0.52.5.sha256sum] = "7088eed71e8b8dda258ecc8bac5fb1153c5cffaf2578fc8ff5d61e23578d3263"
+SRC_URI[windows_aarch64_msvc-0.52.5.sha256sum] = "9985fd1504e250c615ca5f281c3f7a6da76213ebd5ccc9561496568a2752afb6"
+SRC_URI[windows_i686_gnu-0.52.5.sha256sum] = "88ba073cf16d5372720ec942a8ccbf61626074c6d4dd2e745299726ce8b89670"
+SRC_URI[windows_i686_gnullvm-0.52.5.sha256sum] = "87f4261229030a858f36b459e748ae97545d6f1ec60e5e0d6a3d32e0dc232ee9"
+SRC_URI[windows_i686_msvc-0.52.5.sha256sum] = "db3c2bf3d13d5b658be73463284eaf12830ac9a26a90c717b7f771dfe97487bf"
+SRC_URI[windows_x86_64_gnu-0.52.5.sha256sum] = "4e4246f76bdeff09eb48875a0fd3e2af6aada79d409d33011886d3e1581517d9"
+SRC_URI[windows_x86_64_gnullvm-0.52.5.sha256sum] = "852298e482cd67c356ddd9570386e2862b5673c85bd5f88df9ab6802b334c596"
+SRC_URI[windows_x86_64_msvc-0.52.5.sha256sum] = "bec47e5bfd1bff0eeaf6d8b485cc1074891a197ab4225d504cb7a1ab88b02bf0"
diff --git a/meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-python/tiktoken/python3-tiktoken_0.7.0.bb b/meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-python/tiktoken/python3-tiktoken_0.7.0.bb
new file mode 100644
index 00000000..6e5a8f08
--- /dev/null
+++ b/meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-python/tiktoken/python3-tiktoken_0.7.0.bb
@@ -0,0 +1,21 @@
+SUMMARY = "tiktoken is a fast BPE tokeniser for use with OpenAI's models"
+HOMEPAGE = "None"
+AUTHOR = "Shantanu Jain <shantanu@openai.com>"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3794f392e777e4fdf460d9bad404803"
+
+SRC_URI = "https://files.pythonhosted.org/packages/c4/4a/abaec53e93e3ef37224a4dd9e2fc6bb871e7a538c2b6b9d2a6397271daf4/tiktoken-0.7.0.tar.gz"
+SRC_URI[md5sum] = "62b4a9f1953826e61f8e09eb4a51965a"
+SRC_URI[sha256sum] = "1077266e949c24e0291f6c350433c6f0971365ece2b173a23bc3b9f9defef6b6"
+
+require ${BPN}-crates.inc
+
+S = "${WORKDIR}/tiktoken-0.7.0"
+
+DEPENDS += "python3-regex"
+
+RDEPENDS_${PN} = "python3-regex python3-requests python3-urllib3"
+
+inherit cargo setuptools3 python_setuptools3_rust cargo-update-recipe-crates
+
+